]> git.pld-linux.org Git - packages/mono-tools.git/blame_incremental - mono-tools.spec
- fix install
[packages/mono-tools.git] / mono-tools.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without gecko # don't build gecko html renderer
4#
5%include /usr/lib/rpm/macros.mono
6Summary: Mono Tools
7Summary(pl.UTF-8): Narzędzia do mono
8Name: mono-tools
9Version: 2.10
10Release: 2
11License: GPL v2+
12Group: Development/Tools
13# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
14Source0: http://ftp.novell.com/pub/mono/sources/mono-tools/%{name}-%{version}.tar.bz2
15# Source0-md5: da178df2c119c696c08c09dc9eb01994
16Patch0: %{name}-pwd.patch
17URL: http://www.mono-project.com/
18BuildRequires: autoconf
19BuildRequires: automake
20%{?with_gecko:BuildRequires: dotnet-gecko-sharp2-devel >= 0.12}
21BuildRequires: dotnet-gnome-desktop-sharp-devel
22BuildRequires: dotnet-gnome-sharp-devel >= 2.16.0
23BuildRequires: dotnet-gtk-sharp2-devel
24BuildRequires: dotnet-webkit-sharp-devel >= 0.2-1
25BuildRequires: gettext-devel
26BuildRequires: glib2-devel
27BuildRequires: libgdiplus
28BuildRequires: mono-compat-links
29BuildRequires: mono-csharp
30BuildRequires: mono-devel >= 2.10
31BuildRequires: mono-monodoc >= 2.10
32BuildRequires: pkgconfig
33BuildRequires: rpmbuild(monoautodeps)
34BuildRequires: sed >= 4.0
35Requires: mono >= 2.10
36Requires: mono-tools-html-renderer
37ExcludeArch: i386
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41Mono Tools is a collection of development and testing programs and
42utilities for use with Mono.
43
44%description -l pl.UTF-8
45Mono Tools jest kolekcją rozwojowych i testowych programów oraz
46narzędzi do użycia z Mono.
47
48%package gecko
49Summary: Gecko based monodoc HTML renderer
50Summary(pl.UTF-8): Oparty na gecko wyświetlacz HTML-a dla monodoc
51Group: Development/Tools
52Requires: %{name} = %{version}-%{release}
53Provides: mono-tools-html-renderer
54
55%description gecko
56Gecko based monodoc HTML renderer.
57
58%description gecko -l pl.UTF-8
59Oparty na gecko wyświetlacz HTML-a dla monodoc.
60
61%package webkit
62Summary: WebKit based monodoc HTML renderer
63Summary(pl.UTF-8): Oparty na WebKit wyświetlacz HTML-a dla monodoc
64Group: Development/Tools
65Requires: %{name} = %{version}-%{release}
66Provides: mono-tools-html-renderer
67
68%description webkit
69WebKit based monodoc HTML renderer.
70
71%description webkit -l pl.UTF-8
72Oparty na WebKit wyświetlacz HTML-a dla monodoc.
73
74%package monowebbrowser
75Summary: Mono.WebBrowser based monodoc HTML renderer
76Summary(pl.UTF-8): Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc
77Group: Development/Tools
78Requires: %{name} = %{version}-%{release}
79Provides: mono-tools-html-renderer
80
81%description monowebbrowser
82Mono.WebBrowser based monodoc HTML renderer.
83
84%description monowebbrowser -l pl.UTF-8
85Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc.
86
87%package gtkhtml
88Summary: GtkHTML based monodoc HTML renderer
89Summary(pl.UTF-8): Oparty na GtkHTML wyświetlacz HTML-a dla monodoc
90Group: Development/Tools
91Requires: %{name} = %{version}-%{release}
92Provides: mono-tools-html-renderer
93
94%description gtkhtml
95GtkHTML based monodoc HTML renderer.
96
97%description gtkhtml -l pl.UTF-8
98Oparty na GtkHTML wyświetlacz HTML-a dla monodoc.
99
100%package gendarme
101Summary: A tool to find problems in .NET applications and libraries
102Summary(pl.UTF-8): Narzędzie znajdujące problemy w aplikacjach i bibliotekach .NET
103Group: Development/Tools
104Requires: monodoc >= 2.10
105
106%description gendarme
107Gendarme is a extensible rule-based tool to find problems in .NET
108applications and libraries. Gendarme inspects programs and libraries
109that contain code in ECMA CIL format (Mono and .NET) and looks for
110common problems with the code, problems that compiler do not typically
111check or have not historically checked.
112
113%description gendarme -l pl.UTF-8
114Gendarme to rozszerzalne narzędzie oparte o regułki, znajdujące
115problemy w aplikacjach i bibliotekach .NET. Gendarme przeprowadza
116inspekcję programów i bibliotek w formacie ECMA CIL (Mono i .NET)
117szukając typowych problemów, których często kompilator nie sprawdza,
118lub tych które nie były kiedyś sprawdzane.
119
120%package gui-compare
121Summary: Compares API changes between different assemblies
122Summary(pl.UTF-8): Porównuje zmiany API między różnymi assembly
123Group: Development/Tools
124
125%description gui-compare
126Compares API changes between different assemblies.
127
128%description gui-compare -l pl.UTF-8
129Porównuje zmiany API między różnymi assembly.
130
131%package mprof-decoder
132Summary: Console decoder for the logging profiler output files
133Summary(pl.UTF-8): Konsolowy dekoder dla plików tworzonych przez logujący profiler
134Group: Development/Tools
135
136%description mprof-decoder
137Decodes the contents of a logging profiler output file and prints the
138data on standard output.
139
140%description mprof-decoder -l pl.UTF-8
141Dekoduje zawartość pliku wynikowego profilera logującego i wypisuje
142dane na standardowe wyjście.
143
144%package mprof-heap-viewer
145Summary: GUI viewer for the logging profiler heap snapshots
146Summary(pl.UTF-8): Narzędzie do oglądania migawek sterty profilera logującego
147Group: Development/Tools
148
149%description mprof-heap-viewer
150This program decodes the contents of a logging profiler output file
151and locates all the heap snapshots inside it. The user can then select
152each individual snapshot and decide to load it in memory and explore
153its contents.
154
155%description mprof-heap-viewer -l pl.UTF-8
156Ten program dekoduje plik wynikowy profilera logującego i lokalizuje
157wszystkie znajdujące się w nim migawki sterty. Umożliwia wybranie
158dowolnej migawki i załadowanie jej do pamięci w celu obejrzenia
159zawartości.
160
161%prep
162%setup -q
163%patch0 -p1
164
165# as expected by ilcontrast script
166%{__sed} -i -e 's,\$(libdir)/ilcontrast,$(prefix)/lib/ilcontrast,' ilcontrast/Makefile.am
167
168# mono-2.8 path for gasnview.exe
169%{__sed} -i -e 's,mono/1.0,mono/2.0,' asn1view/gtk/Makefile.am
170
171%build
172%{__aclocal}
173%{__autoconf}
174%{__automake}
175%configure
176%{__make} -j1
177
178%install
179rm -rf $RPM_BUILD_ROOT
180
181%{__make} install \
182 DESTDIR=$RPM_BUILD_ROOT \
183 pkglibdir=%{_prefix}/lib/mono-tools \
184 pkgconfigdir=%{_pkgconfigdir}
185
186%find_lang %{name}
187
188%clean
189rm -rf $RPM_BUILD_ROOT
190
191%files -f %{name}.lang
192%defattr(644,root,root,755)
193%doc AUTHORS ChangeLog README
194%attr(755,root,root) %{_bindir}/create-native-map
195%attr(755,root,root) %{_bindir}/emveepee
196%attr(755,root,root) %{_bindir}/gasnview
197%attr(755,root,root) %{_bindir}/gsharp
198%attr(755,root,root) %{_bindir}/minvoke
199%attr(755,root,root) %{_bindir}/monodoc
200%attr(755,root,root) %{_bindir}/mperfmon
201%dir %{_prefix}/lib/gsharp
202%attr(755,root,root) %{_prefix}/lib/gsharp/gsharp.exe
203%{_prefix}/lib/gsharp/gsharp.exe.config
204%attr(755,root,root) %{_prefix}/lib/mono/2.0/gasnview.exe
205%{_prefix}/lib/create-native-map
206%dir %{_prefix}/lib/minvoke
207%attr(755,root,root) %{_prefix}/lib/minvoke/minvoke.exe
208%dir %{_prefix}/lib/mperfmon
209%{_prefix}/lib/mperfmon/config
210%attr(755,root,root) %{_prefix}/lib/mperfmon/mperfmon.exe
211%dir %{_prefix}/lib/mono-tools
212%{_prefix}/lib/mono-tools/Mono.Profiler.Widgets.dll
213%exclude %{_prefix}/lib/mono-tools/Mono.Profiler.Widgets.dll.mdb
214%attr(755,root,root) %{_prefix}/lib/mono-tools/emveepee.exe
215%exclude %{_prefix}/lib/mono-tools/emveepee.exe.mdb
216%attr(755,root,root) %{_prefix}/lib/monodoc/browser.exe
217%{_prefix}/lib/monodoc/web
218%{_desktopdir}/gsharp.desktop
219%{_desktopdir}/monodoc.desktop
220%{_pixmapsdir}/monodoc.png
221%{_pkgconfigdir}/create-native-map.pc
222%{_mandir}/man1/create-native-map.1*
223%{_mandir}/man1/mperfmon.1*
224
225%if %{with gecko}
226%files gecko
227%defattr(644,root,root,755)
228%attr(755,root,root) %{_bindir}/ilcontrast
229%{_prefix}/lib/ilcontrast
230%{_prefix}/lib/monodoc/GeckoHtmlRender.dll
231%{_desktopdir}/ilcontrast.desktop
232%{_pixmapsdir}/ilcontrast.png
233%endif
234
235%files webkit
236%defattr(644,root,root,755)
237%{_prefix}/lib/monodoc/WebKitHtmlRender.dll
238
239%files monowebbrowser
240%defattr(644,root,root,755)
241%{_prefix}/lib/monodoc/MonoWebBrowserHtmlRender.dll
242
243%files gtkhtml
244%defattr(644,root,root,755)
245%{_prefix}/lib/monodoc/GtkHtmlHtmlRender.dll
246
247%files gendarme
248%defattr(644,root,root,755)
249%attr(755,root,root) %{_bindir}/gd2i
250%attr(755,root,root) %{_bindir}/gendarme
251%attr(755,root,root) %{_bindir}/gendarme-wizard
252%{_prefix}/lib/gendarme
253%{_prefix}/lib/monodoc/sources/Gendarme*
254%{_prefix}/lib/monodoc/sources/gendarme*
255%{_desktopdir}/gendarme-wizard.desktop
256%{_pkgconfigdir}/gendarme-framework.pc
257%{_pixmapsdir}/gendarme.svg
258%{_mandir}/man1/gd2i.1*
259%{_mandir}/man1/gendarme.1*
260%{_mandir}/man5/gendarme.5*
261
262%files gui-compare
263%defattr(644,root,root,755)
264%attr(755,root,root) %{_bindir}/gui-compare
265%{_prefix}/lib/gui-compare
266
267%files mprof-decoder
268%defattr(644,root,root,755)
269%attr(755,root,root) %{_bindir}/mprof-decoder
270%{_prefix}/lib/mono-tools/mprof-decoder-library.*
271%{_prefix}/lib/mono-tools/mprof-decoder.*
272%{_mandir}/man1/mprof-decoder.1*
273
274%files mprof-heap-viewer
275%defattr(644,root,root,755)
276%attr(755,root,root) %{_bindir}/mprof-heap-viewer
277%{_prefix}/lib/mono-tools/mprof-heap-snapshot-explorer.*
278%{_prefix}/lib/mono-tools/mprof-heap-viewer.*
279%{_mandir}/man1/mprof-heap-viewer.1*
This page took 0.057449 seconds and 4 git commands to generate.