]> git.pld-linux.org Git - packages/memcached.git/blame_incremental - memcached.spec
add link to release notes
[packages/memcached.git] / memcached.spec
... / ...
CommitLineData
1#
2# NOTE
3# - release notes: https://code.google.com/p/memcached/wiki/ReleaseNotes
4
5# Conditional build:
6%bcond_with repcached # repcached support, http://repcached.lab.klab.org/
7
8Summary: A high-performance, distributed memory object caching system
9Summary(pl.UTF-8): Rozproszony, wysokiej wydajności system cache'owania obiektów
10Name: memcached
11Version: 1.4.15
12Release: 1
13License: BSD
14Group: Networking/Daemons
15Source0: http://memcached.googlecode.com/files/%{name}-%{version}.tar.gz
16# Source0-md5: 36ea966f5a29655be1746bf4949f7f69
17Source1: %{name}.init
18Source2: %{name}.sysconfig
19Source3: %{name}.tmpfiles
20URL: http://memcached.org/
21Patch0: repcached.patch
22BuildRequires: autoconf
23BuildRequires: automake
24BuildRequires: libevent-devel >= 1.1
25BuildRequires: rpmbuild(macros) >= 1.268
26BuildRequires: sed >= 4.0
27Requires(post,preun): /sbin/chkconfig
28Requires(postun): /usr/sbin/groupdel
29Requires(postun): /usr/sbin/userdel
30Requires(pre): /bin/id
31Requires(pre): /usr/bin/getgid
32Requires(pre): /usr/sbin/groupadd
33Requires(pre): /usr/sbin/useradd
34Requires: rc-scripts >= 0.4.1.23
35Provides: group(memcached)
36Provides: user(memcached)
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40A high-performance, distributed memory object caching system.
41
42%description -l pl.UTF-8
43Rozproszony, wysokiej wydajności system cache'owania obiektów.
44
45%prep
46%setup -q
47%{?with_repcached:%patch0 -p1}
48
49sed -nie '1,/^$/p' ChangeLog
50
51%build
52%{__aclocal}
53%{__autoconf}
54%{__autoheader}
55%{__automake}
56%configure \
57 %{?with_repcached:--enable-replication} \
58 --disable-coverage
59%{__make}
60
61%install
62rm -rf $RPM_BUILD_ROOT
63install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig},/var/run/memcached} \
64 $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man1} \
65 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
66
67install -p memcached $RPM_BUILD_ROOT%{_sbindir}
68cp -p doc/memcached.1 $RPM_BUILD_ROOT%{_mandir}/man1
69
70install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
71cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
72
73install %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
74
75%pre
76%groupadd -g 209 %{name}
77%useradd -u 209 -d /usr/share/empty -g %{name} -c "Memcached Daemon" %{name}
78
79%post
80/sbin/chkconfig --add %{name}
81%service %{name} restart
82
83%preun
84if [ "$1" = "0" ]; then
85 %service -q %{name} stop
86 /sbin/chkconfig --del %{name}
87fi
88
89%postun
90if [ "$1" = "0" ]; then
91 %userremove %{name}
92 %groupremove %{name}
93fi
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%files
99%defattr(644,root,root,755)
100%doc AUTHORS README.md ChangeLog doc/*.txt
101%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
102%attr(754,root,root) /etc/rc.d/init.d/%{name}
103%attr(755,root,root) %{_sbindir}/%{name}
104%{_mandir}/man1/memcached.1*
105%dir %attr(770,root,memcached) /var/run/memcached
106%{systemdtmpfilesdir}/%{name}.conf
This page took 0.069336 seconds and 4 git commands to generate.