]> git.pld-linux.org Git - packages/lighttpd.git/blame_incremental - lighttpd.spec
- fixes infinite loop on slow connection over SSL
[packages/lighttpd.git] / lighttpd.spec
... / ...
CommitLineData
1# TODO:
2# - test ldap and mysql (failed at this time)
3# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
4# - fam over gamin is possible, just configure doesn't check other than gamin
5# - lua50 isn't properly detected
6#
7# NOTES:
8# - fcgi-devel is only used for the test-scripts
9# - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
10# see http://article.gmane.org/gmane.comp.web.lighttpd:722
11# - please make subpackages of modules that depend other modules than:
12# - pcre (core binary needs it too)
13# - openssl (core binary needs it too)
14#
15# Conditional build for lighttpd:
16%bcond_without xattr # support of extended attributes
17%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
18%bcond_without largefile # largefile support (see notes above)
19%bcond_without ssl # ssl support
20%bcond_with mysql # mysql support in mod_mysql_vhost
21%bcond_with ldap # ldap support in mod_auth
22%bcond_with lua # LUA support in mod_cml
23%bcond_with memcache # memcached support in mod_cml / mod_trigger_b4_dl
24%bcond_with gamin # gamin for reducing number of stat() calls. NOTE: must be enabled in config: server.stat-cache-engine = "fam"
25%bcond_with gdbm # gdbm in mod_trigger_b4_dl
26%bcond_with webdav_props # properties in mod_webdav (includes extra sqlite3/libxml deps)
27%bcond_with valgrind # compile code with valgrind support.
28%bcond_with dirhide # with 'hide from dirlisting' hack
29
30# Prerelease snapshot: DATE-TIME
31#define _snap 20050116-1743
32
33%if 0%{?_snap}
34%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
35%else
36%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
37%endif
38
39%define _rel 0.4
40
41Summary: Fast and light HTTP server
42Summary(pl): Szybki i lekki serwer HTTP
43Name: lighttpd
44Version: 1.4.1
45Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
46Group: Networking/Daemons
47License: BSD
48Source0: %{_source}
49# Source0-md5: 3abffbe574fd835721760a37c00d3714
50Source1: %{name}.init
51Source2: %{name}.conf
52Source3: %{name}.user
53Source4: %{name}.logrotate
54Source5: %{name}.sysconfig
55Patch0: http://minghetti.ch/blob/dirlist-hide.patch
56Patch1: %{name}-fcgi-verbose.patch
57Patch2: %{name}-ssl-redirect-fix.patch
58Patch3: %{name}-lua-pkgconfig.patch
59URL: http://www.lighttpd.net/
60%{?with_xattr:BuildRequires: attr-devel}
61BuildRequires: autoconf
62BuildRequires: automake
63BuildRequires: bzip2-devel
64%{?with_gamin:BuildRequires: gamin-devel}
65%{?with_webdav_props:BuildRequires: sqlite3-devel}
66%{?with_webdav_props:BuildRequires: libxml2-devel}
67BuildRequires: libtool
68%{?with_mysql:BuildRequires: mysql-devel}
69%{?with_ldap:BuildRequires: openldap-devel}
70%{?with_ssl:BuildRequires: openssl-devel}
71%{?with_lua:BuildRequires: lua50-devel >= 5.0.2-4.1}
72%{?with_memcache:BuildRequires: libmemcache-devel}
73%{?with_gdbm:BuildRequires: gdbm-devel}
74BuildRequires: pcre-devel
75BuildRequires: rpmbuild(macros) >= 1.202
76%{?debug:BuildRequires: valgrind}
77BuildRequires: zlib-devel
78PreReq: rc-scripts
79Requires(pre): sh-utils
80Requires(pre): /bin/id
81Requires(pre): /usr/bin/getgid
82Requires(pre): /usr/sbin/groupadd
83Requires(pre): /usr/sbin/useradd
84Requires(post,preun): /sbin/chkconfig
85Requires(postun): /usr/sbin/groupdel
86Requires(postun): /usr/sbin/userdel
87Provides: group(lighttpd)
88Provides: httpd
89Provides: user(lighttpd)
90Provides: webserver
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93%define _libdir %{_prefix}/%{_lib}/%{name}
94%define _lighttpddir /home/services/%{name}
95%define _sysconfdir /etc/%{name}
96
97%description
98lighttpd is a secure, fast, compliant and very flexible web-server
99which has been optimized for high-performance environments. It has a
100very low memory footprint compared to other webservers and takes care
101of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
102Output-Compression, URL-Rewriting and many more) make lighttpd the
103perfect webserver-software for every server that is suffering load
104problems.
105
106%description -l pl
107lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
108