]> git.pld-linux.org Git - packages/lighttpd.git/blame_incremental - lighttpd.spec
- fixess for issues #10 and #11
[packages/lighttpd.git] / lighttpd.spec
... / ...
CommitLineData
1#
2# TODO
3# - test ldap and mysql (failed at this time)
4# - documentroot specified in config doesn't exist
5# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
6#
7# Conditional build for lighttpd:
8%bcond_without xattr # without support of extended attributes
9%bcond_with mysql # with mysql
10%bcond_with ldap # with ldap
11%bcond_with valgrind # enable valgrind fixes in code.
12%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
13%bcond_without largefile # without largefile support,
14%bcond_without ssl # disable ssl support
15# use it if you have 2.4 kernel to get sendfile() support,
16# and don't need > 2GB file requests,
17# see http://article.gmane.org/gmane.comp.web.lighttpd:722
18#
19
20# Prerelease snapshot: DATE-TIME
21##define _snap 20050116-1743
22
23%if 0%{?_snap}
24%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
25%else
26%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
27%endif
28
29%define _rel 3
30
31Summary: Fast and light HTTP server
32Summary(pl): Szybki i lekki serwer HTTP
33Name: lighttpd
34Version: 1.3.10
35Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
36Group: Networking/Daemons
37License: BSD
38Source0: %{_source}
39# Source0-md5: 28623eff50653a9b104ddb20fe65aaf1
40Source1: %{name}.init
41Source2: %{name}.conf
42Source3: %{name}.user
43Source4: %{name}.logrotate
44Source5: %{name}.sysconfig
45URL: http://www.lighttpd.net/
46Patch0: %{name}-empty_cgi_handler.patch
47Patch1: %{name}-mod_auth-crash.patch
48Patch2: %{name}-index-file.patch
49BuildRequires: autoconf
50BuildRequires: automake
51BuildRequires: bzip2-devel
52BuildRequires: libtool
53%{?with_ssl:BuildRequires: openssl-devel}
54BuildRequires: pcre-devel
55BuildRequires: rpmbuild(macros) >= 1.159
56BuildRequires: zlib-devel
57%if %{with xattr}
58BuildRequires: attr-devel
59%endif
60%{?with_ldap:BuildRequires: openldap-devel}
61%{?with_mysql:BuildRequires: mysql-devel}
62%{?with_valgrind:BuildRequires: valgrind}
63PreReq: rc-scripts
64Requires(pre): sh-utils
65Requires(pre): /bin/id
66Requires(pre): /usr/bin/getgid
67Requires(pre): /usr/sbin/groupadd
68Requires(pre): /usr/sbin/useradd
69Requires(post,preun): /sbin/chkconfig
70Requires(postun): /usr/sbin/groupdel
71Requires(postun): /usr/sbin/userdel
72Provides: group(lighttpd)
73Provides: httpd
74Provides: user(lighttpd)
75Provides: webserver
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78%define _libdir %{_prefix}/%{_lib}/%{name}
79%define _lighttpddir /home/services/%{name}
80%define _sysconfdir /etc/%{name}
81
82%description
83lighttpd is a secure, fast, compliant and very flexible web-server
84which has been optimized for high-performance environments. It has a
85very low memory footprint compared to other webservers and takes care
86of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
87Output-Compression, URL-Rewriting and many more) make lighttpd the
88perfect webserver-software for every server that is suffering load
89problems.
90
91%description -l pl
92lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
93