]> git.pld-linux.org Git - packages/liferea.git/blame_incremental - liferea.spec
- release 2 (xulrunner 1.8.1.13)
[packages/liferea.git] / liferea.spec
... / ...
CommitLineData
1# TODO:
2# - create subpackage -lua (?)
3# - webkit support
4#
5# Conditional build:
6%bcond_without dbus # without DBUS support
7%bcond_without gtkhtml # without GtkHTML
8%bcond_without xulrunner # without XULRunner backend
9%bcond_without lua # without LUA scripting support
10%bcond_with nm # with NetworkManager support
11#
12%ifarch %{x8664}
13%undefine with_gtkhtml # GtkHTML backend disabled on x86_64
14%endif
15Summary: A RSS feed reader
16Summary(pl.UTF-8): Program do pobierania informacji w formacie RSS
17Name: liferea
18Version: 1.4.13
19Release: 2
20License: GPL v2
21Group: X11/Applications/Networking
22Source0: http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23# Source0-md5: 53940aba8d3499758c68a6283d6fe626
24Patch0: %{name}-desktop.patch
25Patch1: %{name}-xulrunner.patch
26Patch2: %{name}-lua51.patch
27Patch3: %{name}-no_versioned_soname.patch
28URL: http://liferea.sourceforge.net/
29BuildRequires: GConf2-devel >= 2.10.0
30%{?with_nm:BuildRequires: NetworkManager-devel}
31BuildRequires: autoconf >= 2.59
32BuildRequires: automake
33%{?with_dbus:BuildRequires: dbus-glib-devel >= 0.33}
34BuildRequires: gettext-devel
35BuildRequires: gnutls-devel
36BuildRequires: gtk+2-devel >= 2:2.8.0
37BuildRequires: intltool >= 0.35.5
38BuildRequires: libglade2-devel >= 2.0.0
39%{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.6.3}
40BuildRequires: libnotify-devel >= 0.3.2
41BuildRequires: libstdc++-devel
42BuildRequires: libtool
43BuildRequires: libxml2-devel >= 1:2.6.27
44BuildRequires: libxslt-devel >= 1.1.19
45%{?with_lua:BuildRequires: lua51-devel}
46BuildRequires: pkgconfig
47BuildRequires: rpmbuild(macros) >= 1.311
48BuildRequires: sqlite3-devel
49%{?with_xulrunner:BuildRequires: xulrunner-devel}
50Requires(post,postun): gtk+2
51Requires(post,postun): hicolor-icon-theme
52Requires(post,preun): GConf2
53Requires: %{name}-backend = %{version}-%{release}
54%ifarch %{x8664}
55Obsoletes: liferea-gtkhtml
56%endif
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59%define _noautoreqdep libgtkembedmoz.so libxpcom.so
60# we have strict deps for it
61%define _noautoreq libxpcom.so
62
63%description
64Liferea is a GTK+ clone of FeedReader.
65
66%description -l pl.UTF-8
67Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
68FeedReader.
69
70%package gtkhtml
71Summary: GtkHTML module for Liferea
72Summary(pl.UTF-8): Moduł GtkHTML dla Liferea
73Group: X11/Applications/Networking
74Requires: %{name} = %{version}-%{release}
75Provides: %{name}-backend = %{version}-%{release}
76
77%description gtkhtml
78GtkHTML module for Liferea.
79
80%description gtkhtml -l pl.UTF-8
81Moduł GtkHTML dla Liferea.
82
83%package mozilla
84Summary: Mozilla HTML browser module for Liferea
85Summary(pl.UTF-8): Moduł przeglądarki HTML dla Liferea oparty na Mozilli
86Group: X11/Applications/Networking
87Requires: %{name} = %{version}-%{release}
88%requires_eq_to xulrunner xulrunner-devel
89Provides: %{name}-backend = %{version}-%{release}
90
91%description mozilla
92Mozilla HTML browser module for Liferea.
93
94%description mozilla -l pl.UTF-8
95Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
96
97%prep
98%setup -q
99%patch0 -p1
100%patch1 -p1
101%patch2 -p1
102%patch3 -p1
103
104
105%build
106%{__glib_gettextize}
107%{__intltoolize}
108%{__aclocal}
109%{__libtoolize}
110%{__autoheader}
111%{__automake}
112%{__autoconf}
113%configure \
114 --disable-schemas-install \
115 %{!?with_dbus: --disable-dbus} \
116 %{!?with_gtkhtml: --disable-gtkhtml2} \
117 %{!?with_lua: --disable-lua} \
118 %{!?with_nm: --disable-nm} \
119 %{!?with_xulrunner: --disable-xulrunner}
120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124
125%{__make} install \
126 DESTDIR=$RPM_BUILD_ROOT \
127 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
128
129rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
130
131%find_lang %{name}
132
133%post
134%gconf_schema_install liferea.schemas
135%update_icon_cache hicolor
136
137%preun
138%gconf_schema_uninstall liferea.schemas
139
140%postun
141%update_icon_cache hicolor
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files -f %{name}.lang
147%defattr(644,root,root,755)
148%doc AUTHORS ChangeLog NEWS README
149%attr(755,root,root) %{_bindir}/liferea
150%attr(755,root,root) %{_bindir}/liferea-add-feed
151%attr(755,root,root) %{_bindir}/liferea-bin
152%dir %{_libdir}/%{name}
153%attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
154%{_iconsdir}/hicolor/48x48/apps/liferea.png
155%{_sysconfdir}/gconf/schemas/liferea.schemas
156%{_datadir}/%{name}
157%{_desktopdir}/*.desktop
158%{_mandir}/man1/liferea.1*
159%{_mandir}/pl/man1/liferea.1*
160%if %{with lua}
161%attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
162%endif
163
164%if %{with gtkhtml}
165%files gtkhtml
166%defattr(644,root,root,755)
167%attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
168%endif
169
170%if %{with xulrunner}
171%files mozilla
172%defattr(644,root,root,755)
173%attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
174%endif
This page took 0.068186 seconds and 4 git commands to generate.