]> git.pld-linux.org Git - packages/liferea.git/blame_incremental - liferea.spec
- 1.4.16b
[packages/liferea.git] / liferea.spec
... / ...
CommitLineData
1# TODO:
2# - create subpackage -lua (?)
3#
4# Conditional build:
5%bcond_without dbus # without DBUS support
6%bcond_without gtkhtml # without GtkHTML
7%bcond_without xulrunner # without XULRunner backend
8%bcond_without lua # without LUA scripting support
9%bcond_with nm # with NetworkManager support
10%bcond_without webkit # without WebKit backend
11#
12%ifarch %{x8664}
13%undefine with_gtkhtml # GtkHTML backend disabled on x86_64
14%endif
15Summary: A RSS feed reader
16Summary(pl.UTF-8): Program do pobierania informacji w formacie RSS
17Name: liferea
18Version: 1.4.16b
19Release: 1
20License: GPL v2
21Group: X11/Applications/Networking
22Source0: http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23# Source0-md5: b7d8ef4b5d054a7c57e53789d7259edb
24Patch0: %{name}-desktop.patch
25Patch1: %{name}-xulrunner.patch
26Patch2: %{name}-lua51.patch
27URL: http://liferea.sourceforge.net/
28BuildRequires: GConf2-devel >= 2.10.0
29%{?with_nm:BuildRequires: NetworkManager-devel}
30BuildRequires: autoconf >= 2.59
31BuildRequires: automake
32%{?with_dbus:BuildRequires: dbus-glib-devel >= 0.33}
33BuildRequires: gettext-devel
34BuildRequires: gnutls-devel
35BuildRequires: gtk+2-devel >= 2:2.8.0
36%{?with_webkit:BuildRequires: gtk-webkit-devel}
37BuildRequires: intltool >= 0.35.5
38BuildRequires: libglade2-devel >= 2.0.0
39%{?with_gtkhtml:BuildRequires: libgtkhtml-devel >= 2.6.3}
40BuildRequires: libnotify-devel >= 0.3.2
41BuildRequires: libstdc++-devel
42BuildRequires: libtool
43BuildRequires: libxml2-devel >= 1:2.6.27
44BuildRequires: libxslt-devel >= 1.1.19
45%{?with_lua:BuildRequires: lua51-devel}
46BuildRequires: pkgconfig
47BuildRequires: rpmbuild(macros) >= 1.311
48BuildRequires: sed >= 4.0
49BuildRequires: sqlite3-devel
50%{?with_xulrunner:BuildRequires: xulrunner-devel}
51Requires(post,postun): gtk+2
52Requires(post,postun): hicolor-icon-theme
53Requires(post,preun): GConf2
54Requires: %{name}-backend = %{version}-%{release}
55%ifarch %{x8664}
56Obsoletes: liferea-gtkhtml
57%endif
58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60%define _noautoreqdep libgtkembedmoz.so libxpcom.so
61# we have strict deps for it
62%define _noautoreq libxpcom.so
63
64%description
65Liferea is a GTK+ clone of FeedReader.
66
67%description -l pl.UTF-8
68Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
69FeedReader.
70
71%package gtkhtml
72Summary: GtkHTML module for Liferea
73Summary(pl.UTF-8): Moduł GtkHTML dla Liferea
74Group: X11/Applications/Networking
75Requires: %{name} = %{version}-%{release}
76Provides: %{name}-backend = %{version}-%{release}
77
78%description gtkhtml
79GtkHTML module for Liferea.
80
81%description gtkhtml -l pl.UTF-8
82Moduł GtkHTML dla Liferea.
83
84%package mozilla
85Summary: Mozilla HTML browser module for Liferea
86Summary(pl.UTF-8): Moduł przeglądarki HTML dla Liferea oparty na Mozilli
87Group: X11/Applications/Networking
88Requires: %{name} = %{version}-%{release}
89%requires_eq_to xulrunner xulrunner-devel
90Provides: %{name}-backend = %{version}-%{release}
91
92%description mozilla
93Mozilla HTML browser module for Liferea.
94
95%description mozilla -l pl.UTF-8
96Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
97
98%package webkit
99Summary: WebKit module for Liferea
100Summary(pl.UTF-8): Moduł WebKit dla Liferea
101Group: X11/Applications/Networking
102Requires: %{name} = %{version}-%{release}
103Provides: %{name}-backend = %{version}-%{release}
104
105%description webkit
106WebKit module for Liferea.
107
108%description webkit -l pl.UTF-8
109Moduł WebKit dla Liferea.
110
111%prep
112%setup -q
113%patch0 -p1
114%patch1 -p1
115%patch2 -p1
116
117%build
118%{__glib_gettextize}
119%{__intltoolize}
120%{__aclocal}
121%{__libtoolize}
122%{__autoheader}
123%{__automake}
124%{__autoconf}
125%configure \
126 --disable-schemas-install \
127 %{!?with_dbus: --disable-dbus} \
128 %{!?with_gtkhtml: --disable-gtkhtml2} \
129 %{!?with_lua: --disable-lua} \
130 %{!?with_nm: --disable-nm} \
131 %{!?with_xulrunner: --disable-xulrunner} \
132 %{!?with_webkit: --disable-webkit}
133%{__make}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137
138%{__make} install \
139 DESTDIR=$RPM_BUILD_ROOT \
140 GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
141
142rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
143
144%find_lang %{name}
145
146%post
147%gconf_schema_install liferea.schemas
148%update_icon_cache hicolor
149
150%preun
151%gconf_schema_uninstall liferea.schemas
152
153%postun
154%update_icon_cache hicolor
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
159%files -f %{name}.lang
160%defattr(644,root,root,755)
161%doc AUTHORS ChangeLog NEWS README
162%attr(755,root,root) %{_bindir}/liferea
163%attr(755,root,root) %{_bindir}/liferea-add-feed
164%attr(755,root,root) %{_bindir}/liferea-bin
165%dir %{_libdir}/%{name}
166%attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
167%{_iconsdir}/hicolor/48x48/apps/liferea.png
168%{_sysconfdir}/gconf/schemas/liferea.schemas
169%{_datadir}/%{name}
170%{_desktopdir}/*.desktop
171%{_mandir}/man1/liferea.1*
172%{_mandir}/pl/man1/liferea.1*
173%if %{with lua}
174%attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
175%endif
176
177%if %{with gtkhtml}
178%files gtkhtml
179%defattr(644,root,root,755)
180%attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
181%endif
182
183%if %{with xulrunner}
184%files mozilla
185%defattr(644,root,root,755)
186%attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
187%endif
188
189%if %{with webkit}
190%files webkit
191%defattr(644,root,root,755)
192%attr(755,root,root) %{_libdir}/%{name}/liblihtmlw.so
193%endif
This page took 0.065707 seconds and 4 git commands to generate.