]> git.pld-linux.org Git - packages/librsvg.git/blame_incremental - librsvg.spec
- release 2
[packages/librsvg.git] / librsvg.spec
... / ...
CommitLineData
1#
2# Conditional build
3%bcond_without apidocs # disable gtk-doc
4%bcond_without libgsf # build without libgsf (used for run-time decompression)
5%bcond_without libcroco # build without CSS support through libcroco
6%bcond_without static_libs # don't build static library
7#
8Summary: A Raph's Library for Rendering SVG Data
9Summary(pl.UTF-8): Biblioteka Raph's SVG do renderowania danych SVG
10Summary(pt_BR.UTF-8): Biblioteca SVG
11Summary(ru.UTF-8): SVG библиотека
12Summary(uk.UTF-8): SVG бібліотека
13Name: librsvg
14Version: 2.26.0
15Release: 2
16Epoch: 1
17License: LGPL v2+
18Group: X11/Libraries
19Source0: http://ftp.gnome.org/pub/GNOME/sources/librsvg/2.26/%{name}-%{version}.tar.bz2
20# Source0-md5: 65dbd726a514fe8b797d26254b8efc1e
21URL: http://librsvg.sourceforge.net/
22BuildRequires: autoconf
23BuildRequires: automake
24BuildRequires: glib2-devel >= 1:2.16.0
25BuildRequires: gtk+2-devel >= 2:2.12.8
26%{?with_apidocs:BuildRequires: gtk-doc-automake}
27%{?with_apidocs:BuildRequires: gtk-doc >= 1.8}
28%{?with_libcroco:BuildRequires: libcroco-devel >= 0.6.1}
29%{?with_libgsf:BuildRequires: libgsf-devel >= 1.14.4}
30BuildRequires: libtool
31BuildRequires: libxml2-devel >= 1:2.6.31
32BuildRequires: pkgconfig
33BuildRequires: rpm-pythonprov
34Requires(post,postun): /sbin/ldconfig
35Requires(post,postun): gtk+2
36Requires: glib2 >= 1:2.16.0
37Requires: gtk+2 >= 2:2.12.8
38%{?with_libcroco:Requires: libcroco >= 0.6.1}
39%{?with_libgsf:Requires: libgsf >= 1.14.4}
40Requires: libxml2 >= 1:2.6.31
41Obsoletes: browser-plugin-librsvg
42Obsoletes: mozilla-plugin-rsvg
43Obsoletes: librsvg0
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46# see gtk+2.spec for source of these ifdefs
47%if "%{_lib}" != "lib"
48%define libext %(lib="%{_lib}"; echo ${lib#lib})
49%define gtketcdir /etc/gtk%{libext}-2.0
50%define pqext -%{libext}
51%else
52%define gtketcdir /etc/gtk-2.0
53%define pqext %{nil}
54%endif
55
56%description
57An library to render SVG (scalable vector graphics), databased upon
58libart.
59
60%description -l pl.UTF-8
61Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
62na kodzie libart.
63
64%description -l ru.UTF-8
65Библиотека SVG, базирующаяся на libart.
66
67%description -l uk.UTF-8
68Бібліотека SVG, базована на libart.
69
70%package devel
71Summary: Include files for developing with librsvg
72Summary(pl.UTF-8): Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
73Summary(pt_BR.UTF-8): Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
74Summary(ru.UTF-8): Библиотечные линки и файлы заголовков для разработки с librsvg
75Summary(uk.UTF-8): Бібліотечні лінки та файли заголовків для розробки з librsvg
76Group: X11/Development/Libraries
77Requires: %{name} = %{epoch}:%{version}-%{release}
78Requires: glib2-devel >= 1:2.16.0
79Requires: gtk+2-devel >= 2:2.12.8
80%{?with_libcroco:Requires: libcroco-devel >= 0.6.1}
81%{?with_libgsf:Requires: libgsf-devel >= 1.14.4}
82Requires: libxml2-devel >= 1:2.6.31
83Obsoletes: librsvg0-devel
84
85%description devel
86This package provides the necessary development libraries and include
87files to allow you to develop with librsvg.
88
89%description devel -l pl.UTF-8
90Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
91z wykorzystaniem librsvg.
92
93%description devel -l pt_BR.UTF-8
94Este pacote contém os arquivos necessários para desenvolver com base
95na biblioteca librsvg.
96
97%description devel -l ru.UTF-8
98Этот пакет содержит необходимые файлы для разработки программ с
99использованием librsvg.
100
101%description devel -l uk.UTF-8
102Цей пакет містить необхідні файли для розробки програм з використанням
103librsvg.
104
105%package static
106Summary: Static libraries for developing with librsvg
107Summary(es.UTF-8): Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
108Summary(pl.UTF-8): Statyczne biblioteki librsvg
109Summary(pt_BR.UTF-8): Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
110Group: X11/Development/Libraries
111Requires: %{name}-devel = %{epoch}:%{version}-%{release}
112
113%description static
114This package contains static version of librsvg libraries.
115
116%description static -l pl.UTF-8
117Statyczna wersja bibliotek librsvg.
118
119%description static -l pt_BR.UTF-8
120Bibliotecas estáticas para o desenvolvimento de aplicações com
121librsvg.
122
123%package apidocs
124Summary: librsvg API documentation
125Summary(pl.UTF-8): Dokumentacja API biblioteki librsvg
126Group: Documentation
127Requires: gtk-doc-common
128
129%description apidocs
130librsvg API documentation.
131
132%description apidocs -l pl.UTF-8
133Dokumentacja API biblioteki librsvg.
134
135%prep
136%setup -q
137
138%if !%{with apidocs}
139echo 'CLEANFILES=' > gtk-doc.make
140echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
141%endif
142
143%build
144%{__libtoolize}
145%{__aclocal}
146%{__autoconf}
147%{__autoheader}
148%{__automake}
149%configure \
150 --disable-mozilla-plugin \
151 %{!?with_static_libs:--disable-static} \
152 %{?with_apidocs:--enable-gtk-doc} \
153 %{!?with_libcroco:--without-croco} \
154 %{!?with_libgsf:--without-svgz} \
155 --with-html-dir=%{_gtkdocdir}/%{name}
156%{__make}
157
158%install
159rm -rf $RPM_BUILD_ROOT
160
161%{__make} install \
162 DESTDIR=$RPM_BUILD_ROOT \
163 pkgconfigdir=%{_pkgconfigdir}
164
165rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/{engines,loaders}/*.{la,a}
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170%post
171/sbin/ldconfig
172umask 022
173%{_bindir}/gdk-pixbuf-query-loaders%{pqext} > %{gtketcdir}/gdk-pixbuf.loaders
174
175%postun
176/sbin/ldconfig
177umask 022
178if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
179 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} > %{gtketcdir}/gdk-pixbuf.loaders
180fi
181
182%files
183%defattr(644,root,root,755)
184%doc ChangeLog AUTHORS NEWS
185%attr(755,root,root) %{_bindir}/rsvg
186%attr(755,root,root) %{_bindir}/rsvg-convert
187%attr(755,root,root) %{_bindir}/rsvg-view
188%attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
189%attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
190%attr(755,root,root) %{_libdir}/gtk-2.0/2.*/engines/libsvg.so
191%attr(755,root,root) %{_libdir}/gtk-2.0/2.*/loaders/svg_loader.so
192%{_mandir}/man1/rsvg.1*
193%{_pixmapsdir}/svg-viewer.svg
194
195%files devel
196%defattr(644,root,root,755)
197%attr(755,root,root) %{_libdir}/librsvg-2.so
198%{_libdir}/librsvg-2.la
199%{_pkgconfigdir}/librsvg-2.0.pc
200%{_includedir}/librsvg-2
201
202%if %{with static_libs}
203%files static
204%defattr(644,root,root,755)
205%{_libdir}/librsvg-2.a
206%endif
207
208%if %{with apidocs}
209%files apidocs
210%defattr(644,root,root,755)
211%{_gtkdocdir}/%{name}
212%endif
This page took 0.106868 seconds and 4 git commands to generate.