]> git.pld-linux.org Git - packages/libkolabxml.git/blame_incremental - libkolabxml.spec
build with php55
[packages/libkolabxml.git] / libkolabxml.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # build without tests
4%bcond_without php # PHP bindings
5%bcond_without python # Python bindings
6
7%define php_name php55
8Summary: Kolab XML format collection parser library
9Name: libkolabxml
10Version: 1.0.1
11Release: 5
12License: LGPL v3+
13Group: Libraries
14Source0: http://mirror.kolabsys.com/pub/releases/%{name}-%{version}.tar.gz
15# Source0-md5: 7adccfa0ed91ac954c815e8d13f334ee
16URL: http://www.kolab.org/
17BuildRequires: QtCore-devel
18BuildRequires: boost-devel
19BuildRequires: cmake >= 2.6
20BuildRequires: curl-devel
21BuildRequires: e2fsprogs-devel
22BuildRequires: kde4-kdelibs-devel
23BuildRequires: kde4-kdepimlibs-devel
24BuildRequires: libstdc++-devel
25BuildRequires: libuuid-devel
26BuildRequires: qt4-build
27BuildRequires: rpmbuild(macros) >= 1.600
28BuildRequires: swig
29BuildRequires: xerces-c-devel
30BuildRequires: xsd
31%if %{with python}
32BuildRequires: python-devel
33BuildRequires: swig-python
34%endif
35%if %{with php}
36BuildRequires: %{php_name}-devel
37BuildRequires: swig-php
38%endif
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42The libkolabxml parsing library interprets Kolab XML formats (xCal,
43xCard) with bindings for Python, PHP and other languages. The language
44bindings are available through sub-packages.
45
46%package devel
47Summary: Kolab XML library development headers
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: QtCore-devel
51Requires: boost-devel
52Requires: cmake >= 2.6
53Requires: curl-devel
54Requires: e2fsprogs-devel
55Requires: kde4-kdelibs-devel
56Requires: kde4-kdepimlibs-devel
57Requires: libstdc++-devel
58Requires: libuuid-devel
59Requires: swig
60Requires: xerces-c-devel
61Requires: xsd
62
63%description devel
64Development headers for the Kolab XML libraries.
65
66%package -n %{php_name}-kolabformat
67Summary: PHP bindings for libkolabxml
68Group: Development/Languages/PHP
69Requires: %{name} = %{version}-%{release}
70%{?requires_php_extension}
71
72%description -n %{php_name}-kolabformat
73The PHP kolabformat package offers a comprehensible PHP library using
74the bindings provided through libkolabxml.
75
76%package -n python-kolabformat
77Summary: Python bindings for libkolabxml
78Group: Libraries
79Requires: %{name} = %{version}-%{release}
80
81%description -n python-kolabformat
82The PyKolab format package offers a comprehensive Python library using
83the bindings provided through libkolabxml.
84
85%prep
86%setup -q
87
88%build
89install -d build
90cd build
91%cmake \
92 -Wno-fatal-errors -Wno-errors \
93 -DCMAKE_SKIP_RPATH=ON \
94 -DCMAKE_PREFIX_PATH=%{_libdir} \
95 -DINCLUDE_INSTALL_DIR=%{_includedir}/kolabxml \
96 -DLIB_INSTALL_DIR:PATH=%{_libdir} \
97%if %{with php}
98 -DPHP_EXECUTABLE=%{_bindir}/php \
99 -DPHP_BINDINGS=ON \
100 -DPHP_INSTALL_DIR=%{php_extensiondir} \
101%endif
102%if %{with python}
103 -DPYTHON_BINDINGS=ON \
104 -DPYTHON_INCLUDE_DIRS=%{python_include} \
105 -DPYTHON_INSTALL_DIR=%{py_sitedir} \
106%endif
107 ..
108%{__make}
109cd ..
110
111%if %{with tests}
112cd build
113# Make sure libkolabxml.so.* is found, otherwise the tests fail
114export LD_LIBRARY_PATH=$(pwd)/src
115cd tests
116./bindingstest
117./conversiontest
118./parsingtest
119cd ..
120%if %{with php}
121cd src/php
122php -d 'enable_dl=On' '-dextension=../../src/php/kolabformat.so' test.php
123cd ..
124%endif
125%if %{with python}
126cd python
127# FIXME
128%{__python} test.py ||
129cd ..
130%endif
131%endif
132
133%install
134rm -rf $RPM_BUILD_ROOT
135%{__make} -C build install \
136 INSTALL='install -p' \
137 DESTDIR=$RPM_BUILD_ROOT
138
139%if %{with php}
140install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_data_dir}}
141mv $RPM_BUILD_ROOT%{php_extensiondir}/kolabformat.php $RPM_BUILD_ROOT%{php_data_dir}/kolabformat.php
142cat > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/kolabformat.ini <<EOF
143; Enable kolabformat extension module
144extension=kolabformat.so
145EOF
146%endif
147
148%if %{with python}
149%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
150%py_comp $RPM_BUILD_ROOT%{py_sitedir}
151%py_postclean
152%endif
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%post -p /sbin/ldconfig
158%postun -p /sbin/ldconfig
159
160%files
161%defattr(644,root,root,755)
162%doc DEVELOPMENT NEWS README
163%attr(755,root,root) %{_libdir}/libkolabxml.so.*.*
164%attr(755,root,root) %ghost %{_libdir}/libkolabxml.so.1
165
166%files devel
167%defattr(644,root,root,755)
168%{_includedir}/kolabxml
169%{_libdir}/libkolabxml.so
170%{_libdir}/cmake/Libkolabxml
171
172%if %{with php}
173%files -n %{php_name}-kolabformat
174%defattr(644,root,root,755)
175%config(noreplace) %{php_sysconfdir}/conf.d/kolabformat.ini
176%attr(755,root,root) %{php_extensiondir}/kolabformat.so
177%{php_data_dir}/kolabformat.php
178%endif
179
180%if %{with python}
181%files -n python-kolabformat
182%defattr(644,root,root,755)
183%attr(755,root,root) %{py_sitedir}/_kolabformat.so
184%{py_sitedir}/kolabformat.py[co]
185%endif
This page took 0.06718 seconds and 4 git commands to generate.