]> git.pld-linux.org Git - packages/lftp.git/blame_incremental - lftp.spec
- rel 2
[packages/lftp.git] / lftp.spec
... / ...
CommitLineData
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3#
4# Conditional build:
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
12%if %{with gnutls} && %{with ssl}
13%undefine with_openssl
14%endif
15
16Summary: Sophisticated command line FTP/HTTP client
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
21Name: lftp
22Version: 4.0.10
23Release: 2
24License: GPL v3+
25Group: Applications/Networking
26Source0: http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
27# Source0-md5: 3dfd4458e1a72803821de468b77ae536
28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
30Source2: %{name}.desktop
31Source3: %{name}-icon.png
32# outdated and nobody cared for 8+ years... will be dropped
33Patch0: %{name}-home_etc.patch
34Patch1: %{name}-makefile.patch
35# ALWAYS send updated patch to lftp mailing lists
36Patch2: %{name}-pl.po-update.patch
37Patch3: %{name}-m4.patch
38URL: http://lftp.yar.ru/
39BuildRequires: autoconf >= 2.60
40BuildRequires: automake
41BuildRequires: gettext-devel >= 0.14.2
42%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
43BuildRequires: libstdc++-devel
44BuildRequires: libtool >= 1:1.4.2-9
45BuildRequires: ncurses-devel >= 5.2
46%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
47BuildRequires: pkgconfig
48BuildRequires: readline-devel >= 4.2
49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
52%if %{_gcc_ver} == 2
53%define __cxx "%{__cc}"
54%endif
55
56%description
57LFTP is a shell-like command line FTP/HTTP client. The main two
58advantages over other FTP clients are reliability and ability to
59perform tasks in background. It will reconnect and reget the file
60being transferred if the connection broke. You can start a transfer in
61background and continue browsing on the FTP site. It does this all in
62one process. When you have started background jobs and feel you are
63done, you can just exit lftp and it automatically moves to nohup mode
64and completes the transfers. It has also such nice features as reput
65and mirror.
66
67%description -l pl.UTF-8
68Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
69połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
70ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
71połączenia po tym jak się wylogujesz. Program ten honoruje komendy
72powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
73jako aplikacja do mirrorowania serwerów FTP.
74
75%description -l pt_BR.UTF-8
76O lftp é um programa de transferência de arquivos por linha de
77comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
78HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
79tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
80o arquivo FEATURES para uma lista mais detalhada.
81
82%prep
83%setup -q
84#%%patch0 -p1
85%patch1 -p1
86%patch2 -p1
87%patch3 -p1
88
89%{__rm} po/stamp-po
90
91%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
92
93%build
94%{__libtoolize}
95%{__gettextize}
96%{__aclocal} -I m4
97%{__autoconf}
98%{__automake}
99CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
100%configure \
101 --with-modules \
102 --with%{!?with_openssl:out}-openssl \
103 --with%{!?with_gnutls:out}-gnutls
104
105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
110
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
113
114install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
115install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
116install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
117
118bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
119%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
120%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
121
122%find_lang %{name}
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130%files -f %{name}.lang
131%defattr(644,root,root,755)
132%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
133%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
134%attr(755,root,root) %{_bindir}/lftp
135%attr(755,root,root) %{_bindir}/lftpget
136%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
137%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
138%dir %{_libdir}/lftp
139%attr(755,root,root) %{_libdir}/lftp/*.so
140%attr(755,root,root) %{_datadir}/lftp
141%{_mandir}/man1/lftp.1*
142%{_mandir}/man1/lftpget.1*
143%lang(pl) %{_mandir}/pl/man1/lftpget.1*
144%{_mandir}/man5/lftp.conf.5*
145%{_desktopdir}/lftp.desktop
146%{_pixmapsdir}/lftp.png
This page took 0.059141 seconds and 4 git commands to generate.