]> git.pld-linux.org Git - packages/lftp.git/blame_incremental - lftp.spec
- updated to 4.0.3
[packages/lftp.git] / lftp.spec
... / ...
CommitLineData
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3#
4# Conditional build:
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
12%if %{with gnutls} && %{with ssl}
13%undefine with_openssl
14%endif
15
16Summary: Sophisticated command line FTP/HTTP client
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
21Name: lftp
22Version: 4.0.3
23Release: 1
24License: GPL v3+
25Group: Applications/Networking
26Source0: ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.lzma
27# Source0-md5: 2083c6ec38b118f9c3b01c289f9ba0b7
28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
30Source2: %{name}.desktop
31Patch0: %{name}-home_etc.patch
32Patch1: %{name}-makefile.patch
33# ALWAYS send updated patch to lftp mailing lists
34Patch2: %{name}-pl.po-update.patch
35Patch3: %{name}-m4.patch
36URL: http://lftp.yar.ru/
37BuildRequires: autoconf >= 2.60
38BuildRequires: automake
39BuildRequires: gettext-devel >= 0.14.2
40%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
41BuildRequires: libstdc++-devel
42BuildRequires: libtool >= 1:1.4.2-9
43BuildRequires: ncurses-devel >= 5.2
44%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
45BuildRequires: readline-devel >= 4.2
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
49%if %{_gcc_ver} == 2
50%define __cxx "%{__cc}"
51%endif
52
53%description
54LFTP is a shell-like command line FTP/HTTP client. The main two
55advantages over other FTP clients are reliability and ability to
56perform tasks in background. It will reconnect and reget the file
57being transferred if the connection broke. You can start a transfer in
58background and continue browsing on the FTP site. It does this all in
59one process. When you have started background jobs and feel you are
60done, you can just exit lftp and it automatically moves to nohup mode
61and completes the transfers. It has also such nice features as reput
62and mirror.
63
64%description -l pl.UTF-8
65Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
66połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
67ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
68połączenia po tym jak się wylogujesz. Program ten honoruje komendy
69powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
70jako aplikacja do mirrorowania serwerów FTP.
71
72%description -l pt_BR.UTF-8
73O lftp é um programa de transferência de arquivos por linha de
74comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
75HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
76tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
77o arquivo FEATURES para uma lista mais detalhada.
78
79%prep
80%setup -q
81#%%patch0 -p1
82%patch1 -p1
83#%patch2 -p1
84%patch3 -p1
85
86rm -f po/stamp-po
87
88%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
89
90%build
91%{__libtoolize}
92%{__gettextize}
93%{__aclocal} -I m4
94%{__autoconf}
95%{__automake}
96CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
97%configure \
98 --with-modules \
99 --with%{!?with_openssl:out}-openssl \
100 --with%{!?with_gnutls:out}-gnutls
101
102%{__make}
103
104%install
105rm -rf $RPM_BUILD_ROOT
106install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
107
108%{__make} install \
109 DESTDIR=$RPM_BUILD_ROOT
110
111install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
112install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
113install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
114
115bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
116rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
118
119%find_lang %{name}
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files -f %{name}.lang
128%defattr(644,root,root,755)
129%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
130%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
131%attr(755,root,root) %{_bindir}/lftp
132%attr(755,root,root) %{_bindir}/lftpget
133%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
134%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
135%dir %{_libdir}/lftp
136%attr(755,root,root) %{_libdir}/lftp/*.so
137%attr(755,root,root) %{_datadir}/lftp
138%{_mandir}/man1/lftp.1*
139%{_mandir}/man1/lftpget.1*
140%lang(pl) %{_mandir}/pl/man1/lftpget.1*
141%{_desktopdir}/lftp.desktop
142%{_pixmapsdir}/lftp.png
This page took 0.025856 seconds and 4 git commands to generate.