]> git.pld-linux.org Git - packages/kf5-kservice.git/blame_incremental - kf5-kservice.spec
- updated to 5.104.0
[packages/kf5-kservice.git] / kf5-kservice.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # build with tests
4%define kdeframever 5.104
5%define qtver 5.15.2
6%define kfname kservice
7
8Summary: Plugin framework for desktop services
9Name: kf5-%{kfname}
10Version: 5.104.0
11Release: 1
12License: LGPL v2.1+
13Group: X11/Libraries
14Source0: https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15# Source0-md5: 7c56d6f666d44bb100fc69a300c18b39
16URL: http://www.kde.org/
17BuildRequires: Qt5Concurrent-devel >= %{qtver}
18BuildRequires: Qt5Core-devel >= %{qtver}
19BuildRequires: Qt5DBus-devel >= %{qtver}
20BuildRequires: Qt5Test-devel >= %{qtver}
21BuildRequires: Qt5Xml-devel >= %{qtver}
22BuildRequires: bison >= 3.0
23BuildRequires: cmake >= 3.16
24BuildRequires: flex
25BuildRequires: kf5-extra-cmake-modules >= %{version}
26BuildRequires: kf5-kconfig-devel >= %{version}
27BuildRequires: kf5-kcoreaddons-devel >= %{version}
28BuildRequires: kf5-kdbusaddons-devel >= %{version}
29BuildRequires: kf5-kdoctools-devel >= %{version}
30BuildRequires: kf5-ki18n-devel >= %{version}
31BuildRequires: ninja
32BuildRequires: rpmbuild(macros) >= 1.736
33BuildRequires: tar >= 1:1.22
34BuildRequires: xz
35Requires: Qt5DBus >= %{qtver}
36Requires: Qt5Xml >= %{qtver}
37Requires: kf5-dirs
38Requires: kf5-kconfig >= %{version}
39Requires: kf5-kcoreaddons >= %{version}
40Requires: kf5-kdbusaddons >= %{version}
41Requires: kf5-ki18n >= %{version}
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%define qt5dir %{_libdir}/qt5
45
46%description
47KService provides a plugin framework for handling desktop services.
48Services can be applications or libraries. They can be bound to MIME
49types or handled by application specific code.
50
51%package devel
52Summary: Header files for %{kfname} development
53Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
54Group: X11/Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: cmake >= 3.16
57Requires: kf5-kconfig-devel >= %{version}
58Requires: kf5-kcoreaddons-devel >= %{version}
59
60%description devel
61Header files for %{kfname} development.
62
63%description devel -l pl.UTF-8
64Pliki nagłówkowe dla programistów używających %{kfname}.
65
66%prep
67%setup -q -n %{kfname}-%{version}
68
69%build
70install -d build
71cd build
72%cmake -G Ninja \
73 %{!?with_tests:-DBUILD_TESTING=OFF} \
74 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
75 ../
76%ninja_build
77
78%if %{with tests}
79ctest
80%endif
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85%ninja_install -C build
86
87%find_lang %{kfname}5
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93%postun -p /sbin/ldconfig
94
95%files -f %{kfname}5.lang
96%defattr(644,root,root,755)
97%doc README.md
98/etc/xdg/menus/applications.menu
99%attr(755,root,root) %{_bindir}/kbuildsycoca5
100%ghost %{_libdir}/libKF5Service.so.5
101%attr(755,root,root) %{_libdir}/libKF5Service.so.*.*
102%{_datadir}/kservicetypes5/application.desktop
103%{_datadir}/kservicetypes5/kplugininfo.desktop
104%{_mandir}/man8/desktoptojson.8*
105%{_mandir}/man8/kbuildsycoca5.8*
106%lang(ca) %{_mandir}/ca/man8/desktoptojson.8*
107%lang(ca) %{_mandir}/ca/man8/kbuildsycoca5.8*
108%lang(de) %{_mandir}/de/man8/desktoptojson.8*
109%lang(de) %{_mandir}/de/man8/kbuildsycoca5.8*
110%lang(es) %{_mandir}/es/man8/desktoptojson.8*
111%lang(es) %{_mandir}/es/man8/kbuildsycoca5.8*
112%lang(it) %{_mandir}/it/man8/desktoptojson.8*
113%lang(it) %{_mandir}/it/man8/kbuildsycoca5.8*
114%lang(nl) %{_mandir}/nl/man8/desktoptojson.8*
115%lang(nl) %{_mandir}/nl/man8/kbuildsycoca5.8*
116%lang(pt) %{_mandir}/pt/man8/desktoptojson.8*
117%lang(pt) %{_mandir}/pt/man8/kbuildsycoca5.8*
118%lang(pt_BR) %{_mandir}/pt_BR/man8/desktoptojson.8*
119%lang(pt_BR) %{_mandir}/pt_BR/man8/kbuildsycoca5.8*
120%lang(sv) %{_mandir}/sv/man8/desktoptojson.8*
121%lang(sv) %{_mandir}/sv/man8/kbuildsycoca5.8*
122%lang(uk) %{_mandir}/uk/man8/desktoptojson.8*
123%lang(uk) %{_mandir}/uk/man8/kbuildsycoca5.8*
124%lang(id) %{_mandir}/id/man8/desktoptojson.8*
125%{_datadir}/qlogging-categories5/kservice.categories
126%lang(fr) %{_mandir}/fr/man8/kbuildsycoca5.8*
127%{_datadir}/qlogging-categories5/kservice.renamecategories
128
129%files devel
130%defattr(644,root,root,755)
131%{_includedir}/KF5/KService
132%{_libdir}/cmake/KF5Service
133%{_libdir}/libKF5Service.so
134%{qt5dir}/mkspecs/modules/qt_KService.pri
This page took 0.029061 seconds and 4 git commands to generate.