]> git.pld-linux.org Git - packages/kf5-kinit.git/blame_incremental - kf5-kinit.spec
- updated to 5.102.0
[packages/kf5-kinit.git] / kf5-kinit.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # build with tests
4%define kdeframever 5.102
5%define qtver 5.15.2
6%define kfname kinit
7
8Summary: Helper library to speed up start of applications on KDE workspaces
9Name: kf5-%{kfname}
10Version: 5.102.0
11Release: 1
12License: LGPL v2.1+
13Group: X11/Libraries
14Source0: https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15# Source0-md5: 678af4940fefaa99d63dd9108a0847b4
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel >= %{qtver}
18BuildRequires: Qt5DBus-devel >= %{qtver}
19BuildRequires: Qt5Gui-devel >= %{qtver}
20BuildRequires: cmake >= 3.5
21BuildRequires: kf5-extra-cmake-modules >= %{version}
22BuildRequires: kf5-kconfig-devel >= %{version}
23BuildRequires: kf5-kcrash-devel >= %{version}
24BuildRequires: kf5-kdbusaddons-devel >= %{version}
25BuildRequires: kf5-kdoctools-devel >= %{version}
26BuildRequires: kf5-ki18n-devel >= %{version}
27BuildRequires: kf5-kio-devel >= %{version}
28BuildRequires: kf5-kservice-devel >= %{version}
29BuildRequires: kf5-kwindowsystem-devel >= %{version}
30BuildRequires: libcap-devel
31BuildRequires: libxcb-devel
32BuildRequires: ninja
33BuildRequires: rpmbuild(macros) >= 1.736
34BuildRequires: tar >= 1:1.22
35BuildRequires: xorg-lib-libX11-devel
36BuildRequires: xz
37Requires: Qt5Core >= %{qtver}
38Requires: Qt5DBus >= %{qtver}
39Requires: Qt5Gui >= %{qtver}
40Requires: kf5-dirs
41Requires: kf5-kconfig >= %{version}
42Requires: kf5-kcrash >= %{version}
43Requires: kf5-kdbusaddons >= %{version}
44Requires: kf5-ki18n >= %{version}
45Requires: kf5-kio >= %{version}
46Requires: kf5-kservice >= %{version}
47Requires: kf5-kwindowsystem >= %{version}
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%define qt5dir %{_libdir}/qt5
51
52%description
53kdeinit is a process launcher somewhat similar to the famous init used
54for booting UNIX.
55
56It launches processes by forking and then loading a dynamic library
57which should contain a 'kdemain(...)' function.
58
59Using kdeinit to launch KDE applications makes starting a typical KDE
60applications 2.5 times faster (100ms instead of 250ms on a P-III 500)
61It reduces memory consumption by approx. 350Kb per application.
62
63%package devel
64Summary: Header files for %{kfname} development
65Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
66Group: X11/Development/Libraries
67Requires: %{name} = %{version}-%{release}
68
69%description devel
70Header files for %{kfname} development.
71
72%description devel -l pl.UTF-8
73Pliki nagłówkowe dla programistów używających %{kfname}.
74
75%prep
76%setup -q -n %{kfname}-%{version}
77
78%build
79install -d build
80cd build
81%cmake -G Ninja \
82 %{!?with_tests:-DBUILD_TESTING=OFF} \
83 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
84 ../
85%ninja_build
86
87%if %{with tests}
88ctest
89%endif
90
91
92%install
93rm -rf $RPM_BUILD_ROOT
94%ninja_install -C build
95
96%find_lang %{kfname}5
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102%postun -p /sbin/ldconfig
103
104%files -f %{kfname}5.lang
105%defattr(644,root,root,755)
106%doc README.md
107%attr(755,root,root) %{_bindir}/kdeinit5
108%attr(755,root,root) %{_bindir}/kdeinit5_shutdown
109%attr(755,root,root) %{_bindir}/kdeinit5_wrapper
110%attr(755,root,root) %{_bindir}/kshell5
111%attr(755,root,root) %{_bindir}/kwrapper5
112%attr(755,root,root) %{_libexecdir}/kf5/klauncher
113%attr(755,root,root) %{_libexecdir}/kf5/start_kdeinit
114%attr(755,root,root) %{_libexecdir}/kf5/start_kdeinit_wrapper
115%attr(755,root,root) %{_libdir}/libkdeinit5_klauncher.so
116%{_datadir}/dbus-1/interfaces/kf5_org.kde.KLauncher.xml
117%{_datadir}/qlogging-categories5/kinit.categories
118%{_mandir}/man8/kdeinit5.8*
119%lang(ca) %{_mandir}/ca/man8/kdeinit5.8*
120%lang(de) %{_mandir}/de/man8/kdeinit5.8*
121%lang(es) %{_mandir}/es/man8/kdeinit5.8*
122%lang(it) %{_mandir}/it/man8/kdeinit5.8*
123%lang(nl) %{_mandir}/nl/man8/kdeinit5.8*
124%lang(pt) %{_mandir}/pt/man8/kdeinit5.8*
125%lang(pt_BR) %{_mandir}/pt_BR/man8/kdeinit5.8*
126%lang(sv) %{_mandir}/sv/man8/kdeinit5.8*
127%lang(uk) %{_mandir}/uk/man8/kdeinit5.8*
128%lang(fr) %{_mandir}/fr/man8/kdeinit5.8*
129%{_datadir}/qlogging-categories5/kinit.renamecategories
130
131%files devel
132%defattr(644,root,root,755)
133%{_libdir}/cmake/KF5Init
This page took 0.089827 seconds and 4 git commands to generate.