]> git.pld-linux.org Git - packages/kazehakase.git/blame_incremental - kazehakase.spec
- fixed bconds in files
[packages/kazehakase.git] / kazehakase.spec
... / ...
CommitLineData
1#
2# - force kazehakase to use old SSL dialogs using nsIBadCertListener, ie. port
3# EphyBadCertRejector from Epiphany, this will fix issues with https sites
4# using self signed and expired certificates or mismatches in domain names
5#
6# Conditional builds
7%bcond_without gecko # build without gecko support
8%bcond_without webkit # build without webkit support
9#
10Summary: A browser with multiple rendering engines support
11Summary(pl.UTF-8): Przeglądarka obsługująca wiele silników renderujących
12Name: kazehakase
13Version: 0.5.6
14Release: 1
15License: GPL
16Group: X11/Applications/Networking
17Source0: http://downloads.sourceforge.jp/kazehakase/33533/%{name}-%{version}.tar.gz
18# Source0-md5: b88257aa10dd53fd5d39c627f8f95890
19Patch0: %{name}-desktop.patch
20Patch1: %{name}-deprecated.patch
21Patch2: %{name}-ti-agent.patch
22Patch3: %{name}-agent.patch
23Patch4: %{name}-libxul.patch
24Patch5: %{name}-xulappinfo.patch
25URL: http://kazehakase.sourceforge.jp/
26BuildRequires: autoconf
27BuildRequires: automake
28BuildRequires: gettext-devel
29BuildRequires: gnutls-devel
30BuildRequires: gtk+2-devel
31%{?with_webkit:BuildRequires: gtk-webkit-devel}
32BuildRequires: libstdc++-devel
33BuildRequires: libtool
34BuildRequires: pkgconfig
35BuildRequires: rpm >= 4.4.9-56
36%{?with_gecko:BuildRequires: xulrunner-devel}
37Requires: %{name}-libs = %{version}-%{release}
38Requires: kazehakase_engine
39%requires_eq_to xulrunner xulrunner-devel
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42# we have strict deps for it
43%define _noautoreq libxpcom.so
44
45%description
46Kazehakase is a browser which allow use many rendering engines. For
47now it support only Gecko (like Epiphany or Galeon) and webkit engines.
48
49%description -l pl.UTF-8
50Kazehakase jest przeglądarką, która pozwala na używanie wielu
51silników renderujących. Na dzień dzisiejszy obsługuje silniki Gecko
52(taki jak w Epiphany lub Galeonie) oraz webkit.
53
54%package libs
55Summary: Kazehakase libraries
56Summary(pl.UTF-8): Biblioteki Kazehakase
57Group: Libraries
58
59%description libs
60This package contains Kazehakase libraries.
61
62%description libs -l pl.UTF-8
63Pakiet zawiera biblioteki Kazehakase.
64
65%package plugin-gecko
66Summary: Gecko plugin engine for Kazehakase
67Summary(pl.UTF-8): Wtyczka Gecko dla Kazehakase
68Group: X11/Applications/Networking
69Requires: xulrunner
70Provides: kazehakase_engine
71
72%description plugin-gecko
73This plugin provides Gecko rendering engine support.
74
75%description plugin-gecko -l pl.UTF-8
76Ta wtyczka dodaje obsługę silnika renderującego Gecko.
77
78%package plugin-webkit
79Summary: Webkit plugin engine for Kazehakase
80Summary(pl.UTF-8): Wtyczka webkit dla Kazehakase
81Group: X11/Applications/Networking
82Provides: kazehakase_engine
83
84%description plugin-webkit
85This plugin provides webkit rendering engine support.
86
87%description plugin-webkit -l pl.UTF-8
88Ta wtyczka dodaje obsługę silnika renderującego webkit.
89
90%prep
91%setup -q
92%patch0 -p1
93%patch1 -p1
94%if "%{pld_release}" == "ti"
95%patch2 -p1
96%else
97%patch3 -p1
98%endif
99%patch4 -p1
100%patch5 -p1
101
102%build
103%{__libtoolize}
104%{__aclocal} -I macros
105%{__autoconf}
106%{__automake}
107%configure \
108 %{!?with_gecko:--disable-gecko} \
109 %{!?with_webkit:--disable-webkit}
110
111%{__make}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115
116%{__make} install \
117 libkazehakasedir=%{_libdir} \
118 DESTDIR=$RPM_BUILD_ROOT
119
120# unnecessary
121rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
122rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/embed/*.la
123
124%find_lang %{name}
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post libs -p /sbin/ldconfig
130%postun libs -p /sbin/ldconfig
131
132%files -f %{name}.lang
133%defattr(644,root,root,755)
134%doc README README.ja AUTHORS ChangeLog COPYING.README TODO.ja
135%{_sysconfdir}/%{name}
136%attr(755,root,root) %{_bindir}/*
137%{_desktopdir}/%{name}.desktop
138%{_datadir}/%{name}
139%{_pixmapsdir}/*
140%{_mandir}/man?/*
141
142%files libs
143%defattr(644,root,root,755)
144%attr(755,root,root) %{_libdir}/lib*.so
145%attr(755,root,root) %{_libdir}/lib*.so.*
146%dir %{_libdir}/%{name}
147%dir %{_libdir}/%{name}/embed
148
149%if %{with gecko}
150%files plugin-gecko
151%defattr(644,root,root,755)
152%attr(755,root,root) %{_libdir}/%{name}/embed/gecko.so
153%endif
154%if %{with webkit}
155%files plugin-webkit
156%defattr(644,root,root,755)
157%attr(755,root,root) %{_libdir}/%{name}/embed/webkit_gtk.so
158%endif
This page took 0.076421 seconds and 4 git commands to generate.