]> git.pld-linux.org Git - packages/json-c.git/blame_incremental - json-c.spec
- x32 rebuild
[packages/json-c.git] / json-c.spec
... / ...
CommitLineData
1Summary: A JSON implementation in C
2Summary(pl.UTF-8): Implementacja JSON w C
3Name: json-c
4Version: 0.12
5Release: 2
6License: MIT
7Group: Libraries
8Source0: https://s3.amazonaws.com/json-c_releases/releases/%{name}-%{version}.tar.gz
9# Source0-md5: 3ca4bbb881dfc4017e8021b5e0a8c491
10URL: https://github.com/json-c/json-c/wiki
11BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13%description
14JSON-C implements a reference counting object model that allows you to
15easily construct JSON objects in C, output them as JSON formatted
16strings and parse JSON formatted strings back into the C
17representation of JSON objects.
18
19%description -l pl.UTF-8
20JSON-C implementuje model obiektów ze zliczaniem odwołań, pozwalający
21łatwo konstruować obiekty JSON w C, wypisywać je w postaci łańcuchów w
22formacie JSON i analizować łańcuchy w formacie JSON tworząc z powrotem
23reprezentacje obiektów JSON w C.
24
25%package devel
26Summary: Header files for the json-c library
27Summary(pl.UTF-8): Pliki nagłówkowe biblioteki json-c
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30
31%description devel
32Header files for the json-c library.
33
34%description devel -l pl.UTF-8
35Pliki nagłówkowe biblioteki json-c.
36
37%package static
38Summary: Static json-c library
39Summary(pl.UTF-8): Statyczna biblioteka json-c
40Group: Development/Libraries
41Requires: %{name}-devel = %{version}-%{release}
42
43%description static
44Static json-c library.
45
46%description static -l pl.UTF-8
47Statyczna biblioteka json-c.
48
49%prep
50%setup -q
51
52%build
53# avoid "json_tokener.c:355:6: error: variable 'size' set but not used [-Werror=unused-but-set-variable]"
54CFLAGS="%{rpmcflags} -Wno-unused-but-set-variable"
55%configure
56%{__make} -j1
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT
63
64%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%post -p /sbin/ldconfig
70%postun -p /sbin/ldconfig
71
72%pretrans devel
73# transition from 0.11-2
74[ ! -L %{_includedir}/json-c ] || rm -f %{_includedir}/json-c
75# transition from <= 0.10 and 0.11-2
76if [ -d %{_includedir}/json -a ! -d %{_includedir}/json-c ]; then
77 mv -f %{_includedir}/json %{_includedir}/json-c
78 ln -sf json-c %{_includedir}/json
79fi
80
81%files
82%defattr(644,root,root,755)
83%doc AUTHORS COPYING ChangeLog README README.html
84%attr(755,root,root) %{_libdir}/libjson-c.so.*.*.*
85%attr(755,root,root) %ghost %{_libdir}/libjson-c.so.2
86
87%files devel
88%defattr(644,root,root,755)
89%attr(755,root,root) %{_libdir}/libjson-c.so
90%{_includedir}/json-c
91%{_pkgconfigdir}/json-c.pc
92
93%files static
94%defattr(644,root,root,755)
95%{_libdir}/libjson-c.a
This page took 0.03361 seconds and 4 git commands to generate.