]> git.pld-linux.org Git - packages/john.git/blame_incremental - john.spec
- s/path/patch/
[packages/john.git] / john.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with jumbopatch # This patch integrates lots of contributed
4 # patches adding support for over 30
5 # of additional hash types, and more.
6
7%ifarch i586 i686 athlon pentium2 pentium3 pentium4
8%define do_mmx 1
9%else
10%define do_mmx 0
11%endif
12%ifarch i586 i686
13%define do_mmxfb 1
14%define optmmxfb -DCPU_FALLBACK=1
15%else
16%define do_mmxfb 0
17%undefine optmmxfb
18%endif
19Summary: Password cracker
20Summary(pl.UTF-8): Łamacz haseł
21Name: john
22Version: 1.7.3.4
23Release: 2
24License: GPL
25Group: Applications/System
26Source0: http://www.openwall.com/john/g/%{name}-%{version}.tar.bz2
27# Source0-md5: 2f2310c49961c3edea6f92b8dcd45ff4
28Patch0: %{name}-mailer.patch
29%{?with_jumbopatch:Patch1: http://www.openwall.com/john/contrib/john-%{version}-jumbo-2.diff.gz}
30URL: http://www.openwall.com/john/
31BuildRequires: rpmbuild(macros) >= 1.213
32%{?with_jumbopatch:BuildRequires: openssl-devel >= 0.9.7}
33Requires: words
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37John the Ripper is a fast password cracker, currently available for
38many flavors of Unix (11 are officially supported, not counting
39different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
40requires a contributed patch). Its primary purpose is to detect weak
41Unix passwords. Besides several crypt(3) password hash types most
42commonly found on various Unix flavors, supported out of the box are
43Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
44contributed patches.
45
46%description -l pl.UTF-8
47John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
48rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
49architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
50łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
51Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
52na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
53Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
54
55%prep
56%setup -q
57%patch0 -p1
58%{?with_jumbopatch:%patch1 -p1}
59
60%build
61cd src
62
63%if %{do_mmxfb}
64%{__make} linux-x86-any \
65 CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
66 CC="%{__cc}"
67mv ../run/john ../run/john-non-mmx
68%{__make} clean
69%endif
70
71%ifarch %{ix86}
72 %if %{do_mmx}
73 TARG=linux-x86-mmx
74 %else
75 TARG=linux-x86-any
76 %endif
77%else
78 %ifarch alpha
79 TARG=linux-alpha
80 %else
81 %ifarch sparc sparcv9
82 TARG=linux-sparc
83 %else
84 %ifarch %{x8664}
85 TARG=linux-x86-64
86 %else
87 TARG=generic
88 %endif
89 %endif
90 %endif
91%endif
92
93%{__make} $TARG \
94 CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}" \
95 CC="%{__cc}"
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
101install run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
102install run/john $RPM_BUILD_ROOT%{_bindir}
103%if %{do_mmxfb}
104install -d $RPM_BUILD_ROOT%{_libdir}/john
105install run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
106%endif
107
108rm -f doc/INSTALL
109
110cd $RPM_BUILD_ROOT%{_bindir}
111ln -sf john unafs
112ln -sf john unique
113ln -sf john unshadow
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%files
119%defattr(644,root,root,755)
120%doc doc/* run/mailer
121%attr(755,root,root) %{_bindir}/*
122%if %{do_mmxfb}
123%dir %{_libdir}/john
124%attr(755,root,root) %{_libdir}/john/john-non-mmx
125%endif
126%{_datadir}/john
This page took 0.022341 seconds and 4 git commands to generate.