]> git.pld-linux.org Git - packages/icedove.git/blame_incremental - icedove.spec
- updated to 24.5.0
[packages/icedove.git] / icedove.spec
... / ...
CommitLineData
1# TODO:
2# - separate spec for enigmail
3# - build with system mozldap
4#
5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without ldap # disable e-mail address lookups in LDAP directories
8%bcond_without lightning # disable Sunbird/Lightning calendar
9%bcond_with xulrunner # system xulrunner
10%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
11
12%if 0%{?_enable_debug_packages} != 1
13%undefine crashreporter
14%endif
15
16%define enigmail_ver 1.6
17%define nspr_ver 4.9.3
18%define nss_ver 3.15.3.1
19
20%define xulrunner_ver 2:24.0
21
22%if %{without xulrunner}
23# The actual sqlite version (see RHBZ#480989):
24%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
25%endif
26
27Summary: Icedove - email client
28Summary(pl.UTF-8): Icedove - klient poczty
29Name: icedove
30Version: 24.5.0
31Release: 1
32License: MPL 1.1 or GPL v2+ or LGPL v2.1+
33Group: X11/Applications/Mail
34Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
35# Source0-md5: dbe164c48e42c04b4959910eda2e52ca
36Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
37# Source1-md5: 4a2bbcb020bdb282a660fda8c70d5608
38Source2: %{name}-branding.tar.bz2
39# Source2-md5: d8e6897870bf288fdf264c0e9ef85f7d
40Source3: %{name}-rm_nonfree.sh
41Source4: %{name}.desktop
42Source5: %{name}.sh
43Patch0: %{name}-branding.patch
44Patch1: %{name}-enigmail-shared.patch
45Patch3: %{name}-fonts.patch
46Patch6: %{name}-prefs.patch
47Patch7: system-mozldap.patch
48Patch8: %{name}-makefile.patch
49Patch10: %{name}-extensiondir.patch
50Patch11: crashreporter.patch
51Patch12: no-subshell.patch
52# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
53Patch13: system-virtualenv.patch
54Patch14: gyp-slashism.patch
55Patch15: enable-addons.patch
56URL: http://www.pld-linux.org/Packages/Icedove
57BuildRequires: GConf2-devel >= 1.2.1
58BuildRequires: alsa-lib-devel
59BuildRequires: automake
60BuildRequires: bzip2-devel
61BuildRequires: cairo-devel >= 1.10
62BuildRequires: dbus-glib-devel >= 0.60
63BuildRequires: freetype-devel >= 1:2.1.8
64BuildRequires: glib2-devel >= 2.0
65BuildRequires: gstreamer0.10-devel
66BuildRequires: gstreamer0.10-plugins-base-devel
67BuildRequires: gtk+2-devel >= 2:2.10.0
68BuildRequires: hunspell-devel
69BuildRequires: libIDL-devel >= 0.8.0
70BuildRequires: libevent-devel
71BuildRequires: libiw-devel
72# requires libjpeg-turbo implementing at least libjpeg 6b API
73BuildRequires: libjpeg-devel >= 6b
74BuildRequires: libjpeg-turbo-devel
75BuildRequires: libnotify-devel >= 0.4
76BuildRequires: libpng-devel >= 1.4.1
77BuildRequires: libstdc++-devel
78BuildRequires: mozldap-devel
79BuildRequires: nspr-devel >= 1:%{nspr_ver}
80BuildRequires: nss-devel >= 1:%{nss_ver}
81BuildRequires: pango-devel >= 1:1.14.0
82BuildRequires: perl-base >= 1:5.6
83BuildRequires: python-virtualenv
84BuildRequires: pkgconfig
85BuildRequires: python >= 1:2.5
86BuildRequires: sed >= 4.0
87BuildRequires: sqlite3-devel >= 3.7.4
88BuildRequires: startup-notification-devel >= 0.8
89BuildRequires: libvpx-devel >= 1.0.0
90BuildRequires: xorg-lib-libXext-devel
91BuildRequires: xorg-lib-libXinerama-devel
92BuildRequires: xorg-lib-libXt-devel
93BuildRequires: yasm
94BuildRequires: zip
95%if %{with xulrunner}
96BuildRequires: xulrunner-devel >= %{xulrunner_ver}
97%else
98Requires: myspell-common
99Requires: nspr >= 1:%{nspr_ver}
100Requires: nss >= 1:%{nss_ver}
101Requires: sqlite3 >= %{sqlite_build_version}
102%endif
103Requires(post): mktemp >= 1.5-18
104%if %{with xulrunner}
105%requires_eq_to xulrunner xulrunner-devel
106%endif
107Requires: libjpeg-turbo
108Obsoletes: mozilla-thunderbird
109Obsoletes: mozilla-thunderbird-dictionary-en-US
110Conflicts: icedove-lang-resources < %{version}
111BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
114
115# iceweasel/icedove/iceape provide their own versions
116%define _noautoprovfiles %{_libdir}/%{name}/components
117%if %{without xulrunner}
118# we don't want these to satisfy packages depending on xulrunner
119%define _noautoprov libmozalloc.so libxpcom.so libxul.so
120# and as we don't provide them, don't require either
121%define _noautoreq libmozalloc.so libxpcom.so libxul.so
122%endif
123
124%define topdir %{_builddir}/%{name}-%{version}
125%define objdir %{topdir}/obj-%{_target_cpu}
126
127%description
128Icedove is an open-source, fast and portable email client.
129
130%description -l pl.UTF-8
131Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
132poczty.
133
134%package addon-lightning
135Summary: An integrated calendar for Icedove
136Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
137License: MPL 1.1 or GPL v2+ or LGPL v2.1+
138Group: Applications/Networking
139Requires: %{name} = %{version}-%{release}
140
141%description addon-lightning
142Lightning is an calendar extension to Icedove email client.
143
144%description addon-lightning -l pl.UTF-8
145Lightning to rozszerzenie do klienta poczty Icedove dodające
146funkcjonalność kalendarza.
147
148%package addon-enigmail
149Summary: Extension for the authentication and encryption features provided by GnuPG
150Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
151License: MPL/LGPL
152Group: Applications/Networking
153URL: http://enigmail.mozdev.org/
154Requires: %{name} = %{version}-%{release}
155Requires: gnupg
156Obsoletes: mozilla-thunderbird-addon-enigmail
157
158%description addon-enigmail
159Enigmail is an extension to the Icedove mail client which allows users
160to access the authentication and encryption features provided by
161GnuPG.
162
163Main Features:
164- Encrypt/sign mail when sending, decrypt/authenticate received mail
165- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
166- Per-Account based encryption and signing defaults
167- Per-Recipient rules for automated key selection, and
168 enabling/disabling encryption and signing
169- OpenPGP key management interface
170
171%description addon-enigmail -l pl.UTF-8
172Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
173użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
174przez GnuPG.
175
176Główne możliwości:
177- szyfrowanie/podpisywanie poczty przy wysyłaniu,
178 odszyfrowywanie/uwierzytelnianie poczty odebranej
179- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
180- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
181- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
182 podpisywania dla każdego adresata
183- interfejs do zarządzania kluczami OpenPGP
184
185%prep
186%setup -qc
187mv comm-esr24 mozilla
188%setup -q -T -D -a2
189cd mozilla
190%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
191/bin/sh %{SOURCE3}
192%patch0 -p1
193%{?with_enigmail:%patch1 -p1}
194%patch3 -p1
195%patch6 -p1
196%patch7 -p1
197%patch8 -p2
198%patch10 -p2
199#patch11 -p2
200%patch12 -p1
201%patch13 -p1
202%patch14 -p1
203%patch15 -p1
204
205# the entire check in that configure is so wrong, it's simpler to just workaround it here temporarily
206%{__sed} -i -e 's|min_nss_version=3.15.3.1|min_nss_version=3.15.3|' mozilla/configure
207
208%build
209cd mozilla
210cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
211cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
212cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
213
214cat << EOF > .mozconfig
215mk_add_options MOZ_OBJDIR=%{objdir}
216
217export CFLAGS="%{rpmcflags}"
218export CXXFLAGS="%{rpmcflags}"
219
220%if %{with crashreporter}
221export MOZ_DEBUG_SYMBOLS=1
222%endif
223
224# Options for 'configure' (same as command-line options).
225ac_add_options --prefix=%{_prefix}
226ac_add_options --exec-prefix=%{_exec_prefix}
227ac_add_options --bindir=%{_bindir}
228ac_add_options --sbindir=%{_sbindir}
229ac_add_options --sysconfdir=%{_sysconfdir}
230ac_add_options --datadir=%{_datadir}
231ac_add_options --includedir=%{_includedir}
232ac_add_options --libdir=%{_libdir}
233ac_add_options --libexecdir=%{_libexecdir}
234ac_add_options --localstatedir=%{_localstatedir}
235ac_add_options --sharedstatedir=%{_sharedstatedir}
236ac_add_options --mandir=%{_mandir}
237ac_add_options --infodir=%{_infodir}
238%if %{?debug:1}0
239ac_add_options --disable-optimize
240ac_add_options --enable-debug
241ac_add_options --enable-debug-modules
242ac_add_options --enable-debugger-info-modules
243ac_add_options --enable-crash-on-assert
244%else
245ac_add_options --disable-debug
246ac_add_options --disable-debug-modules
247ac_add_options --disable-logging
248ac_add_options --enable-optimize="%{rpmcflags} -Os"
249%endif
250ac_add_options --disable-strip
251ac_add_options --disable-strip-libs
252%if %{with tests}
253ac_add_options --enable-tests
254%else
255ac_add_options --disable-tests
256%endif
257ac_add_options --enable-gio
258ac_add_options --disable-gnomeui
259ac_add_options --disable-gnomevfs
260%if %{with ldap}
261ac_add_options --enable-ldap
262ac_add_options --with-system-ldap
263%else
264ac_add_options --disable-ldap
265%endif
266%if %{with crashreporter}
267ac_add_options --enable-crashreporter
268%else
269ac_add_options --disable-crashreporter
270%endif
271ac_add_options --disable-xterm-updates
272ac_add_options --enable-postscript
273%if %{with lightning}
274ac_add_options --enable-calendar
275%else
276ac_add_options --disable-calendar
277%endif
278ac_add_options --disable-elf-dynstr-gc
279ac_add_options --disable-installer
280ac_add_options --disable-javaxpcom
281ac_add_options --disable-updater
282ac_add_options --enable-crypto
283ac_add_options --enable-libxul
284ac_add_options --enable-pango
285ac_add_options --enable-shared-js
286ac_add_options --enable-startup-notification
287ac_add_options --enable-system-cairo
288ac_add_options --enable-system-hunspell
289ac_add_options --enable-system-sqlite
290ac_add_options --enable-application=mail
291ac_add_options --with-distribution-id=org.pld-linux
292ac_add_options --with-branding=icedove/branding
293%if %{with xulrunner}
294ac_add_options --with-system-libxul
295ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
296%endif
297ac_add_options --with-pthreads
298ac_add_options --with-system-bz2
299ac_add_options --with-system-ffi
300ac_add_options --with-system-jpeg
301ac_add_options --with-system-libevent
302ac_add_options --with-system-libvpx
303ac_add_options --with-system-nspr
304ac_add_options --with-system-nss
305ac_add_options --with-system-png
306ac_add_options --with-system-zlib
307ac_add_options --enable-single-profile
308ac_add_options --disable-profilesharing
309ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
310EOF
311
312mkdir -p %{objdir}/config
313ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
314
315%{__make} -j1 -f client.mk build \
316 STRIP="/bin/true" \
317 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
318 installdir=%{_libdir}/%{name} \
319 XLIBS="-lX11 -lXt" \
320 CC="%{__cc}" \
321 CXX="%{__cxx}"
322
323%if %{with crashreporter}
324# create debuginfo for crash-stats.mozilla.com
325%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
326%endif
327
328%if %{with enigmail}
329cd mailnews/extensions/enigmail
330./makemake -r -o %{objdir}
331%{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail \
332 STRIP="/bin/true" \
333 CC="%{__cc}" \
334 CXX="%{__cxx}"
335
336%{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail xpi \
337 STRIP="/bin/true" \
338 CC="%{__cc}" \
339 CXX="%{__cxx}"
340%endif
341
342%install
343rm -rf $RPM_BUILD_ROOT
344install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
345
346cd %{objdir}
347%{__make} -C mail/installer stage-package \
348 DESTDIR=$RPM_BUILD_ROOT \
349 installdir=%{_libdir}/%{name} \
350 PKG_SKIP_STRIP=1
351
352%{__make} -C icedove/branding install \
353 DESTDIR=$RPM_BUILD_ROOT
354
355cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
356
357%if %{with xulrunner}
358# needed to find mozilla runtime
359ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
360%endif
361
362# Enable crash reporter for Thunderbird application
363%if %{with crashreporter}
364%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
365
366# Add debuginfo for crash-stats.mozilla.com
367install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
368cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
369%endif
370
371# copy manually lightning files, somewhy they are not installed by make
372cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
373 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
374
375# move arch independant ones to datadir
376mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
377ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
378
379# dir for arch independant extensions besides arch dependant extensions
380# see mozilla/xpcom/build/nsXULAppAPI.h
381# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
382install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
383
384%if %{without xulrunner}
385%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
386ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
387%endif
388
389%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
390 -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
391 %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
392
393%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
394ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
395ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
396
397# install icons and desktop file
398cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
399for i in 16 32 48 64 128 256; do
400 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
401 cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
402 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
403done
404install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
405cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
406
407cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
408
409# files created by regxpcom -register in post
410touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
411touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
412cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
413#!/bin/sh
414umask 022
415# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
416# dangerous if you run this with sudo with keep_env += HOME
417# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
418t=$(mktemp -d)
419%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
420TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
421rm -rf $t
422EOF
423chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
424
425%if %{with enigmail}
426ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
427install -d $ext_dir/{chrome,components,defaults/preferences,modules}
428cd mozilla/dist/bin
429cp -rfLp chrome/enigmail.jar $ext_dir/chrome
430cp -rfLp components/enig* $ext_dir/components
431cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
432cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
433cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
434cd -
435cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
436cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
437%endif
438
439# mozldap
440%{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
441%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
442
443%clean
444rm -rf $RPM_BUILD_ROOT
445
446%pretrans
447if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
448 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
449fi
450for d in chrome defaults icons isp modules res searchplugins; do
451 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
452 install -d %{_datadir}/%{name}
453 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
454 fi
455done
456exit 0
457
458%post
459%{_libdir}/%{name}/register || :
460
461%files
462%defattr(644,root,root,755)
463%attr(755,root,root) %{_bindir}/icedove
464%attr(755,root,root) %{_bindir}/mozilla-thunderbird
465%attr(755,root,root) %{_bindir}/thunderbird
466%dir %{_libdir}/%{name}
467%{_libdir}/%{name}/application.ini
468%{_libdir}/%{name}/blocklist.xml
469%{_libdir}/%{name}/chrome.manifest
470%dir %{_libdir}/%{name}/components
471%{_libdir}/%{name}/components/components.manifest
472%attr(755,root,root) %{_libdir}/%{name}/*.sh
473%attr(755,root,root) %{_libdir}/%{name}/*-bin
474%attr(755,root,root) %{_libdir}/%{name}/icedove
475%attr(755,root,root) %{_libdir}/%{name}/register
476%{_libdir}/%{name}/omni.ja
477%if %{without xulrunner}
478%{_libdir}/%{name}/dependentlibs.list
479%{_libdir}/%{name}/platform.ini
480#%{_libdir}/%{name}/greprefs.js
481%attr(755,root,root) %{_libdir}/%{name}/components/*.so
482%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
483%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
484%attr(755,root,root) %{_libdir}/%{name}/libxul.so
485%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
486%attr(755,root,root) %{_libdir}/%{name}/plugin-container
487%endif
488
489# symlinks
490%{_libdir}/%{name}/chrome
491%{_libdir}/%{name}/defaults
492%{_libdir}/%{name}/isp
493#%{_libdir}/%{name}/modules
494%{_libdir}/%{name}/searchplugins
495%if %{with xulrunner}
496%{_libdir}/%{name}/xulrunner
497%else
498%{_libdir}/%{name}/dictionaries
499%endif
500
501%{_pixmapsdir}/icedove.png
502%{_desktopdir}/icedove.desktop
503
504%dir %{_datadir}/%{name}
505%{_datadir}/%{name}/extensions
506%{_datadir}/%{name}/searchplugins
507
508%if %{with crashreporter}
509%attr(755,root,root) %{_libdir}/%{name}/crashreporter
510%{_libdir}/%{name}/crashreporter.ini
511%{_libdir}/%{name}/Throbber-small.gif
512%endif
513
514%dir %{_libdir}/%{name}/extensions
515%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
516
517# files created by regxpcom -register
518%ghost %{_libdir}/%{name}/components/compreg.dat
519%ghost %{_libdir}/%{name}/components/xpti.dat
520
521%{_iconsdir}/hicolor/*/apps/icedove.*
522
523%if %{with lightning}
524%files addon-lightning
525%defattr(644,root,root,755)
526%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
527%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
528%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
529%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
530%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
531%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
532%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
533%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
534%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
535%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
536%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
540%endif
541
542%if %{with enigmail}
543%files addon-enigmail
544%defattr(644,root,root,755)
545%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
546%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
547%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
548%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
549%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
550%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
551%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
552%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
553%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
554%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
555%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
556%endif
This page took 0.036496 seconds and 4 git commands to generate.