]> git.pld-linux.org Git - packages/icedove.git/blame_incremental - icedove.spec
- updated to 8.0
[packages/icedove.git] / icedove.spec
... / ...
CommitLineData
1# TODO:
2# - separate spec for enigmail
3# - build with system mozldap
4# - replace gnome-vfs2 with gio
5# - files:
6# /usr/lib/icedove/hyphenation/hyph_en_US.dic
7#
8# Conditional builds
9%bcond_without enigmail # don't build enigmail - GPG/PGP support
10%bcond_without gnomeui # disable gnomeui support
11%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
12%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
13%bcond_without ldap # disable e-mail address lookups in LDAP directories
14%bcond_without lightning # disable Sunbird/Lightning calendar
15%bcond_without xulrunner # build with xulrunner
16%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
17
18%if %{without gnome}
19%undefine with_gnomeui
20%undefine with_gnomevfs
21%endif
22
23%if 0%{?_enable_debug_packages} != 1
24%undefine crashreporter
25%endif
26
27%define enigmail_ver 1.3.2
28%define nspr_ver 4.8.8
29%define nss_ver 3.12.10
30
31# convert firefox release number to platform version: 7.0.x -> 7.0.x
32%define xulrunner_main 8.0
33%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#8.0})
34
35%if %{without xulrunner}
36# The actual sqlite version (see RHBZ#480989):
37%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
38%endif
39
40Summary: Icedove - email client
41Summary(pl.UTF-8): Icedove - klient poczty
42Name: icedove
43Version: 8.0
44Release: 0.1
45License: MPL 1.1 or GPL v2+ or LGPL v2.1+
46Group: X11/Applications/Networking
47Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
48# Source0-md5: 332f60036aebdce7dec6ee2b1af4941d
49Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
50# Source1-md5: 2318d60320dc6c3db3c34d968bb7d533
51Source2: %{name}-branding.tar.bz2
52# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
53Source3: %{name}-rm_nonfree.sh
54Source4: %{name}.desktop
55Source5: %{name}.sh
56Patch0: %{name}-branding.patch
57Patch1: %{name}-enigmail-shared.patch
58Patch2: %{name}-gcc.patch
59Patch3: %{name}-fonts.patch
60Patch4: %{name}-install.patch
61Patch5: %{name}-hunspell.patch
62Patch6: %{name}-prefs.patch
63Patch7: system-mozldap.patch
64Patch8: %{name}-makefile.patch
65Patch10: %{name}-extensiondir.patch
66Patch11: crashreporter.patch
67Patch12: no-subshell.patch
68URL: http://www.pld-linux.org/Packages/Icedove
69%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
70BuildRequires: alsa-lib-devel
71BuildRequires: automake
72BuildRequires: bzip2-devel
73BuildRequires: cairo-devel >= 1.10
74BuildRequires: dbus-glib-devel >= 0.60
75BuildRequires: freetype-devel >= 1:2.1.8
76%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
77BuildRequires: gtk+2-devel >= 2:2.10.0
78BuildRequires: hunspell-devel
79BuildRequires: libIDL-devel >= 0.8.0
80%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
81%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
82%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
83BuildRequires: libiw-devel
84BuildRequires: libjpeg-devel >= 6b
85BuildRequires: libnotify-devel >= 0.4
86BuildRequires: libpng-devel >= 1.4.1
87BuildRequires: libstdc++-devel
88BuildRequires: nspr-devel >= 1:%{nspr_ver}
89BuildRequires: nss-devel >= 1:%{nss_ver}
90BuildRequires: pango-devel >= 1:1.1.0
91BuildRequires: perl-base >= 1:5.6
92BuildRequires: pkgconfig
93BuildRequires: python >= 1:2.5
94BuildRequires: sed >= 4.0
95BuildRequires: sqlite3-devel >= 3.7.4
96BuildRequires: startup-notification-devel >= 0.8
97BuildRequires: xorg-lib-libXext-devel
98BuildRequires: xorg-lib-libXinerama-devel
99BuildRequires: xorg-lib-libXt-devel
100BuildRequires: yasm
101BuildRequires: zip
102%if %{with xulrunner}
103BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
104%else
105Requires: myspell-common
106Requires: nspr >= 1:%{nspr_ver}
107Requires: nss >= 1:%{nss_ver}
108Requires: sqlite3 >= %{sqlite_build_version}
109%endif
110Requires(post): mktemp >= 1.5-18
111%if %{with xulrunner}
112%requires_eq_to xulrunner xulrunner-devel
113%endif
114Obsoletes: mozilla-thunderbird
115Obsoletes: mozilla-thunderbird-dictionary-en-US
116BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
119
120# iceweasel/icedove/iceape provide their own versions
121%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
122%define _noautoprovfiles %{_libdir}/%{name}/components
123# we don't want these to satisfy xulrunner-devel
124%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
125# and as we don't provide them, don't require either
126%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
127
128%define topdir %{_builddir}/%{name}-%{version}
129%define objdir %{topdir}/obj-%{_target_cpu}
130
131%description
132Icedove is an open-source, fast and portable email client.
133
134%description -l pl.UTF-8
135Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
136poczty.
137
138%package addon-lightning
139Summary: An integrated calendar for Icedove
140Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
141License: MPL 1.1 or GPL v2+ or LGPL v2.1+
142Group: Applications/Networking
143Requires: %{name} = %{version}-%{release}
144
145%description addon-lightning
146Lightning is an calendar extension to Icedove email client.
147
148%description addon-lightning -l pl.UTF-8
149Lightning to rozszerzenie do klienta poczty Icedove dodające
150funkcjonalność kalendarza.
151
152%package addon-enigmail
153Summary: Extension for the authentication and encryption features provided by GnuPG
154Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
155License: MPL/LGPL
156Group: Applications/Networking
157URL: http://enigmail.mozdev.org/
158Requires: %{name} = %{version}-%{release}
159Requires: gnupg
160Obsoletes: mozilla-thunderbird-addon-enigmail
161
162%description addon-enigmail
163Enigmail is an extension to the Icedove mail client which allows users
164to access the authentication and encryption features provided by
165GnuPG.
166
167Main Features:
168- Encrypt/sign mail when sending, decrypt/authenticate received mail
169- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
170- Per-Account based encryption and signing defaults
171- Per-Recipient rules for automated key selection, and
172 enabling/disabling encryption and signing
173- OpenPGP key management interface
174
175%description addon-enigmail -l pl.UTF-8
176Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
177użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
178przez GnuPG.
179
180Główne możliwości:
181- szyfrowanie/podpisywanie poczty przy wysyłaniu,
182 odszyfrowywanie/uwierzytelnianie poczty odebranej
183- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
184- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
185- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
186 podpisywania dla każdego adresata
187- interfejs do zarządzania kluczami OpenPGP
188
189%prep
190%setup -qc
191mv comm-release mozilla
192%setup -q -T -D -a2
193cd mozilla
194%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
195/bin/sh %{SOURCE3}
196%patch0 -p1
197%{?with_enigmail:%patch1 -p1}
198%patch2 -p1
199%patch3 -p1
200%patch4 -p1
201%patch6 -p1
202%patch7 -p1
203%patch8 -p2
204%patch10 -p2
205%patch11 -p2
206%patch12 -p1
207
208%build
209cd mozilla
210cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
211cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
212cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
213
214install -d libxul-sdk
215ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
216
217cat << EOF > .mozconfig
218mk_add_options MOZ_OBJDIR=%{objdir}
219
220export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
221export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
222
223%if %{with crashreporter}
224export MOZ_DEBUG_SYMBOLS=1
225%endif
226
227# Options for 'configure' (same as command-line options).
228ac_add_options --prefix=%{_prefix}
229ac_add_options --exec-prefix=%{_exec_prefix}
230ac_add_options --bindir=%{_bindir}
231ac_add_options --sbindir=%{_sbindir}
232ac_add_options --sysconfdir=%{_sysconfdir}
233ac_add_options --datadir=%{_datadir}
234ac_add_options --includedir=%{_includedir}
235ac_add_options --libdir=%{_libdir}
236ac_add_options --libexecdir=%{_libexecdir}
237ac_add_options --localstatedir=%{_localstatedir}
238ac_add_options --sharedstatedir=%{_sharedstatedir}
239ac_add_options --mandir=%{_mandir}
240ac_add_options --infodir=%{_infodir}
241%if %{?debug:1}0
242ac_add_options --disable-optimize
243ac_add_options --enable-debug
244ac_add_options --enable-debug-modules
245ac_add_options --enable-debugger-info-modules
246ac_add_options --enable-crash-on-assert
247%else
248ac_add_options --disable-debug
249ac_add_options --disable-debug-modules
250ac_add_options --disable-logging
251ac_add_options --enable-optimize="%{rpmcflags} -Os"
252%endif
253ac_add_options --disable-strip
254ac_add_options --disable-strip-libs
255%if %{with tests}
256ac_add_options --enable-tests
257%else
258ac_add_options --disable-tests
259%endif
260%if %{with gnomeui}
261ac_add_options --enable-gnomeui
262%else
263ac_add_options --disable-gnomeui
264%endif
265%if %{with gnomevfs}
266ac_add_options --enable-gnomevfs
267%else
268ac_add_options --disable-gnomevfs
269%endif
270%if %{with ldap}
271ac_add_options --enable-ldap
272ac_add_options --with-system-ldap
273%else
274ac_add_options --disable-ldap
275%endif
276%if %{with crashreporter}
277ac_add_options --enable-crashreporter
278%else
279ac_add_options --disable-crashreporter
280%endif
281ac_add_options --disable-xterm-updates
282ac_add_options --enable-postscript
283%if %{with lightning}
284ac_add_options --enable-calendar
285%else
286ac_add_options --disable-calendar
287%endif
288ac_add_options --disable-installer
289ac_add_options --disable-jsd
290ac_add_options --disable-updater
291ac_add_options --disable-xprint
292ac_add_options --disable-permissions
293ac_add_options --disable-pref-extensions
294ac_add_options --enable-canvas
295ac_add_options --enable-crypto
296ac_add_options --enable-mathml
297ac_add_options --enable-pango
298ac_add_options --enable-reorder
299ac_add_options --enable-startup-notification
300ac_add_options --enable-svg
301ac_add_options --enable-system-cairo
302ac_add_options --enable-system-hunspell
303ac_add_options --enable-system-sqlite
304ac_add_options --enable-xft
305ac_add_options --enable-application=mail
306ac_add_options --enable-default-toolkit=cairo-gtk2
307ac_add_options --enable-xinerama
308ac_add_options --with-distribution-id=org.pld-linux
309ac_add_options --with-branding=icedove/branding
310%if %{with xulrunner}
311#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
312ac_add_options --with-system-libxul
313ac_add_options --enable-shared
314ac_add_options --enable-libxul
315%else
316ac_add_options --disable-xul
317%endif
318ac_add_options --with-pthreads
319ac_add_options --with-system-bz2
320ac_add_options --with-system-jpeg
321ac_add_options --with-system-nspr
322ac_add_options --with-system-nss
323ac_add_options --with-system-png
324ac_add_options --with-system-zlib
325ac_add_options --enable-single-profile
326ac_add_options --disable-profilesharing
327ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
328EOF
329
330%{__make} -j1 -f client.mk build \
331 STRIP="/bin/true" \
332 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
333 CC="%{__cc}" \
334 CXX="%{__cxx}"
335
336%if %{with crashreporter}
337# create debuginfo for crash-stats.mozilla.com
338%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
339%endif
340
341%if %{with enigmail}
342cd mailnews/extensions/enigmail
343./makemake -r -o %{objdir}
344%{__make} -C %{objdir}/mailnews/extensions/enigmail \
345 STRIP="/bin/true" \
346 CC="%{__cc}" \
347 CXX="%{__cxx}"
348%endif
349
350%install
351rm -rf $RPM_BUILD_ROOT
352install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
353
354cd %{objdir}
355%{__make} -C mail/installer stage-package \
356 DESTDIR=$RPM_BUILD_ROOT \
357 MOZ_PKG_DIR=%{_libdir}/%{name} \
358 PKG_SKIP_STRIP=1
359
360# Enable crash reporter for Firefox application
361%if %{with crashreporter}
362%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
363
364# Add debuginfo for crash-stats.mozilla.com
365install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
366cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
367%endif
368
369# copy manually lightning files, somewhy they are not installed by make
370cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
371 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
372 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
373
374# move arch independant ones to datadir
375mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
376mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
377mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
378mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
379mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
380ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
381ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
382ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
383ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
384ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
385
386# dir for arch independant extensions besides arch dependant extensions
387# see mozilla/xpcom/build/nsXULAppAPI.h
388# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
389install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
390
391%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
392ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
393
394%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
395ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
396ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
397
398cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
399cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
400
401# files created by regxpcom -register in post
402touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
403touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
404cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
405#!/bin/sh
406umask 022
407# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
408# dangerous if you run this with sudo with keep_env += HOME
409# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
410t=$(mktemp -d)
411%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
412TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
413rm -rf $t
414EOF
415chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
416
417%if %{with enigmail}
418ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
419install -d $ext_dir/{chrome,components,defaults/preferences}
420cd mozilla/dist/bin
421#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
422#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
423cp -rfLp components/enig* $ext_dir/components
424cp -rfLp components/libenigmime.so $ext_dir/components
425cp -rfLp components/libipc.so $ext_dir/components
426cp -rfLp components/ipc.xpt $ext_dir/components
427cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
428cd -
429cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
430cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
431%endif
432
433# remove unecessary stuff
434%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
435#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
436#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
437
438# never package these. always remove
439# nss
440%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
441# nspr
442%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
443# mozldap
444%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
445
446%clean
447rm -rf $RPM_BUILD_ROOT
448
449%pretrans
450if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
451 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
452fi
453for d in chrome defaults icons isp modules res; do
454 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
455 install -d %{_datadir}/%{name}
456 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
457 fi
458done
459exit 0
460
461%post
462%{_libdir}/%{name}/register || :
463
464%files
465%defattr(644,root,root,755)
466%attr(755,root,root) %{_bindir}/icedove
467%attr(755,root,root) %{_bindir}/mozilla-thunderbird
468%attr(755,root,root) %{_bindir}/thunderbird
469%dir %{_libdir}/%{name}
470%{_libdir}/%{name}/application.ini
471%{_libdir}/%{name}/platform.ini
472%{_libdir}/%{name}/blocklist.xml
473%{_libdir}/%{name}/chrome.manifest
474%{_libdir}/%{name}/greprefs.js
475%dir %{_libdir}/%{name}/components
476%attr(755,root,root) %{_libdir}/%{name}/components/*.so
477%{_libdir}/%{name}/components/*.js
478%{_libdir}/%{name}/components/*.xpt
479%{_libdir}/%{name}/components/components.manifest
480%{_libdir}/%{name}/components/interfaces.manifest
481%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
482#%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
483%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
484#%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
485%attr(755,root,root) %{_libdir}/%{name}/libxul.so
486%attr(755,root,root) %{_libdir}/%{name}/*.sh
487%attr(755,root,root) %{_libdir}/%{name}/*-bin
488%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
489%attr(755,root,root) %{_libdir}/%{name}/icedove
490%attr(755,root,root) %{_libdir}/%{name}/plugin-container
491%attr(755,root,root) %{_libdir}/%{name}/register
492
493# symlinks
494%{_libdir}/%{name}/chrome
495%{_libdir}/%{name}/defaults
496%{_libdir}/%{name}/dictionaries
497#%%{_libdir}/%{name}/greprefs
498%{_libdir}/%{name}/isp
499%{_libdir}/%{name}/modules
500%{_libdir}/%{name}/res
501
502%{_pixmapsdir}/*.png
503%{_desktopdir}/*.desktop
504
505%dir %{_datadir}/%{name}
506%{_datadir}/%{name}/chrome
507%{_datadir}/%{name}/defaults
508#%%{_datadir}/%{name}/greprefs
509%{_datadir}/%{name}/isp
510%{_datadir}/%{name}/modules
511%{_datadir}/%{name}/res
512%{_datadir}/%{name}/extensions
513
514%if %{with crashreporter}
515%attr(755,root,root) %{_libdir}/%{name}/crashreporter
516%{_libdir}/%{name}/crashreporter.ini
517%{_libdir}/%{name}/Throbber-small.gif
518%endif
519
520%dir %{_libdir}/%{name}/extensions
521%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
522
523# files created by regxpcom -register
524%ghost %{_libdir}/%{name}/components/compreg.dat
525%ghost %{_libdir}/%{name}/components/xpti.dat
526
527%if %{with lightning}
528%files addon-lightning
529%defattr(644,root,root,755)
530%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
531%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
532%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
533%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
534%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
535%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
536%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
537%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
539%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
540%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
541%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
542%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
543%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
544%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
545%endif
546
547%if %{with enigmail}
548%files addon-enigmail
549%defattr(644,root,root,755)
550%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
551%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
552%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
553%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
554%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
555%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
556%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
557%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
558%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
559%endif
This page took 0.096603 seconds and 4 git commands to generate.