]> git.pld-linux.org Git - packages/ice.git/blame_incremental - ice.spec
- fix building with db 5.3
[packages/ice.git] / ice.spec
... / ...
CommitLineData
1# TODO
2# - finish (pldize) -servers package
3#
4# Conditional build:
5%bcond_without gui # IceGrid GUI
6%bcond_without dotnet # .NET bindings
7%bcond_without java # Java bindings
8%bcond_without php # PHP bindings
9%bcond_without python # Python bindings
10%bcond_without ruby # Ruby bindings
11
12%if %{without java}
13%undefine with_gui
14%endif
15
16%{?with_java:%include /usr/lib/rpm/macros.java}
17Summary: The Ice base runtime and services
18Name: ice
19Version: 3.4.2
20Release: 2
21License: GPL v2 with exceptions (see ICE_LICENSE)
22Group: Applications
23URL: http://www.zeroc.com/
24Source0: http://www.zeroc.com/download/Ice/3.4/Ice-%{version}.tar.gz
25# Source0-md5: e97672eb4a63c6b8dd202d0773e19dc7
26# Extracted from http://zeroc.com/download/Ice/3.4/ice-3.4.0-1.src.rpm
27Source1: Ice-rpmbuild-3.4.0.tar.gz
28# Source1-md5: 869cc60645e7e2b4115584a5ab17d1e9
29# Man pages courtesy of Francisco Moya's Debian packages
30Source2: Ice-3.3.0-man-pages.tbz2
31# Source2-md5: c6c17ee1be2e6b615af5b40edae88b75
32Source3: %{name}gridgui
33Source4: IceGridAdmin.desktop
34Patch0: %{name}-build.patch
35Patch1: dont-build-demo-test.patch
36Patch2: java-build.patch
37Patch3: jgoodies.patch
38Patch4: ice-gcc46.patch
39Patch5: ice-gcc47.patch
40Patch6: ice-db.patch
41BuildRequires: bzip2-devel
42BuildRequires: db-cxx-devel
43BuildRequires: expat-devel
44BuildRequires: mcpp-devel
45BuildRequires: openssl-devel
46BuildRequires: rpmbuild(macros) >= 1.533
47%if %{with gui}
48BuildRequires: ImageMagick
49BuildRequires: ImageMagick-coder-png
50%endif
51%if %{with dotnet}
52BuildRequires: mono-csharp
53%endif
54%if %{with java}
55BuildRequires: ant-nodeps
56BuildRequires: db-java-devel
57BuildRequires: java-jgoodies-common
58BuildRequires: java-jgoodies-forms
59BuildRequires: java-jgoodies-looks
60BuildRequires: jdk
61BuildRequires: jpackage-utils
62BuildRequires: rpm-javaprov
63%endif
64%if %{with php}
65BuildRequires: php-devel >= 3:5.0.0
66%endif
67%if %{with python}
68BuildRequires: python-devel
69BuildRequires: rpm-pythonprov
70%endif
71%if %{with ruby}
72BuildRequires: ruby >= 1:1.8.6
73BuildRequires: ruby-devel
74%endif
75# Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
76ExcludeArch: ppc64 sparc64
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79# Some file suffixes we need to grab the right stuff for the file lists
80%define soversion 34
81
82%description
83Ice is a modern alternative to object middleware such as CORBA or
84COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
85infrastructure for demanding technical applications. It features an
86object-oriented specification language, easy to use C++, C#, Java,
87Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
88protocol, asynchronous method invocation and dispatch, dynamic
89transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
90firewall solution, and much more.
91
92%package devel
93Summary: Tools for developing Ice applications in C++
94Group: Development/Libraries
95Requires: %{name} = %{version}-%{release}
96
97%description devel
98Tools for developing Ice applications in C++.
99
100%package servers
101Summary: Ice services to run through /etc/rc.d/init.d
102Group: Development/Tools
103Requires(post,preun): /sbin/chkconfig
104Requires: %{name} = %{version}-%{release}
105Requires: rc-scripts
106
107%description servers
108Ice services to run through /etc/rc.d/init.d
109
110%package -n icegrid-gui
111Summary: IceGrid Admin Tool
112Group: Development/Tools
113Requires: %{name} = %{version}-%{release}
114Requires: java-%{name} = %{version}-%{release}
115Requires: java-jgoodies-forms
116Requires: java-jgoodies-looks
117Requires: jpackage-utils
118
119%description -n icegrid-gui
120Graphical administration tool for IceGrid
121
122%package -n java-%{name}
123Summary: The Ice runtime for Java
124Group: Libraries/Java
125Requires: %{name} = %{version}-%{release}
126Requires: db-java
127Requires: jpackage-utils
128
129%description -n java-%{name}
130The Ice runtime for Java
131
132%package -n csharp-%{name}
133Summary: The Ice runtime for C#
134Group: Libraries
135Requires: %{name} = %{version}-%{release}
136Requires: mono >= 1.2.2
137
138%description -n csharp-%{name}
139The Ice runtime for C#
140
141%package -n ruby-%{name}
142Summary: The Ice runtime for Ruby applications
143Group: Development/Languages
144Requires: %{name} = %{version}-%{release}
145%{?ruby_mod_ver_requires_eq}
146
147%description -n ruby-%{name}
148The Ice runtime for Ruby applications.
149
150%package -n python-%{name}
151Summary: The Ice runtime for Python applications
152Group: Development/Languages/Python
153Requires: %{name} = %{version}-%{release}
154Requires: python >= 1:2.3.4
155
156%description -n python-%{name}
157The Ice runtime for Python applications.
158
159%package -n php-%{name}
160Summary: The Ice runtime for PHP applications
161Group: Development/Languages/PHP
162Requires: %{name} = %{version}-%{release}
163%{?requires_php_extension}
164
165%description -n php-%{name}
166The Ice runtime for PHP applications.
167
168%prep
169%setup -q -n Ice-%{version} -a1 -a2
170%patch0 -p0
171%patch1 -p1
172%patch2 -p1
173%patch3 -p1
174%patch4 -p1
175%patch5 -p1
176%patch6 -p1
177
178# no longer included in 3.4
179rm -f *man-pages/slice2docbook.1
180
181# Fix the encoding and line-endings of all the IceGridAdmin documentation files
182cd java/resources/IceGridAdmin
183%undos -f js,css
184
185for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
186 iconv -f ISO88591 -t UTF8 $f -o $f.tmp
187 mv $f.tmp $f
188done
189cd -
190
191%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' cpp/src/ca/iceca
192
193%if %{with java}
194# we nuke it only when we build new class later, as ice build system expects the file being around
195rm cpp/src/ca/ImportKey.class
196%endif
197
198# update path to our install
199sed -i -e 's,/usr/share/Ice-%{version},%{_datadir}/Ice,' cpp/src/ca/iceca Ice-rpmbuild-*/icegridregistry.conf
200
201# force our CC/CXX as build system compares for exactly "c++" to setup other rules
202sed -i -e 's,c++,%{__cxx},g' cpp/config/Make.rules.Linux
203
204%build
205# Compile the main Ice runtime
206# TODO: CC/CXX passing as make param breaks build system
207
208%if %{with java}
209# Rebuild the Java ImportKey class - need it early for main cpp build
210javac cpp/src/ca/ImportKey.java
211%endif
212
213%{__make} -j1 -C cpp \
214 CC="%{__cc}" \
215 CXX="%{__cxx}" \
216 CFLAGS="%{rpmcflags} -fPIC" \
217 CXXFLAGS="%{rpmcxxflags} -fPIC" \
218 embedded_runpath_prefix=""
219
220%if %{with gui}
221# Create the IceGrid icon
222convert java/resources/icons/icegrid.ico temp.png
223mv temp-8.png java/resources/icons/icegrid.png
224rm temp*.png
225%endif
226
227%if %{with java}
228
229# Set the CLASSPATH correctly for the Java compile
230export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
231
232%{__make} -j1 -C java \
233 CC="%{__cc}" \
234 CXX="%{__cxx}" \
235 CFLAGS="%{rpmcflags} -fPIC" \
236 CXXFLAGS="%{rpmcxxflags} -fPIC" \
237 embedded_runpath_prefix=""
238%endif
239
240%if %{with dotnet}
241%{__make} -j1 -C cs \
242 CC="%{__cc}" \
243 CXX="%{__cxx}" \
244 CFLAGS="%{rpmcflags} -fPIC" \
245 CXXFLAGS="%{rpmcxxflags} -fPIC" \
246 embedded_runpath_prefix=""
247%endif
248
249%if %{with python}
250%{__make} -j1 -C py \
251 CC="%{__cc}" \
252 CXX="%{__cxx}" \
253 CFLAGS="%{rpmcflags} -fPIC" \
254 CXXFLAGS="%{rpmcxxflags} -fPIC" \
255 embedded_runpath_prefix=""
256%endif
257
258%if %{with ruby}
259%{__make} -j1 -C rb \
260 CC="%{__cc}" \
261 CXX="%{__cxx}" \
262 CFLAGS="%{rpmcflags} -fPIC" \
263 CXXFLAGS="%{rpmcxxflags} -fPIC" \
264 embedded_runpath_prefix=""
265%endif
266
267%if %{with php}
268%{__make} -j1 -C php \
269 CC="%{__cc}" \
270 CXX="%{__cxx}" \
271 PHP_HOME=%{_prefix} \
272 CFLAGS="%{rpmcflags} -fPIC" \
273 CXXFLAGS="%{rpmcxxflags} -fPIC" \
274 embedded_runpath_prefix=""
275%endif
276
277%install
278rm -rf $RPM_BUILD_ROOT
279install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_docdir}/Ice-%{version},%{_datadir}/Ice}
280
281%{__make} -C cpp install \
282 prefix=$RPM_BUILD_ROOT
283
284# Move the ImportKey.class file
285mv $RPM_BUILD_ROOT/lib/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
286
287mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
288mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
289mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
290
291mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
292
293# Copy the man pages into the correct directory
294install -d $RPM_BUILD_ROOT%{_mandir}/man1
295cp -a *man-pages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
296
297%if %{with java}
298%{__make} -C java install \
299 prefix=$RPM_BUILD_ROOT
300
301# Move Java stuff where it should be
302install -d $RPM_BUILD_ROOT%{_javadir}
303mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
304ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
305mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
306ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
307
308# Register ant target
309install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ant.d,%{_javadir}/ant}
310mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice-%{version}.jar
311ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice.jar
312echo 'ice ant/ant-ice' > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ice
313%endif
314
315%if %{with gui}
316# Install the IceGrid GUI
317install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
318mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
319cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
320install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
321cp -a java/resources/icons/icegrid.png $RPM_BUILD_ROOT%{_pixmapsdir}
322mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
323%endif
324
325%if %{with dotnet}
326install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
327%{__make} -C cs install \
328 prefix=$RPM_BUILD_ROOT \
329 GACINSTALL=yes \
330 GAC_ROOT=$RPM_BUILD_ROOT%{_prefix}/lib \
331
332mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
333# .NET spec files (for csharp-devel) -- convert the paths
334for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
335 sed -i -e "s#/lib/#%{_prefix}/lib/#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
336 sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
337 mv $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/$f.pc
338 mv $RPM_BUILD_ROOT%{_bindir}/$f.xml $RPM_BUILD_ROOT%{_prefix}/lib/mono/gac/$f/%{version}.*/
339done
340%endif
341
342%if %{with python}
343%{__make} -C py install \
344 prefix=$RPM_BUILD_ROOT
345%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
346install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
347mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
348rm -f $RPM_BUILD_ROOT/python/IcePy.so*
349mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
350cp -a Ice-rpmbuild-*/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
351%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
352%py_comp $RPM_BUILD_ROOT%{py_sitedir}
353%py_postclean
354%endif
355
356%if %{with ruby}
357%{__make} -C rb install \
358 prefix=$RPM_BUILD_ROOT
359%{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
360install -d $RPM_BUILD_ROOT%{ruby_sitearchdir}
361mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_sitearchdir}/IceRuby.so
362rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
363mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_sitearchdir}
364%endif
365
366%if %{with php}
367%{__make} -C php install \
368 prefix=$RPM_BUILD_ROOT
369# Put the PHP stuff into the right place
370install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
371cp -a Ice-rpmbuild-*/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
372mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
373mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
374%endif
375
376# move as last, bindings reinstall these if missing
377mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
378
379# Move the license files into the documentation directory
380mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
381mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
382# Copy in the other files too
383cp CHANGES RELEASE_NOTES $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
384
385# Install the servers
386install -d $RPM_BUILD_ROOT%{_sysconfdir}
387cp -a Ice-rpmbuild-*/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
388install -d $RPM_BUILD_ROOT%{_initrddir}
389for i in icegridregistry icegridnode glacier2router; do
390 cp -a Ice-rpmbuild-*/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
391done
392install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
393
394%clean
395rm -rf $RPM_BUILD_ROOT
396
397%post -p /sbin/ldconfig
398%postun -p /sbin/ldconfig
399
400%post -n php-%{name}
401%php_webserver_restart
402
403%postun -n php-%{name}
404if [ "$1" = 0 ]; then
405 %php_webserver_restart
406fi
407
408%files
409%defattr(644,root,root,755)
410%doc %{_docdir}/Ice-%{version}
411%attr(755,root,root) %{_bindir}/dumpdb
412%attr(755,root,root) %{_bindir}/glacier2router
413%attr(755,root,root) %{_bindir}/icebox
414%attr(755,root,root) %{_bindir}/iceboxadmin
415%attr(755,root,root) %{_bindir}/iceca
416%attr(755,root,root) %{_bindir}/icegridadmin
417%attr(755,root,root) %{_bindir}/icegridnode
418%attr(755,root,root) %{_bindir}/icegridregistry
419%attr(755,root,root) %{_bindir}/icepatch2calc
420%attr(755,root,root) %{_bindir}/icepatch2client
421%attr(755,root,root) %{_bindir}/icepatch2server
422%attr(755,root,root) %{_bindir}/icestormadmin
423%attr(755,root,root) %{_bindir}/icestormmigrate
424%attr(755,root,root) %{_bindir}/slice2html
425%attr(755,root,root) %{_bindir}/transformdb
426%{_mandir}/man1/dumpdb.1*
427%{_mandir}/man1/glacier2router.1*
428%{_mandir}/man1/icebox.1*
429%{_mandir}/man1/iceboxadmin.1*
430%{_mandir}/man1/icegridadmin.1*
431%{_mandir}/man1/icegridnode.1*
432%{_mandir}/man1/icegridregistry.1*
433%{_mandir}/man1/icepatch2calc.1*
434%{_mandir}/man1/icepatch2client.1*
435%{_mandir}/man1/icepatch2server.1*
436%{_mandir}/man1/icestormadmin.1*
437%{_mandir}/man1/slice2html.1*
438%{_mandir}/man1/transformdb.1*
439%attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
440%attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
441%attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
442%attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
443%attr(755,root,root) %{_libdir}/libIce.so.*.*.*
444%attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
445%attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
446%attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
447%attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
448%attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
449%attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
450%attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
451%attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
452%attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
453%attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
454%attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
455%attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
456%attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
457%attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
458%attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
459%attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
460%attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
461%attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
462%attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
463%attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
464%attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
465%attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
466%attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
467%attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
468%attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
469%{_datadir}/Ice
470
471%if %{with gui}
472# Exclude the stuff that's in IceGrid
473%exclude %{_docdir}/Ice-%{version}/IceGridAdmin
474%exclude %{_datadir}/Ice/IceGridGUI.jar
475
476%files -n icegrid-gui
477%defattr(644,root,root,755)
478%doc %{_docdir}/Ice-%{version}/IceGridAdmin
479%attr(755,root,root) %{_bindir}/icegridgui
480%{_datadir}/Ice/IceGridGUI.jar
481%{_mandir}/man1/icegridgui.1*
482%{_desktopdir}/IceGridAdmin.desktop
483%{_pixmapsdir}/icegrid.png
484%endif
485
486%files devel
487%defattr(644,root,root,755)
488%attr(755,root,root) %{_bindir}/slice2cpp
489%attr(755,root,root) %{_bindir}/slice2freeze
490%attr(755,root,root) %{_libdir}/libFreeze.so
491%attr(755,root,root) %{_libdir}/libGlacier2.so
492%attr(755,root,root) %{_libdir}/libIce.so
493%attr(755,root,root) %{_libdir}/libIceBox.so
494%attr(755,root,root) %{_libdir}/libIceDB.so
495%attr(755,root,root) %{_libdir}/libIceGrid.so
496%attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
497%attr(755,root,root) %{_libdir}/libIcePatch2.so
498%attr(755,root,root) %{_libdir}/libIceSSL.so
499%attr(755,root,root) %{_libdir}/libIceStorm.so
500%attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
501%attr(755,root,root) %{_libdir}/libIceStormService.so
502%attr(755,root,root) %{_libdir}/libIceUtil.so
503%attr(755,root,root) %{_libdir}/libIceXML.so
504%attr(755,root,root) %{_libdir}/libSlice.so
505%{_includedir}/Freeze
506%{_includedir}/Glacier2
507%{_includedir}/Ice
508%{_includedir}/IceBox
509%{_includedir}/IceGrid
510%{_includedir}/IcePatch2
511%{_includedir}/IceSSL
512%{_includedir}/IceStorm
513%{_includedir}/IceUtil
514%{_includedir}/IceXML
515%{_includedir}/Slice
516%{_mandir}/man1/slice2cpp.1*
517%{_mandir}/man1/slice2freeze.1*
518%if %{with java}
519%{_sysconfdir}/ant.d/ice
520%{_javadir}/ant/ant-ice-%{version}.jar
521%{_javadir}/ant/ant-ice.jar
522%endif
523
524%if %{with dotnet}
525%{_pkgconfigdir}/Glacier2.pc
526%{_pkgconfigdir}/Ice.pc
527%{_pkgconfigdir}/IceBox.pc
528%{_pkgconfigdir}/IceGrid.pc
529%{_pkgconfigdir}/IcePatch2.pc
530%{_pkgconfigdir}/IceStorm.pc
531%endif
532
533# as we do not have -devel for each binding, these are in main -devel
534# -csharp
535%attr(755,root,root) %{_bindir}/slice2cs
536%{_mandir}/man1/slice2cs.1*
537# -java
538%attr(755,root,root) %{_bindir}/slice2freezej
539%attr(755,root,root) %{_bindir}/slice2java
540%{_mandir}/man1/slice2freezej.1*
541%{_mandir}/man1/slice2java.1*
542# -php
543%attr(755,root,root) %{_bindir}/slice2php
544# -python
545%attr(755,root,root) %{_bindir}/slice2py
546%{_mandir}/man1/slice2py.1*
547# -ruby
548%attr(755,root,root) %{_bindir}/slice2rb
549%{_mandir}/man1/slice2rb.1*
550
551%files servers
552%defattr(644,root,root,755)
553%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
554%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
555%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
556%attr(754,root,root) /etc/rc.d/init.d/glacier2router
557%attr(754,root,root) /etc/rc.d/init.d/icegridnode
558%attr(754,root,root) /etc/rc.d/init.d/icegridregistry
559
560%if %{with dotnet}
561%files -n csharp-%{name}
562%defattr(644,root,root,755)
563%attr(755,root,root) %{_bindir}/iceboxnet.exe
564%{_mandir}/man1/iceboxnet.exe.1*
565%{_prefix}/lib/mono/Glacier2
566%{_prefix}/lib/mono/Ice
567%{_prefix}/lib/mono/IceBox
568%{_prefix}/lib/mono/IceGrid
569%{_prefix}/lib/mono/IcePatch2
570%{_prefix}/lib/mono/IceStorm
571
572%{_prefix}/lib/mono/gac/Glacier2
573%{_prefix}/lib/mono/gac/Ice
574%{_prefix}/lib/mono/gac/IceBox
575%{_prefix}/lib/mono/gac/IceGrid
576%{_prefix}/lib/mono/gac/IcePatch2
577%{_prefix}/lib/mono/gac/IceStorm
578
579%{_prefix}/lib/mono/gac/policy.3.4.Glacier2
580%{_prefix}/lib/mono/gac/policy.3.4.Ice
581%{_prefix}/lib/mono/gac/policy.3.4.IceBox
582%{_prefix}/lib/mono/gac/policy.3.4.IceGrid
583%{_prefix}/lib/mono/gac/policy.3.4.IcePatch2
584%{_prefix}/lib/mono/gac/policy.3.4.IceStorm
585%endif
586
587%if %{with python}
588%files -n python-%{name}
589%defattr(644,root,root,755)
590%{py_sitedir}/ice.pth
591%dir %{py_sitedir}/Ice
592%dir %{py_sitedir}/Ice/IceBox
593%dir %{py_sitedir}/Ice/IceGrid
594%dir %{py_sitedir}/Ice/IcePatch2
595%dir %{py_sitedir}/Ice/IceStorm
596%{py_sitedir}/Ice/*.py[co]
597%{py_sitedir}/Ice/IceBox/*.py[co]
598%{py_sitedir}/Ice/IceGrid/*.py[co]
599%{py_sitedir}/Ice/IcePatch2/*.py[co]
600%{py_sitedir}/Ice/IceStorm/*.py[co]
601%attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
602%endif
603
604%if %{with ruby}
605%files -n ruby-%{name}
606%defattr(644,root,root,755)
607%{ruby_sitearchdir}/Glacier2.rb
608%{ruby_sitearchdir}/Glacier2
609%{ruby_sitearchdir}/Ice.rb
610%{ruby_sitearchdir}/Ice
611%{ruby_sitearchdir}/IceBox.rb
612%{ruby_sitearchdir}/IceBox
613%{ruby_sitearchdir}/IceGrid.rb
614%{ruby_sitearchdir}/IceGrid
615%{ruby_sitearchdir}/IcePatch2.rb
616%{ruby_sitearchdir}/IcePatch2
617%{ruby_sitearchdir}/IceStorm.rb
618%dir %{ruby_sitearchdir}/IceStorm
619%{ruby_sitearchdir}/IceStorm/IceStorm.rb
620%attr(755,root,root) %{ruby_sitearchdir}/IceRuby.so
621%endif
622
623%if %{with java}
624%files -n java-%{name}
625%defattr(644,root,root,755)
626%{_javadir}/Freeze-%{version}.jar
627%{_javadir}/Freeze.jar
628%{_javadir}/Ice-%{version}.jar
629%{_javadir}/Ice.jar
630%endif
631
632%if %{with php}
633%files -n php-%{name}
634%defattr(644,root,root,755)
635%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
636%attr(755,root,root) %{php_extensiondir}/IcePHP.so
637%{php_data_dir}/Glacier2.php
638%{php_data_dir}/Glacier2
639%{php_data_dir}/Ice.php
640%{php_data_dir}/Ice
641%{php_data_dir}/IceBox.php
642%{php_data_dir}/IceBox
643%{php_data_dir}/IceGrid.php
644%{php_data_dir}/IceGrid
645%{php_data_dir}/IcePatch2.php
646%{php_data_dir}/IcePatch2
647%{php_data_dir}/IceStorm.php
648%{php_data_dir}/IceStorm
649%endif
This page took 0.080554 seconds and 4 git commands to generate.