]> git.pld-linux.org Git - projects/template-specs.git/blame_incremental - horde.spec
- name horde packages with horde- prefix
[projects/template-specs.git] / horde.spec
... / ...
CommitLineData
1%define _hordeapp skeleton
2#define _snap 2005-08-01
3#define _rc rc1
4%define _rel 1
5
6# REPLACE words 'SKELETON', 'Skeleton', 'skeleton' with your application
7# GET THE Summary from here: http://www.horde.org/source/modules.php
8# FIND .htaccess FILES AND MAKE SURE APACHE CONF DISABLES ACCESS TO
9# THOSE DIRS: find -name '.??*' IS EASY TO LOCATE.
10
11%include /usr/lib/rpm/macros.php
12Summary: Template for horde projects
13Name: horde-%{_hordeapp}
14Version: 0.1
15Release: %{?_rc:0.%{_rc}.}%{?_snap:0.%(echo %{_snap} | tr -d -).}%{_rel}
16License: GPL v2 (CHECK IT FIRST, could be ASL)
17Group: Applications/WWW
18# due builder limitations can't have complrex macros in Source0
19#Source0: ftp://ftp.horde.org/pub/skeleton/%{_hordeapp}-h3-%{version}.tar.gz
20#Source0: ftp://ftp.horde.org/pub/skeleton/%{_hordeapp}-h3-%{version}-%{_rc}.tar.gz
21#Source0: ftp://ftp.horde.org/pub/snaps/%{_snap}/%{_hordeapp}-HEAD-%{_snap}.tar.gz
22# Source0-md5: -
23# COPY IN SOURCES ../SOURCES/ingo.conf AS SOURCE1 HERE:
24# cp ../SOURCES/{ingo,skeleton}.conf
25# DON'T FORGET TO :%s#ingo#skeleton#g in that file
26Source1: %{_hordeapp}.conf
27Patch0: %{_hordeapp}-prefs.patch
28URL: http://www.horde.org/skeleton/
29BuildRequires: rpm-php-pearprov >= 4.0.2-98
30BuildRequires: rpmbuild(macros) >= 1.226
31BuildRequires: tar >= 1:1.15.1
32Requires: apache >= 1.3.33-2
33Requires: apache(mod_access)
34Requires: horde >= 3.0
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38# horde accesses it directly in help->about
39%define _noautocompressdoc CREDITS
40%define _noautoreq 'pear(Horde.*)'
41
42%define hordedir /usr/share/horde
43%define _sysconfdir /etc/horde.org
44%define _appdir %{hordedir}/%{_hordeapp}
45
46# GET DESCRIPTION FROM PROJECT URL
47%description
48SKELETON
49
50The Horde Project writes web applications in PHP and releases them
51under the GNU Public License. For more information (including help
52with Skeleton) please visit <http://www.horde.org/>.
53
54%description -l pl
55SKELETON
56
57Projekt Horde tworzy aplikacje WWW w PHP i wydaje je na licencji GNU
58