]> git.pld-linux.org Git - packages/highway.git/blame_incremental - highway.spec
- updated to 1.0.3 (new sonames)
[packages/highway.git] / highway.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4%bcond_without tests # don't build tests
5#
6Summary: Efficient and performance-portable SIMD
7Summary(pl.UTF-8): Wydajne i przenośne operacje SIMD
8Name: highway
9Version: 1.0.3
10Release: 1
11License: Apache v2.0
12Group: Libraries
13#Source0Download: https://github.com/google/highway/releases
14Source0: https://github.com/google/highway/archive/%{version}/%{name}-%{version}.tar.gz
15# Source0-md5: d591cf12d8d1f9f237a015ffc691b7c2
16URL: https://github.com/google/highway
17BuildRequires: cmake >= 3.10
18%{?with_tests:BuildRequires: gtest-devel}
19BuildRequires: libstdc++-devel >= 6:4.7
20BuildRequires: rpm-build >= 4.6
21BuildRequires: rpmbuild(macros) >= 1.742
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Highway is a C++ library for SIMD (Single Instruction, Multiple Data),
26i.e. applying the same operation to multiple 'lanes' using a single
27CPU instruction.
28
29%description -l pl.UTF-8
30Highway to biblioteka C++ do operacji SIMD (Single Instruction,
31Multiple Data), czyli wykonywania tej samej operacji na wielu "pasach"
32przy użyciu pojedynczej instrukcji procesora.
33
34%package devel
35Summary: Header files for Highway library
36Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Highway
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41Header files for Highway library.
42
43%description devel -l pl.UTF-8
44Pliki nagłówkowe biblioteki Highway.
45
46%package test
47Summary: Highway test helper library
48Summary(pl.UTF-8): Biblioteka pomocnicza testów z użyciem biblioteki Highway
49Group: Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description test
53Highway test helper library.
54
55%description test -l pl.UTF-8
56Biblioteka pomocnicza testów z użyciem biblioteki Highway.
57
58%package test-devel
59Summary: Header files for Highway test library
60Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Highway test
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63Requires: %{name}-test = %{version}-%{release}
64Requires: gtest-devel
65
66%description test-devel
67Header files for Highway test library.
68
69%description test-devel -l pl.UTF-8
70Pliki nagłówkowe biblioteki Highway test.
71
72%package apidocs
73Summary: API documentation for Highway library
74Summary(pl.UTF-8): Dokumentacja API biblioteki Highway
75Group: Documentation
76BuildArch: noarch
77
78%description apidocs
79API documentation for Highway library.
80
81%description apidocs -l pl.UTF-8
82Dokumentacja API biblioteki Highway.
83
84%prep
85%setup -q
86
87%build
88install -d build
89cd build
90%cmake .. \
91 %{cmake_on_off tests BUILD_TESTING} \
92 -DCMAKE_INSTALL_INCLUDEDIR=include \
93 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
94 -DHWY_SYSTEM_GTEST=ON
95
96%{__make}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100
101%{__make} -C build install \
102 DESTDIR=$RPM_BUILD_ROOT
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%post test -p /sbin/ldconfig
111%postun test -p /sbin/ldconfig
112
113%files
114%defattr(644,root,root,755)
115%doc README.md
116%attr(755,root,root) %{_libdir}/libhwy.so.*.*.*
117%attr(755,root,root) %ghost %{_libdir}/libhwy.so.1
118%attr(755,root,root) %{_libdir}/libhwy_contrib.so.*.*.*
119%attr(755,root,root) %ghost %{_libdir}/libhwy_contrib.so.1
120
121%files devel
122%defattr(644,root,root,755)
123%attr(755,root,root) %{_libdir}/libhwy.so
124%attr(755,root,root) %{_libdir}/libhwy_contrib.so
125%dir %{_includedir}/hwy
126%{_includedir}/hwy/contrib
127%{_includedir}/hwy/ops
128%{_includedir}/hwy/*.h
129%{_pkgconfigdir}/libhwy.pc
130%{_pkgconfigdir}/libhwy-contrib.pc
131
132%files test
133%defattr(644,root,root,755)
134%attr(755,root,root) %{_libdir}/libhwy_test.so.*.*.*
135%attr(755,root,root) %ghost %{_libdir}/libhwy_test.so.1
136
137%files test-devel
138%defattr(644,root,root,755)
139%attr(755,root,root) %{_libdir}/libhwy_test.so
140%{_includedir}/hwy/tests
141%{_pkgconfigdir}/libhwy-test.pc
142
143%if %{with apidocs}
144%files apidocs
145%defattr(644,root,root,755)
146%doc g3doc/*.{md,pdf}
147%endif
This page took 0.113772 seconds and 4 git commands to generate.