]> git.pld-linux.org Git - packages/git-core.git/blame_incremental - git-core.spec
- updated to 1.7.10.4 (memory corruption bugfixes).
[packages/git-core.git] / git-core.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # don't perform make test
4%bcond_with tests_cvs # perform tests which use CVS
5%bcond_with tests_svn # perform tests which use subversion
6%bcond_without doc # skip building/packaging docs/manuals (takes some time)
7
8%include /usr/lib/rpm/macros.perl
9Summary: Distributed version control system focused on speed, effectivity and usability
10Summary(pl.UTF-8): Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
11Name: git-core
12Version: 1.7.10.4
13Release: 1
14License: GPL v2
15Group: Development/Tools
16# Source0: http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
17Source0: http://git-core.googlecode.com/files/git-%{version}.tar.gz
18# Source0-md5: 68319d593d051ef76c26e945bbd2d7ac
19Source1: %{name}-gitweb.conf
20Source2: %{name}-gitweb-httpd.conf
21Source3: %{name}-gitweb-lighttpd.conf
22Source4: %{name}.sysconfig
23Source5: %{name}.inet
24Source6: %{name}.init
25Patch0: %{name}-tests.patch
26Patch1: %{name}-key-bindings.patch
27Patch2: %{name}-sysconfdir.patch
28URL: http://git-scm.com/
29BuildRequires: autoconf >= 2.59
30BuildRequires: automake
31BuildRequires: curl-devel
32BuildRequires: expat-devel
33BuildRequires: gettext-devel
34BuildRequires: openssl-devel
35BuildRequires: perl-Error > 0.15
36BuildRequires: perl-base
37BuildRequires: python-devel
38BuildRequires: rpm-perlprov >= 4.1-13
39BuildRequires: rpm-pythonprov
40BuildRequires: rpmbuild(macros) >= 1.264
41BuildRequires: tcl
42BuildRequires: zlib-devel
43%if %{with doc}
44BuildRequires: asciidoc >= 7.1.2-3
45BuildRequires: docbook-dtd45-xml
46BuildRequires: xmlto
47%endif
48%if %{with tests}
49%if %{with tests_cvs}
50# tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
51BuildRequires: cvs-gnu-client < 1.13
52BuildRequires: cvs-gnu-client >= 1.12
53%endif
54Conflicts: pdksh < 5.2.14-46
55%endif
56Requires: coreutils
57Requires: diffutils
58Requires: findutils
59Requires: grep
60Requires: openssh-clients
61Requires: perl-Error
62Requires: perl-Git = %{version}-%{release}
63Requires: sed
64Suggests: git-core-cvs
65Suggests: git-core-svn
66Suggests: less
67Suggests: rsync
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70# html docs have links to txt files
71%define _noautocompressdoc *.txt
72
73%define webapp gitweb
74%define webappdir %{_sysconfdir}/webapps/%{webapp}
75%define appdir %{_datadir}/%{webapp}
76%define cgibindir %{_prefix}/lib/cgi-bin
77
78%description
79"git" can mean anything, depending on your mood.
80
81- random three-letter combination that is pronounceable, and not
82 actually used by any common UNIX command. The fact that it is a
83 mispronunciation of "get" may or may not be relevant.
84- stupid. contemptible and despicable. simple. Take your pick from the
85 dictionary of slang.
86- "global information tracker": you're in a good mood, and it actually
87 works for you. Angels sing, and a light suddenly fills the room.
88- "goddamn idiotic truckload of sh*t": when it breaks
89
90This is a stupid (but extremely fast) directory content manager. It
91doesn't do a whole lot, but what it 'does' do is track directory
92contents efficiently.
93
94%description -l pl.UTF-8
95"git" może oznaczać cokolwiek, w zależności od nastroju.
96
97- losową kombinację trzech liter, która jest wymawialna i właściwie
98 nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
99 błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
100- głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
101- "global information tracker" (narzędzie do globalnego śledzenia
102 informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
103 Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
104- "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
105 g*) - kiedy się zepsuje.
106
107Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
108Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
109katalogu.
110
111%package doc
112Summary: Documentation for git-core
113Summary(pl.UTF-8): Dokumentacja do git-core
114Group: Documentation
115
116%description doc
117Documentation for git-core.
118
119%description doc -l pl.UTF-8
120Dokumentacja do git-core.
121
122%description doc -l fr.UTF-8
123Javadoc pour git-core.
124
125%package daemon-inetd
126Summary: Files necessary to run git-daemon as an inetd service
127Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
128Group: Networking/Daemons
129Requires: %{name} = %{version}-%{release}
130Requires: setup >= 2.4.11-1
131Provides: git-core-daemon
132Obsoletes: git-core-daemon
133Obsoletes: git-core-daemon-standalone
134
135%description daemon-inetd
136Git-daemon is a really simple TCP git daemon that can serve git
137repositories. This package provides all necessarry files to run
138git-daemon as an inetd service.
139
140%description daemon-inetd -l pl.UTF-8
141Git-daemon to prosty demon git korzystający z protokołu TCP do
142udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
143do uruchomienia git-demona w trybie usługi inetd.
144
145%package daemon-standalone
146Summary: Files necessary to run git-daemon as a standalone service
147Summary(pl.UTF-8): Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
148Group: Networking/Daemons
149Requires: %{name} = %{version}-%{release}
150Provides: git-core-daemon
151Obsoletes: git-core-daemon
152Obsoletes: git-core-daemon-inetd
153
154%description daemon-standalone
155Git-daemon is a really simple TCP git daemon that can serve git
156repositories. This package provides all necessarry files to run
157git-daemon as an standalone service.
158
159%description daemon-standalone -l pl.UTF-8
160Git-daemon to prosty demon git korzystający z protokołu TCP do
161udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
162do uruchomienia git-daemona w trybie usługi samodzielnej.
163
164%package devel
165Summary: Header files for git-core
166Summary(pl.UTF-8): Pliki nagłówkowe dla git-core
167Group: Development/Libraries
168Requires: zlib-devel
169
170%description devel
171Header files for git-core.
172
173%description devel -l pl.UTF-8
174Pliki nagłówkowe dla git-core.
175
176%package gitk
177Summary: Tcl/Tk interface to the Git version control system
178Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
179Group: Development/Tools
180Requires: %{name} = %{version}-%{release}
181Requires: tk
182
183%description gitk
184gitk displays changes in a repository or a selected set of commits.
185This includes visualizing the commit graph, showing information
186related to each commit, and the files in the trees of each revision.
187
188Historically, gitk was the first repository browser. It's written in
189Tcl/Tk and started off in a separate repository but was later merged
190into the main git repository.
191
192%description gitk -l pl.UTF-8
193gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
194Oznacza to wizualizację grafu commitów, wyświetlanie informacji
195związanych z każdym z commitów oraz listę plików dla każdej rewizji.
196
197Z historycznego punktu widzenia gitk był pierwszą przeglądarką
198repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
199osobnym repozytorium, ale z czasem został włączony do głównego
200repozytorium gita.
201
202%package gitweb
203Summary: Web frontend to git
204Summary(pl.UTF-8): Frontend WWW do gita
205Group: Development/Tools
206Requires: %{name} = %{version}-%{release}
207Requires: webapps
208Requires: webserver(alias)
209Requires: webserver(cgi)
210Suggests: webserver(setenv)
211
212%description gitweb
213This package provides a web interface for browsing git repositories.
214
215%description gitweb -l pl.UTF-8
216Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
217
218%package gitview
219Summary: A GTK+ based repository browser for git
220Summary(pl.UTF-8): Oparta na GTK+ przeglądarka repozytorium gita
221Group: Development/Tools
222Requires: %{name} = %{version}-%{release}
223Requires: python >= 1:2.4
224Requires: python-pycairo >= 1.0
225Requires: python-pygobject
226Requires: python-pygtk-gtk >= 2:2.8
227Suggests: python-gnome-desktop-gtksourceview
228
229%description gitview
230A GTK+ based repository browser for git.
231
232%description gitview -l pl.UTF-8
233Oparta na GTK+ przeglądarka repozytorium gita.
234
235%package gui
236Summary: Tcl/Tk interface to the Git version control system
237Summary(pl.UTF-8): Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
238Group: Development/Tools
239Requires: %{name} = %{version}-%{release}
240Requires: tk
241Requires: xdg-utils
242Suggests: meld
243
244%description gui
245Displays changes in a repository or a selected set of commits. This
246includes visualizing the commit graph, showing information related to
247each commit, and the files in the trees of each revision.
248
249Historically, gitk was the first repository browser. It's written in
250Tcl/Tk and started off in a separate repository but was later merged
251into the main git repository.
252
253%description gui -l pl.UTF-8
254Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
255to wizualizację grafu commitów, wyświetlanie informacji związanych z
256każdym z commitów oraz listę plików dla każdej rewizji.
257
258Z punktu widzenia historii, gitk był pierwszą przeglądarką
259repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
260osobnym repozytorium, ale z czasem został włączony do głównego
261repozytorium gita.
262
263%package svn
264Summary: Subversion support for Git
265Summary(pl.UTF-8): Obsługa Subversion dla Gita
266Group: Development/Tools
267Requires: %{name} = %{version}-%{release}
268Requires: perl-Encode
269Requires: perl-Term-ReadKey
270
271%description svn
272Subversion support for Git.
273
274%description svn -l pl.UTF-8
275Obsługa Subversion dla Gita.
276
277%package cvs
278Summary: CVS support for Git
279Summary(pl.UTF-8): Obsługa CVS dla Gita
280Group: Development/Tools
281Requires: %{name} = %{version}-%{release}
282Requires: cvsps >= 2.1-2
283Requires: rcs
284
285%description cvs
286CVS support for Git.
287
288%description cvs -l pl.UTF-8
289Obsługa CVS dla Gita.
290
291%package arch
292Summary: Git tools for importing Arch repositories
293Summary(pl.UTF-8): Narzędzia Gita do importowania repozytoriów Archa
294Group: Development/Tools
295Requires: %{name} = %{version}-%{release}
296Requires: tla
297
298%description arch
299Git tools for importing Arch repositories.
300
301%description arch -l pl.UTF-8
302Narzędzia Gita do importowania repozytoriów Archa.
303
304%package email
305Summary: Git tools for sending email
306Summary(pl.UTF-8): Narzędzia Gita do wysyłania poczty
307Group: Development/Tools
308Requires: %{name} = %{version}-%{release}
309
310%description email
311Git tools for sending email.
312
313%description email -l pl.UTF-8
314Narzędzia Gita do wysyłania poczty.
315
316%package -n bash-completion-git
317Summary: bash-completion for git
318Summary(pl.UTF-8): bashowe uzupełnianie nazw dla gita
319Group: Applications/Shells
320Requires: %{name} = %{version}-%{release}
321Requires: bash-completion
322
323%description -n bash-completion-git
324This package provides bash-completion for git.
325
326%description -n bash-completion-git -l pl.UTF-8
327Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
328
329%package -n perl-Git
330Summary: Perl interface to the Git version control system
331Summary(pl.UTF-8): Perlowy interfejs do systemu kontroli wersji Git
332Group: Development/Languages/Perl
333Obsoletes: perl-git-core
334
335%description -n perl-Git
336This module provides Perl scripts easy way to interface the Git
337version control system. The modules have an easy and well-tested way
338to call arbitrary Git commands; in the future, the interface will also
339provide specialized methods for doing easily operations which are not
340totally trivial to do over the generic command interface.
341
342%description -n perl-Git -l pl.UTF-8
343Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
344wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
345dowolne polecenia Gita; w przyszłości interfejs udostępni także
346specjalne metody do łatwego wykonywania operacji nietrywialnych do
347wykonania przy użyciu ogólnego interfejsu poleceń.
348
349%package -n python-Git
350Summary: Python Git remote helpers for non-git repositories
351Summary(pl.UTF-8): Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
352Group: Development/Languages/Python
353Requires: %{name} = %{version}-%{release}
354
355%description -n python-Git
356This package contains Python git_repote_helpers package - Git remote
357helpers for non-git repositories.
358
359%description -n python-Git -l pl.UTF-8
360Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
361pomocnicze Gita dla repozytoriów niegitowych.
362
363%package -n vim-syntax-gitcommit
364Summary: Vim syntax: gitcommit
365Summary(pl.UTF-8): Składnia dla Vima: gitcommit
366Group: Applications/Editors/Vim
367Requires: %{name} = %{version}-%{release}
368# for _vimdatadir existence
369Requires: vim-rt >= 4:6.3.058-3
370
371%description -n vim-syntax-gitcommit
372This plugin provides syntax highlighting for git's commit messages.
373
374%description -n vim-syntax-gitcommit -l pl.UTF-8
375Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
376
377%prep
378%setup -q -n git-%{version}
379%patch0 -p1
380%patch1 -p0
381%patch2 -p1
382
383%build
384%{__aclocal}
385%{__autoconf}
386%configure \
387 --sysconfdir=%{_sysconfdir}/git-core \
388 --with-openssl
389
390echo "BLK_SHA1=1" >> config.mak
391
392%{__make} \
393 INSTALLDIRS=vendor \
394 GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
395 GITWEB_PROJECTROOT="/var/lib/git" \
396 GITWEB_CSS="/gitweb/gitweb.css" \
397 GITWEB_LOGO="/gitweb/git-logo.png" \
398 GITWEB_FAVICON="/gitweb/git-favicon.png" \
399 V=1
400
401# use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
402%{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
403
404%if %{with tests}
405%if %{without tests_cvs}
406rm t/t*cvs*.sh || :
407%endif
408%{!?with_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
409%endif
410
411%install
412rm -rf $RPM_BUILD_ROOT
413install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
414install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
415install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
416install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
417cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
418[init]
419 templatedir = %{_sysconfdir}/%{name}/templates
420EOF
421
422%{__make} install \
423 INSTALLDIRS=vendor \
424 DESTDIR=$RPM_BUILD_ROOT
425
426%if %{with doc}
427%{__make} -C Documentation install \
428 DESTDIR=$RPM_BUILD_ROOT
429%endif
430
431# copy templates except sample hooks
432cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
433%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
434
435# header files and lib
436cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
437cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
438cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
439cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
440cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
441
442# bash completion
443install -d $RPM_BUILD_ROOT/etc/bash_completion.d
444cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
445
446# vim syntax
447install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
448cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
449autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG setf gitcommit
450autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
451autocmd BufNewFile,BufRead git-rebase-todo setf gitrebase
452autocmd BufNewFile,BufRead .msg.[0-9]*
453 \ if getline(1) =~ '^From.*# This line is ignored.$' |
454 \ setf gitsendemail |
455 \ endif
456autocmd BufNewFile,BufRead *.git/**
457 \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
458 \ setf git |
459 \ endif
460EOF
461
462# gitweb
463mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
464ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
465cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
466cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
467cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
468cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
469
470# gitview
471install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
472
473# git-daemon related files
474cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
475cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
476install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
477
478# paths cleanup
479sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
480sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
481
482# hardlink
483ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
484ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
485ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
486ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
487
488# remove unneeded files
489%{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
490%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
491%py_postclean
492
493mv $RPM_BUILD_ROOT%{_datadir}/locale/pt{_PT,}
494%find_lang git
495
496%clean
497rm -rf $RPM_BUILD_ROOT
498
499%post daemon-inetd
500%service -q rc-inetd reload
501
502%postun daemon-inetd
503if [ "$1" = "0" ]; then
504 %service -q rc-inetd reload
505fi
506
507%post daemon-standalone
508/sbin/chkconfig --add git-daemon
509%service git-daemon restart "git-daemon"
510
511%preun daemon-standalone
512if [ "$1" = "0" ]; then
513 %service git-daemon stop
514 /sbin/chkconfig --del git-daemon
515fi
516
517%triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
518%webapp_register apache %{webapp}
519
520%triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
521%webapp_unregister apache %{webapp}
522
523%triggerin gitweb -- apache < 2.2.0, apache-base
524%webapp_register httpd %{webapp}
525
526%triggerun gitweb -- apache < 2.2.0, apache-base
527%webapp_unregister httpd %{webapp}
528
529%triggerin gitweb -- lighttpd
530%webapp_register lighttpd %{webapp}
531
532%triggerun gitweb -- lighttpd
533%webapp_unregister lighttpd %{webapp}
534
535%files -f git.lang
536%defattr(644,root,root,755)
537%doc README contrib
538%attr(755,root,root) %{_bindir}/git
539%attr(755,root,root) %{_bindir}/git-receive-pack
540%attr(755,root,root) %{_bindir}/git-shell
541%attr(755,root,root) %{_bindir}/git-upload-archive
542%attr(755,root,root) %{_bindir}/git-upload-pack
543%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
544
545%if %{with doc}
546%{_mandir}/man1/git-*.1*
547%exclude %{_mandir}/man1/git-svn.1*
548%exclude %{_mandir}/man1/git-cvs*.1*
549%exclude %{_mandir}/man1/git-remote-helpers.1*
550%{_mandir}/man1/git.1*
551%{_mandir}/man5/gitattributes.5*
552%{_mandir}/man5/githooks.5*
553%{_mandir}/man5/gitignore.5*
554%{_mandir}/man5/gitmodules.5*
555%{_mandir}/man5/gitrepository-layout.5*
556%{_mandir}/man7/gitcli.7*
557%{_mandir}/man7/gitcore-tutorial.7*
558%{_mandir}/man7/gitcredentials.7*
559%{_mandir}/man7/gitdiffcore.7*
560%{_mandir}/man7/gitglossary.7*
561%{_mandir}/man7/gitnamespaces.7*
562%{_mandir}/man7/gitrevisions.7*
563%{_mandir}/man7/gittutorial-2.7*
564%{_mandir}/man7/gittutorial.7*
565%{_mandir}/man7/gitworkflows.7*
566%endif
567
568%dir %{_libdir}/%{name}
569%attr(755,root,root) %{_libdir}/%{name}/*-*
570%attr(755,root,root) %{_libdir}/%{name}/git
571%{_libdir}/%{name}/mergetools
572
573%exclude %{_libdir}/%{name}/git-gui
574%exclude %{_libdir}/%{name}/git-svn
575%exclude %{_libdir}/%{name}/git-archimport
576%exclude %{_libdir}/%{name}/git-cvs*
577%exclude %{_libdir}/%{name}/git-instaweb
578%exclude %{_libdir}/%{name}/git-remote-testgit
579%exclude %{_libdir}/%{name}/*email*
580
581%{_datadir}/%{name}
582
583%{_localstatedir}/lib/git
584
585%if %{with doc}
586%files doc
587%defattr(644,root,root,755)
588%doc Documentation/RelNotes*
589%doc Documentation/*.html Documentation/howto Documentation/technical
590%endif
591
592%files daemon-inetd
593%defattr(644,root,root,755)
594%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
595
596%files daemon-standalone
597%defattr(644,root,root,755)
598%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
599%attr(754,root, root) /etc/rc.d/init.d/git-daemon
600
601%files devel
602%defattr(644,root,root,755)
603%{_includedir}/%{name}
604%{_libdir}/libgit.a
605%{_libdir}/libgit_xdiff.a
606
607%files gitk
608%defattr(644,root,root,755)
609%if %{with doc}
610%{_mandir}/man1/gitk.1*
611%endif
612%attr(755,root,root) %{_bindir}/gitk
613%dir %{_datadir}/gitk
614%dir %{_datadir}/gitk/lib
615%dir %{_datadir}/gitk/lib/msgs
616%lang(de) %{_datadir}/gitk/lib/msgs/de.msg
617%lang(es) %{_datadir}/gitk/lib/msgs/es.msg
618%lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
619%lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
620%lang(it) %{_datadir}/gitk/lib/msgs/it.msg
621%lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
622%lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
623%lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
624%lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
625
626%files gitweb
627%defattr(644,root,root,755)
628%doc gitweb/{README,INSTALL}
629%dir %{webappdir}
630%config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
631%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
632%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
633%config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
634%attr(755,root,root) %{cgibindir}/gitweb.cgi
635%{appdir}
636%attr(755,root,root) %{_libdir}/%{name}/git-instaweb
637%if %{with doc}
638%{_mandir}/man1/gitweb.1*
639%{_mandir}/man5/gitweb.conf.5*
640%endif
641
642%files gitview
643%defattr(644,root,root,755)
644%doc contrib/gitview/gitview.txt
645%attr(755,root,root) %{_bindir}/gitview
646
647%files gui
648%defattr(644,root,root,755)
649%attr(755,root,root) %{_libdir}/%{name}/git-gui
650%dir %{_datadir}/git-gui
651%dir %{_datadir}/git-gui/lib
652%dir %{_datadir}/git-gui/lib/msgs
653%{_datadir}/git-gui/lib/git-gui.ico
654%{_datadir}/git-gui/lib/tclIndex
655%{_datadir}/git-gui/lib/*.js
656%{_datadir}/git-gui/lib/*.tcl
657%lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
658%lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
659%lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
660%lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
661%lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
662%lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
663%lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
664%lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
665%lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
666%lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
667%lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
668
669%files svn
670%defattr(644,root,root,755)
671%attr(755,root,root) %{_libdir}/%{name}/git-svn
672%if %{with doc}
673%{_mandir}/man1/git-svn.1*
674%endif
675
676%files cvs
677%defattr(644,root,root,755)
678%attr(755,root,root) %{_bindir}/git-cvsserver
679%attr(755,root,root) %{_libdir}/%{name}/git-cvs*
680%if %{with doc}
681%{_mandir}/man1/git-cvs*.1*
682%{_mandir}/man7/gitcvs-migration.7*
683%endif
684
685%files arch
686%defattr(644,root,root,755)
687%attr(755,root,root) %{_libdir}/%{name}/git-archimport
688%if %{with doc}
689%{_mandir}/man1/git-archimport.1*
690%endif
691
692%files email
693%defattr(644,root,root,755)
694%attr(755,root,root) %{_libdir}/%{name}/*email*
695%if %{with doc}
696%{_mandir}/man1/*email*.1*
697%endif
698
699%files -n bash-completion-git
700%defattr(644,root,root,755)
701/etc/bash_completion.d/git-completion.bash
702
703%files -n perl-Git
704%defattr(644,root,root,755)
705%{perl_vendorlib}/Git.pm
706%{perl_vendorlib}/Git
707%{_mandir}/man3/Git*.3pm*
708
709%files -n python-Git
710%defattr(644,root,root,755)
711%attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
712%dir %{py_sitescriptdir}/git_remote_helpers
713%{py_sitescriptdir}/git_remote_helpers/*.py[co]
714%dir %{py_sitescriptdir}/git_remote_helpers/git
715%{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
716%if "%{py_ver}" > "2.4"
717%{py_sitescriptdir}/git_remote_helpers*.egg-info
718%endif
719%if %{with doc}
720%{_mandir}/man1/git-remote-helpers.1*
721%endif
722
723%files -n vim-syntax-gitcommit
724%defattr(644,root,root,755)
725%doc contrib/vim/README
726%{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.035294 seconds and 4 git commands to generate.