]> git.pld-linux.org Git - packages/ggaoed.git/blame_incremental - ggaoed.spec
- peek & read netlink message in one shot since the default algorithm doesn't work...
[packages/ggaoed.git] / ggaoed.spec
... / ...
CommitLineData
1Summary: ggaoed - ATA over Ethernet target implementation for Linux
2Name: ggaoed
3Version: 1.1
4Release: 2
5License: GPL v2
6Group: Networking/Daemons
7Source0: http://ggaoed.googlecode.com/files/%{name}-%{version}.tar.gz
8# Source0-md5: 9d46d1b274e96547bb93bc5360a1db54
9Source1: %{name}.init
10Source2: %{name}.sysconfig
11Patch0: %{name}-build.patch
12Patch1: %{name}-netlink-rx-buffer-realloc.patch
13URL: http://code.google.com/p/ggaoed/
14BuildRequires: docbook2X >= 0.8
15BuildRequires: glib2-devel >= 2.12
16BuildRequires: libaio-devel >= 0.3.107
17BuildRequires: libatomic_ops >= 1.2
18BuildRequires: libblkid-devel
19BuildRequires: pkgconfig
20Requires(post,preun): /sbin/chkconfig
21Requires: rc-scripts
22Requires: uname(release) >= 2.6.31
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26ggaoed is an AoE (ATA over Ethernet) target implementation for Linux.
27It utilizes Linux kernel AIO, memory mapped sockets and other Linux
28features to provide the best performance.
29
30%prep
31%setup -q
32%patch0 -p1
33%patch1 -p1
34
35%build
36%configure
37%{__make}
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT%{_sharedstatedir}/ggaoed
42
43%{__make} install \
44 datarootdir=$RPM_BUILD_ROOT%{_datadir} \
45 sbindir=$RPM_BUILD_ROOT%{_sbindir} \
46 mandir=$RPM_BUILD_ROOT%{_mandir}
47
48install -D ggaoed.conf.dist $RPM_BUILD_ROOT%{_sysconfdir}/ggaoed.conf
49install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ggaoed
50install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ggaoed
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%post
56/sbin/chkconfig --add ggaoed
57/sbin/chkconfig ggaoed off
58%service ggaoed restart
59
60%preun
61if [ "$1" = "0" ]; then
62 /sbin/chkconfig --del ggaoed
63 %service ggaoed stop
64 # nuke config cache if uninstalling
65 rm -rf %{_sharedstatedir}/ggaoed/*
66fi
67
68%files
69%defattr(644,root,root,755)
70%doc NEWS README
71%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ggaoed.conf
72%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ggaoed
73%attr(754,root,root) /etc/rc.d/init.d/ggaoed
74%attr(755,root,root) %{_sbindir}/ggaoectl
75%attr(755,root,root) %{_sbindir}/ggaoed
76%{_mandir}/man5/ggaoed.conf.5*
77%{_mandir}/man8/ggaoectl.8*
78%{_mandir}/man8/ggaoed.8*
79%dir %{_sharedstatedir}/ggaoed
This page took 0.053416 seconds and 5 git commands to generate.