]> git.pld-linux.org Git - packages/gdome2.git/blame_incremental - gdome2.spec
- added no-common patch to fix build with -fno-common, gcc 10+ default; release 16
[packages/gdome2.git] / gdome2.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # static library
4
5Summary: DOM level2 library for accessing XML files
6Summary(pl.UTF-8): Biblioteka dostępu do plików XML, DOM poziom 2
7Name: gdome2
8Version: 0.8.1
9Release: 16
10License: LGPL v2.1+
11Group: Libraries
12Source0: http://gdome2.cs.unibo.it/tarball/%{name}-%{version}.tar.gz
13# Source0-md5: bfc114e59eec50cbda8e4ece751ff022
14Patch0: %{name}-glib2.patch
15Patch1: %{name}-build_fix.patch
16Patch2: format-security.patch
17Patch3: %{name}-destdir.patch
18Patch4: %{name}-no-common.patch
19URL: http://gdome2.cs.unibo.it/
20BuildRequires: autoconf
21BuildRequires: automake
22BuildRequires: glib2-devel >= 2.2.0
23BuildRequires: libtool
24BuildRequires: libxml2-devel >= 1:2.4.26
25BuildRequires: pkgconfig
26Requires: glib2 >= 2.2.0
27Requires: libxml2 >= 1:2.4.26
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31gdome2 is a fast, light and complete DOM level2 implementation based
32on libxml2. Although it has been written for the GNOME project, it can
33be used stand-alone.
34
35A DOM implementation (also called a host implementation) is what makes
36a parsed XML or HTML document available for processing via the DOM
37interface.
38
39gdome2 currently supports the "Core", "XML", "Events" and
40"MutationEvents" modules from the DOM2 Recommendation (see
41http://www.w3.org/TR/DOM-Level-2-Core/ and
42http://www.w3.org/TR/DOM-Level-2-Events/), and is supposed to become a
43full implementation of all the DOM Level2 standard.
44
45Now gdome2 also partially supports the XPath module from the DOM level
463 drafts.
47
48%description -l pl.UTF-8
49gdome2 jest szybką, lekką i kompletną implementacją poziomu 2 DOM
50opartą o libxml2. Pomimo, że gdome2 zostało napisane z myślą o
51projekcie GNOME, może być używane samodzielnie.
52
53Implementacja DOM (zwana również implementacją hosta) udostępnia
54przeanalizowany składniowo dokument XML lub HTML w celu dalszego jego
55przetwarzania poprzez interfejs DOM.
56
57gdome2 w chwili obecnej wspiera następujące moduły rekomendacji DOM2:
58"Core", "XML", "Events" oraz "MutationEvents" (więcej informacji można
59uzyskać pod adresem http://www.w3.org/TR/DOM-Level-2-Core/ oraz
60http://www.w3.org/TR/DOM-Level-2-Events/), a w przyszłości ma zostać
61pełną implementacją standardu poziomu 2 DOM.
62
63gdome2 wspiera również częściowo poziom 3 DOM, konkretnie XPath.
64
65%package devel
66Summary: Development files for gdome2
67Summary(pl.UTF-8): Pliki nagłówkowe gdome2
68Group: Development/Libraries
69Requires: %{name} = %{version}-%{release}
70Requires: glib2-devel >= 2.2.0
71Requires: libxml2-devel >= 1:2.4.26
72
73%description devel
74This package contains the header files and configuration scripts for
75developing with gdome2.
76
77gdome2 is a fast, light and complete DOM level2 implementation based
78on libxml2. Although it has been written for the GNOME project, it can
79be used stand-alone.
80
81A DOM implementation (also called a host implementation) is what makes
82a parsed XML or HTML document available for processing via the DOM
83interface.
84
85gdome2 currently supports the "Core", "XML", "Events" and
86"MutationEvents" modules from the DOM2 Recommendation (see
87http://www.w3.org/TR/DOM-Level-2-Core/ and
88http://www.w3.org/TR/DOM-Level-2-Events/), and is supposed to become a
89full implementation of all the DOM Level2 standard.
90
91Now gdome2 also partially supports the XPath module from the DOM level
923 drafts.
93
94%description devel -l pl.UTF-8
95Pakiet ten zawiera pliki nagłówkowe oraz skrypty konfiguracyjne
96potrzebne do rozwijania oprogramowania opartego o gdome2.
97
98gdome2 jest szybką, lekką i kompletną implementacją poziomu 2 DOM
99opartą o libxml2. Pomimo, że gdome2 zostało napisane z myślą o
100projekcie GNOME, może być używane samodzielnie.
101
102Implementacja DOM (zwana również implementacją hosta) udostępnia
103przeanalizowany składniowo dokument XML lub HTML w celu dalszego jego
104przetwarzania poprzez interfejs DOM.
105
106gdome2 w chwili obecnej wspiera następujące moduły rekomendacji DOM2:
107"Core", "XML", "Events" oraz "MutationEvents" (więcej informacji można
108uzyskać pod adresem http://www.w3.org/TR/DOM-Level-2-Core/ oraz
109http://www.w3.org/TR/DOM-Level-2-Events/), a w przyszłości ma zostać
110pełną implementacją standardu poziomu 2 DOM.
111
112gdome2 wspiera również częściowo poziom 3 DOM, konkretnie XPath.
113
114%package static
115Summary: Static libraries for gdome2
116Summary(pl.UTF-8): Biblioteki statyczne dla gdome2
117Group: Development/Libraries
118Requires: %{name}-devel = %{version}-%{release}
119
120%description static
121This package contains static libraries for developing with gdome2.
122
123%description static -l pl.UTF-8
124Pakiet ten zawiera statyczne biblioteki potrzebne do rozwijania
125oprogramowania opartego o gdome2.
126
127%package apidocs
128Summary: API documentation for gdome2 library
129Summary(pl.UTF-8): Dokumentacja API biblioteki gdome2
130Group: Documentation
131BuildArch: noarch
132
133%description apidocs
134API documentation for gdome2 library.
135
136%description apidocs -l pl.UTF-8
137Dokumentacja API biblioteki gdome2.
138
139%prep
140%setup -q
141%patch0 -p1
142%patch1 -p1
143%patch2 -p1
144%patch3 -p1
145%patch4 -p1
146
147# disable glib 1.x in order to force 2.x
148echo 'AM_DEFUN([AM_PATH_GLIB], [$3])' >> acinclude.m4
149
150%build
151%{__libtoolize}
152%{__aclocal}
153%{__autoconf}
154%{__autoheader}
155%{__automake}
156%configure \
157 %{!?with_static_libs:--disable-static} \
158 --with-html-dir=%{_gtkdocdir}
159
160%{__make}
161
162%install
163rm -rf $RPM_BUILD_ROOT
164
165%{__make} install \
166 DESTDIR=$RPM_BUILD_ROOT
167
168# obsoleted by pkg-config
169%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgdome.la
170
171%clean
172rm -rf $RPM_BUILD_ROOT
173
174%post -p /sbin/ldconfig
175%postun -p /sbin/ldconfig
176
177%files
178%defattr(644,root,root,755)
179%doc AUTHORS MAINTAINERS ChangeLog README
180%attr(755,root,root) %{_libdir}/libgdome.so.*.*.*
181%attr(755,root,root) %ghost %{_libdir}/libgdome.so.0
182
183%files devel
184%defattr(644,root,root,755)
185%attr(755,root,root) %{_bindir}/gdome-config
186%attr(755,root,root) %{_libdir}/libgdome.so
187%attr(755,root,root) %{_libdir}/gdomeConf.sh
188%{_includedir}/libgdome
189%{_mandir}/man1/gdome-config.1*
190%{_aclocaldir}/gdome2.m4
191%{_pkgconfigdir}/gdome2.pc
192
193%if %{with static_libs}
194%files static
195%defattr(644,root,root,755)
196%{_libdir}/libgdome.a
197%endif
198
199%files apidocs
200%defattr(644,root,root,755)
201%{_gtkdocdir}/gdome2-%{version}
This page took 0.064564 seconds and 5 git commands to generate.