]> git.pld-linux.org Git - packages/gdb.git/blame_incremental - gdb.spec
- switch on parallel building
[packages/gdb.git] / gdb.spec
... / ...
CommitLineData
1# NOTE
2# - Do not remove -lib package, it is required by FPC
3
4# TODO
5# - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
6#
7# Conditional build:
8%bcond_without python # build without python support
9
10Summary: A GNU source-level debugger for C, C++ and Fortran
11Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
12Summary(es.UTF-8): Depurador de programas C y otras lenguajes
13Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
14Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
15Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
16Summary(ru.UTF-8): Символический отладчик для C и других языков
17Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
18Summary(uk.UTF-8): Символьний відладчик для С та інших мов
19Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
20Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
21%define snap 20120926
22Name: gdb
23Version: 7.6.1
24Release: 1
25License: GPL v3+
26Group: Development/Debuggers
27Source0: http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
28# Source0-md5: fbc4dab4181e6e9937075b43a4ce2732
29Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
30# Source1-md5: 2e8a48939ae282c12bbacdd54e398247
31Source3: %{name}-gstack.man
32Patch100: gdb-6.6-buildid-locate.patch
33Patch101: gdb-6.6-buildid-locate-solib-missing-ids.patch
34Patch102: gdb-6.6-buildid-locate-rpm.patch
35Patch103: gdb-6.6-buildid-locate-core-as-arg.patch
36Patch104: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
37Patch105: gdb-6.3-gstack-20050411.patch
38Patch106: gdb-gdb-add-index-script.patch
39Patch1000: %{name}-readline.patch
40Patch1001: %{name}-info.patch
41Patch1002: %{name}-passflags.patch
42Patch1005: %{name}-pretty-print-by-default.patch
43Patch1006: buildid-locate-rpm-pld.patch
44URL: http://www.gnu.org/software/gdb/
45BuildRequires: autoconf >= 2.69
46BuildRequires: automake
47BuildRequires: bison
48BuildRequires: expat-devel
49BuildRequires: flex
50BuildRequires: gettext-devel
51BuildRequires: libselinux-devel
52BuildRequires: libtool
53BuildRequires: libunwind-devel >= 0.97
54BuildRequires: ncurses-devel >= 5.2
55BuildRequires: pkgconfig
56BuildRequires: readline-devel
57BuildRequires: rpmbuild(macros) >= 1.219
58BuildRequires: texinfo >= 4.4
59BuildRequires: zlib-devel
60%if %{with python}
61BuildRequires: python-devel
62BuildRequires: rpm-pythonprov
63Obsoletes: python-gdb
64# for traceback module
65Requires: python-modules
66%endif
67Requires: libunwind >= 0.97
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70%description
71Gdb is a full featured, command driven debugger. Gdb allows you to
72trace the execution of programs and examine their internal state at
73any time. Gdb works for C and C++ compiled with the GNU C compiler
74gcc.
75
76%description -l de.UTF-8
77dem Sie die Ausführung von Programmen verfolgen und jederzeit den
78inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
79kompiliertes C++.
80
81%description -l es.UTF-8
82Este es un debugger orientado a comandos repleto de características.
83Te permite rastrear la ejecución de programas y examinar su estado
84interno a cualquier momento. Funciona para C y C++ compilado con el
85compilador GNU C.
86
87%description -l fr.UTF-8
88Débugger complet, piloté par commandes. Permet de tracer l'exécution
89des programmes et d'examiner à tout moment leur état interne.
90Fonctionne avec les binaires C et C++ compilés avec le compilateur C
91de GNU, gcc.
92
93%description -l pl.UTF-8
94Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
95śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
96umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
97przy pomocy kompilatora GNU (gcc).
98
99%description -l pt_BR.UTF-8
100Este é um debugger orientado a comandos repleto de características.
101Ele permite à você rastrear a execução de programas e examinar o seu
102estado interno a qualquer momento. Ele funciona para para C e C++
103compilado com o compilador GNU C.
104
105%description -l ru.UTF-8
106Это полноценный отладчик, управляемый командами. Он позволяет
107трассировать исполнение программ и изучать их внутреннее состояние в
108любой момент времени. Работает с программами на C и C++,
109скомпилированными GNU компилятором C (gcc, egcs, pgcc).
110
111%description -l tr.UTF-8
112Bir komut arayüzü üzerinden programcıya programını adım adım izleme
113(trace) ve herhangi bir anda programın durumunu inceleme olanağı
114verir.
115
116%description -l uk.UTF-8
117Це повноцінний відладчик, що керується командами. Він дозволяє
118трасувати виконання програм та вивчати їх внутрішній стан в довільний
119момент часу. Працює з програмами на C та C++, зкомпільованими
120компіляторами GNU C (gcc, egcs, pgcc).
121
122%package gdbserver
123Summary: A standalone server for GDB (the GNU source-level debugger)
124Summary(pl.UTF-8): Samodzielny serwer GDB (debuggera GNU)
125Group: Development/Debuggers
126
127%description gdbserver
128GDB, the GNU debugger, allows you to debug programs written in C, C++,
129Java, and other languages, by executing them in a controlled fashion
130and printing their data.
131
132This package provides a program that allows you to run GDB on a
133different machine than the one which is running the program being
134debugged.
135
136%description gdbserver -l pl.UTF-8
137GDB (GNU debugger) pozwala śledzić programy napisane w C, C++, Javie i
138innych językach programowania poprzez wykonywanie ich w sposób
139kontrolowany oraz wypisywanie ich danych.
140
141Ten pakiet zawiera program pozwalający uruchamiać GDB na innej
142maszynie niż ta, na której działa śledzony program.
143
144%package lib
145Summary: GDB in the form of a static library
146Summary(pl.UTF-8): GDB w postaci biblioteki statycznej
147Group: Development/Debuggers
148# libraries that needs to be linked to fulfill libgdb.a symbol requirements
149Requires: binutils-devel >= 2.17.50
150Requires: expat-devel
151Requires: libselinux-devel
152Requires: libsepol-devel
153Requires: ncurses-devel
154Requires: python-devel
155Requires: readline-devel
156Requires: xz-devel
157Requires: zlib-devel
158
159%description lib
160GDB in the form of a static library.
161
162%description lib -l pl.UTF-8
163GDB w postaci biblioteki statycznej.
164
165%prep
166%setup -q
167
168# Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
169rm -f gdb/ada-exp.c gdb/ada-lex.c gdb/c-exp.c gdb/cp-name-parser.c gdb/f-exp.c
170rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
171
172%patch100 -p1
173%patch101 -p1
174%patch102 -p1
175%patch103 -p1
176%patch104 -p1
177%patch105 -p1
178%patch106 -p1
179
180%patch1000 -p1
181%patch1001 -p1
182%patch1002 -p1
183%patch1005 -p1
184%patch1006 -p1
185
186# Change the version that gets printed at GDB startup, so it is PLD Linux specific.
187cat > gdb/version.in << EOF
188%{version}-%{release} (PLD Linux)
189EOF
190
191sed -i -e 's#_GCC_AUTOCONF_VERSION\], \[2\.64\]#_GCC_AUTOCONF_VERSION], [2.69]#g' config/override.m4
192
193%build
194# omit hand-written gdb/testsuite aclocal.m4
195for dir in gdb gdb/gdbserver ; do
196 olddir=$(pwd)
197 cd $dir
198 %{__rm} aclocal.m4
199 %{__aclocal} $(grep '^ACLOCAL_AMFLAGS' Makefile.in | sed -e 's/.*=//')
200 cd $olddir
201done
202for dir in $(find gdb -name 'configure.in' -o -name 'configure.ac'); do
203 dir=$(dirname "$dir")
204 olddir=$(pwd)
205 cd $dir
206 %{__autoconf}
207 grep -q AC_CONFIG_HEADER configure.* && %{__autoheader}
208 cd $olddir
209done
210cp -f /usr/share/automake/config.* .
211# don't --enable-shared here, there would be libs version mismatch with binutils
212%configure \
213 --with-gdb-datadir=%{_datadir}/gdb \
214 --with-separate-debug-dir=/usr/lib/debug \
215%if %{with python}
216 --with-python=yes \
217 --with-pythondir=%{py_sitescriptdir} \
218%else
219 --without-python \
220%endif
221 --disable-gdbtk \
222 --disable-shared \
223 --enable-gdbcli \
224 --enable-gdbmi \
225 --enable-multi-ice \
226 --enable-netrom \
227 --enable-nls \
228 --enable-tui \
229 --with-system-readline \
230 --with-cpu=%{_target_cpu} \
231%ifnarch alpha
232 --with-mmalloc \
233%endif
234 --without-included-gettext \
235 --without-included-regex \
236 --without-x
237
238%{__make}
239%{__make} -j1 info
240
241# gdb/ChangeLog: Build gdb directly from *.o files not using libgdb.a.
242%{__make} -C gdb libgdb.a
243
244%install
245rm -rf $RPM_BUILD_ROOT
246install -d $RPM_BUILD_ROOT%{_infodir}
247
248%{__make} -j1 install install-info \
249 DESTDIR=$RPM_BUILD_ROOT
250
251# gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
252# window is created too.
253echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
254ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
255
256bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
257cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
258
259rm -f $RPM_BUILD_ROOT%{_infodir}/dir
260rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
261
262%if %{with python}
263# Temporarily now:
264for LIB in lib lib64; do
265 LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
266 install -d $LIBPATH
267done
268
269%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
270%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
271%py_postclean
272%endif
273
274cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
275
276install libdecnumber/libdecnumber.a $RPM_BUILD_ROOT%{_libdir}
277
278# Remove the files that are part of a gdb build but that are owned and provided by other packages.
279# These are part of binutils
280rm -rf $RPM_BUILD_ROOT%{_localedir}
281rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
282rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
283rm -f $RPM_BUILD_ROOT%{_infodir}/mmalloc*
284rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
285rm -rf $RPM_BUILD_ROOT%{_includedir}
286rm -rf $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,opcodes*,iberty*,mmalloc*}
287
288%clean
289rm -rf $RPM_BUILD_ROOT
290
291%post -p /sbin/postshell
292-/usr/sbin/fix-info-dir -c %{_infodir}
293
294%postun -p /sbin/postshell
295-/usr/sbin/fix-info-dir -c %{_infodir}
296
297%files
298%defattr(644,root,root,755)
299%doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
300%attr(755,root,root) %{_bindir}/gdb
301%attr(755,root,root) %{_bindir}/gdbtui
302%attr(755,root,root) %{_bindir}/gdb-add-index
303%attr(755,root,root) %{_bindir}/gstack
304%dir %{_datadir}/gdb
305%dir %{_datadir}/gdb/auto-load
306%dir %{_datadir}/gdb/auto-load%{_prefix}
307%dir %{_datadir}/gdb/auto-load%{_prefix}/lib
308%ifarch %{x8664}
309%dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
310%endif
311%{_datadir}/gdb/syscalls
312%{_datadir}/gdb/python
313%{_mandir}/man1/gdb.1*
314%{_mandir}/man1/gdbtui.1*
315%{_mandir}/man1/gstack.1*
316%lang(es) %{_mandir}/es/man1/*
317%lang(fr) %{_mandir}/fr/man1/*
318%lang(hu) %{_mandir}/hu/man1/*
319%lang(ja) %{_mandir}/ja/man1/*
320%lang(pl) %{_mandir}/pl/man1/*
321%{_infodir}/annotate.info*
322%{_infodir}/gdb.info*
323%{_infodir}/gdbint.info*
324%{_infodir}/stabs.info*
325
326%files gdbserver
327%defattr(644,root,root,755)
328%attr(755,root,root) %{_bindir}/gdbserver
329%{_mandir}/man1/gdbserver.1*
330%attr(755,root,root) %{_libdir}/libinproctrace.so
331
332%files lib
333%defattr(644,root,root,755)
334%{_libdir}/libdecnumber.a
335%{_libdir}/libgdb.a
This page took 0.036515 seconds and 4 git commands to generate.