]> git.pld-linux.org Git - packages/gdb.git/blame_incremental - gdb.spec
- updated to 6.8
[packages/gdb.git] / gdb.spec
... / ...
CommitLineData
1#
2# NOTE: Do not remove -lib package, it is required by FPC
3#
4Summary: A GNU source-level debugger for C, C++ and Fortran
5Summary(de.UTF-8): Symbolischer Debugger für C und andere Sprachen
6Summary(es.UTF-8): Depurador de programas C y otras lenguajes
7Summary(fr.UTF-8): Débugger symbolique pour C et d'autres langages
8Summary(pl.UTF-8): Symboliczny odpluskwiacz dla C i innych języków
9Summary(pt_BR.UTF-8): Depurador de programas C e outras linguagens
10Summary(ru.UTF-8): Символический отладчик для C и других языков
11Summary(tr.UTF-8): C ve diğer diller için sembolik hata ayıklayıcı
12Summary(uk.UTF-8): Символьний відладчик для С та інших мов
13Summary(zh_CN.UTF-8): [开发]C和其他语言的调试器
14Summary(zh_TW.UTF-8): [.-A開發]C和.$)B其.-A他語.$)B言的調試器
15Name: gdb
16Version: 6.8
17Release: 1
18License: GPL v3+
19Group: Development/Debuggers
20Source0: http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
21# Source0-md5: c9da266b884fb8fa54df786dfaadbc7a
22Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
23# Source1-md5: 2e8a48939ae282c12bbacdd54e398247
24Patch0: %{name}-readline.patch
25Patch1: %{name}-info.patch
26Patch2: %{name}-passflags.patch
27Patch4: %{name}-gdbinit-stat.patch
28Patch5: %{name}-pretty-print-by-default.patch
29Patch6: %{name}-absolute-gnu_debuglink-path.patch
30URL: http://www.gnu.org/software/gdb/
31BuildRequires: autoconf >= 2.53
32BuildRequires: automake
33BuildRequires: bison
34BuildRequires: flex
35BuildRequires: libtool
36BuildRequires: ncurses-devel >= 5.2
37BuildRequires: readline-devel >= 4.3
38BuildRequires: texinfo >= 4.4
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42Gdb is a full featured, command driven debugger. Gdb allows you to
43trace the execution of programs and examine their internal state at
44any time. Gdb works for C and C++ compiled with the GNU C compiler
45gcc.
46
47%description -l de.UTF-8
48dem Sie die Ausführung von Programmen verfolgen und jederzeit den
49inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
50kompiliertes C++.
51
52%description -l es.UTF-8
53Este es un debugger orientado a comandos repleto de características.
54Te permite rastrear la ejecución de programas y examinar su estado
55interno a cualquier momento. Funciona para C y C++ compilado con el
56compilador GNU C.
57
58%description -l fr.UTF-8
59Débugger complet, piloté par commandes. Permet de tracer l'exécution
60des programmes et d'examiner à tout moment leur état interne.
61Fonctionne avec les binaires C et C++ compilés avec le compilateur C
62de GNU, gcc.
63
64%description -l pl.UTF-8
65Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
66śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
67umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
68przy pomocy kompilatora GNU (gcc).
69
70%description -l pt_BR.UTF-8
71Este é um debugger orientado a comandos repleto de características.
72Ele permite à você rastrear a execução de programas e examinar o seu
73estado interno a qualquer momento. Ele funciona para para C e C++
74compilado com o compilador GNU C.
75
76%description -l ru.UTF-8
77Это полноценный отладчик, управляемый командами. Он позволяет
78трассировать исполнение программ и изучать их внутреннее состояние в
79любой момент времени. Работает с программами на C и C++,
80скомпилированными GNU компилятором C (gcc, egcs, pgcc).
81
82%description -l tr.UTF-8
83Bir komut arayüzü üzerinden programcıya programını adım adım izleme
84(trace) ve herhangi bir anda programın durumunu inceleme olanağı
85verir.
86
87%description -l uk.UTF-8
88Це повноцінний відладчик, що керується командами. Він дозволяє
89трасувати виконання програм та вивчати їх внутрішній стан в довільний
90момент часу. Працює з програмами на C та C++, зкомпільованими
91компіляторами GNU C (gcc, egcs, pgcc).
92
93%package lib
94Summary: GDB in the form of a static library
95Summary(pl.UTF-8): GDB w postaci biblioteki statycznej
96Group: Development/Debuggers
97#Requires: binutils-devel >= 2.17.50
98
99%description lib
100GDB in the form of a static library.
101
102%description lib -l pl.UTF-8
103GDB w postaci biblioteki statycznej.
104
105%prep
106%setup -q
107%patch0 -p1
108%patch1 -p1
109%patch2 -p1
110%patch4 -p0
111%patch5 -p1
112%patch6 -p1
113
114%build
115for dir in `find gdb/ -name 'configure.in'`; do
116 dir=$(dirname "$dir")
117 olddir=$(pwd)
118 cd $dir
119 rm -f aclocal.m4
120 %{__aclocal}
121 %{__autoconf}
122 cd $olddir
123done
124cp -f /usr/share/automake/config.* .
125# don't --enable-shared here, there would be libs version mismatch with binutils
126%configure \
127 --disable-gdbtk \
128 --disable-shared \
129 --enable-gdbcli \
130 --enable-gdbmi \
131 --enable-multi-ice \
132 --enable-netrom \
133 --enable-nls \
134 --enable-tui \
135 --with-cpu=%{_target_cpu} \
136%ifnarch alpha
137 --with-mmalloc \
138%endif
139 --without-included-gettext \
140 --without-included-regex \
141 --without-x
142
143%{__make}
144%{__make} info
145
146%install
147rm -rf $RPM_BUILD_ROOT
148install -d $RPM_BUILD_ROOT%{_infodir}
149
150%{__make} install install-info \
151 prefix=$RPM_BUILD_ROOT%{_prefix} \
152 bindir=$RPM_BUILD_ROOT%{_bindir} \
153 sbindir=$RPM_BUILD_ROOT%{_sbindir} \
154 infodir=$RPM_BUILD_ROOT%{_infodir} \
155 includedir=$RPM_BUILD_ROOT%{_includedir} \
156 libdir=$RPM_BUILD_ROOT%{_libdir} \
157 mandir=$RPM_BUILD_ROOT%{_mandir}
158
159bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
160
161install gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
162
163%clean
164rm -rf $RPM_BUILD_ROOT
165
166%post -p /sbin/postshell
167-/usr/sbin/fix-info-dir -c %{_infodir}
168
169%postun -p /sbin/postshell
170-/usr/sbin/fix-info-dir -c %{_infodir}
171
172%files
173%defattr(644,root,root,755)
174%doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
175%attr(755,root,root) %{_bindir}/*
176%{_mandir}/man1/*
177%lang(es) %{_mandir}/es/man1/*
178%lang(fr) %{_mandir}/fr/man1/*
179%lang(hu) %{_mandir}/hu/man1/*
180%lang(ja) %{_mandir}/ja/man1/*
181%lang(pl) %{_mandir}/pl/man1/*
182%{_infodir}/gdb*.info*
183%{_infodir}/stabs*.info*
184
185%files lib
186%defattr(644,root,root,755)
187%{_libdir}/libgdb.a
This page took 0.046 seconds and 4 git commands to generate.