]> git.pld-linux.org Git - packages/galeon.git/blame_incremental - galeon.spec
- updated gettext BR
[packages/galeon.git] / galeon.spec
... / ...
CommitLineData
1#
2# TODO:
3# - force galeon to use old SSL dialogs using nsIBadCertListener, ie. port
4# EphyBadCertRejector from Epiphany, this will fix issues with https sites
5# using self signed and expired certificates or mismatches in domain names
6#
7# Conditional build:
8%bcond_with nautilus # enable nautilus view
9%bcond_with gcc2 # compile using gcc2 to get working gcc2-compiled java
10 # plugin (better get gcc3-compiled one).
11 # Flash plugin seems to still not work, use
12 # mozilla instead. To compile wit this option, You
13 # have to install mozilla compiled with gcc2.
14#
15Summary: Galeon - gecko-based GNOME web browser
16Summary(pl.UTF-8): Galeon - przeglądarka WWW dla GNOME
17Summary(pt_BR.UTF-8): O galeon é um browser para o GNOME baseado no mozilla
18Summary(zh_CN.UTF-8): 基于Gecko的GNOME流览器
19Name: galeon
20Version: 2.0.7
21Release: 13
22Epoch: 2
23License: GPL
24Group: X11/Applications/Networking
25Source0: http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
26# Source0-md5: 2eede1f43e3f6f2ac4ce7d4db99b15b2
27Source1: %{name}-config-tool.1
28Patch0: %{name}-desktop.patch
29Patch1: %{name}-home_etc.patch
30Patch2: %{name}-ti-agent.patch
31Patch3: %{name}-agent.patch
32Patch4: %{name}-libxul.patch
33Patch5: %{name}-xul_includes_fix.patch
34Patch6: %{name}-xulrunner-1_9_1.patch
35URL: http://galeon.sourceforge.net/
36BuildRequires: GConf2-devel >= 2.4.0
37BuildRequires: ORBit2-devel >= 2.8.3
38BuildRequires: autoconf >= 2.52
39BuildRequires: automake
40BuildRequires: bison
41BuildRequires: gettext-tools
42BuildRequires: glib2-devel >= 1:2.4.4
43BuildRequires: gnome-desktop-devel >= 2.9.91
44BuildRequires: gnome-vfs2-devel >= 2.10.0-2
45BuildRequires: gtk+2-devel >= 2:2.4.4
46BuildRequires: intltool
47BuildRequires: libbonoboui-devel >= 2.4.0
48BuildRequires: libglade2-devel >= 1:2.4.0
49BuildRequires: libgnomeui-devel >= 2.6.0
50BuildRequires: libstdc++-devel
51BuildRequires: libtool
52BuildRequires: libxml2-devel >= 2.6.6
53BuildRequires: xulrunner-devel >= 1.9.1
54%{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
55BuildRequires: pkgconfig
56BuildRequires: rpm >= 4.4.9-56
57BuildRequires: rpmbuild(find_lang) >= 1.23
58BuildRequires: rpmbuild(macros) >= 1.197
59BuildRequires: scrollkeeper >= 0.1.4
60BuildRequires: sed >= 4.0
61Requires(post,postun): desktop-file-utils
62Requires(post,postun): scrollkeeper
63Requires(post,preun): GConf2
64Requires: glib2 >= 1:2.4.4
65Requires: gtk+2 >= 2:2.4.4
66Requires: libbonobo >= 2.4.0
67%requires_eq_to xulrunner xulrunner-devel
68Provides: wwwbrowser
69# sr@Latn vs. sr@latin
70Conflicts: glibc-misc < 6:2.7
71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73# can be provided by mozilla or mozilla-embedded
74%define _noautoreqdep libgtkembedmoz.so libgtksuperwin.so libxpcom.so
75# we have strict deps for it
76%define _noautoreq libxpcom.so
77
78%if %{with gcc2}
79%define __cc gcc2
80%define __cxx gcc2
81%endif
82
83%description
84GNOME browser based on Gecko (Mozilla rendering engine).
85
86%description -l pl.UTF-8
87Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
88interpretacji stron Mozilli).
89
90%description -l pt_BR.UTF-8
91O galeon é um browser para o GNOME baseado no mozilla.
92
93%prep
94%setup -q
95%patch0 -p1
96%patch1 -p1
97%if "%{pld_release}" == "ti"
98%patch2 -p1
99%else
100%patch3 -p1
101%endif
102%patch4 -p1
103%patch5 -p1
104%patch6 -p1
105
106sed -i -e 's#sr\@Latn#sr\@latin#' configure.in
107mv po/sr\@{Latn,latin}.po
108
109# regenerate - didn't compile with ORBit2 2.7.2
110cd idl
111orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
112mv Galeon*.[ch] ../src
113
114%build
115cp /usr/share/automake/mkinstalldirs .
116%{__glib_gettextize}
117%{__intltoolize}
118%{__libtoolize}
119%{__aclocal}
120%{__autoheader}
121%{__autoconf}
122%{__automake}
123%configure \
124 --disable-schemas-install \
125 %if %{with nautilus}
126 --enable-nautilus-view=yes
127 %else
128 --enable-nautilus-view=no
129 %endif
130%{__make}
131
132%install
133rm -rf $RPM_BUILD_ROOT
134install -d $RPM_BUILD_ROOT%{_mandir}/man1
135
136%{__make} install \
137 DESTDIR=$RPM_BUILD_ROOT
138
139install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
140
141# No components installed now.
142#rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
143
144# galeon-2.0.mo, but gnome/help/galeon
145%find_lang galeon-2.0 --with-gnome --with-omf --all-name
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%post
151%scrollkeeper_update_post
152%gconf_schema_install galeon.schemas
153%update_desktop_database_post
154
155%preun
156%gconf_schema_uninstall galeon.schemas
157
158%postun
159%scrollkeeper_update_postun
160%update_desktop_database_postun
161
162%files -f galeon-2.0.lang
163%defattr(644,root,root,755)
164%doc AUTHORS ChangeLog NEWS README*
165%attr(755,root,root) %{_bindir}/*
166%{_libdir}/bonobo/servers/*
167%{_datadir}/galeon
168%{_desktopdir}/*.desktop
169%{_datadir}/gnome-2.0/ui/*.xml
170%{_datadir}/sounds/galeon
171%{_pixmapsdir}/*
172%{_sysconfdir}/gconf/schemas/galeon.schemas
173%{_sysconfdir}/sound/events/*
174%{_mandir}/man1/*
This page took 0.030854 seconds and 5 git commands to generate.