]> git.pld-linux.org Git - packages/freetype1.git/blame_incremental - freetype1.spec
- added link patch to avoid pulling additional xorg deps (SM and ICE)
[packages/freetype1.git] / freetype1.spec
... / ...
CommitLineData
1# TODO:
2# - fix build with libtool-2
3#
4# Conditional build:
5%bcond_without static_libs # don't build static libraries
6#
7Summary: Truetype font rasterizer
8Summary(pl.UTF-8): Rasteryzer fontów Truetype
9Name: freetype1
10Version: 1.3.1
11Release: 13
12License: BSD-like
13Group: Libraries
14Source0: ftp://ftp.freetype.org/freetype/freetype1/freetype-%{version}.tar.gz
15# Source0-md5: 9a9e7ad00c1ef6dfbf8f8e19ceefb300
16Patch0: freetype-DESTDIR.patch
17Patch1: freetype-autoconf.patch
18Patch2: %{name}-po.patch
19Patch3: freetype-gcc33.patch
20Patch4: %{name}-parallel-make.patch
21Patch5: %{name}-link.patch
22URL: http://freetype.sourceforge.net/freetype1/index.html
23BuildRequires: autoconf
24BuildRequires: automake
25BuildRequires: gettext-devel
26BuildRequires: libtool
27BuildRequires: xorg-lib-libX11-devel
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31The FreeType engine is a free and portable TrueType font rendering
32engine. It has been developed to provide TrueType support to a great
33variety of platforms and environments.
34
35Note that FreeType is a *library*. It is not a font server for your
36favorite platform, even though it was designed to be used in many of
37them. Note also that it is *not* a complete text-rendering library.
38Its purpose is simply to open and manage font files, as well as load,
39hint and render individual glyphs efficiently. You can also see it as
40a "TrueType driver" for a higher-level library, though rendering text
41with it is extremely easy, as demo-ed by the test programs.
42
43%description -l pl.UTF-8
44FreeType jest biblioteką służącą do rasteryzacji fontów TrueType. Jest
45to jedynie biblioteka, a nie serwer fontów, chociaż została ona
46zaprojektowana do używania także w takich serwerach. Nie jest to też
47kompletna biblioteka do rasteryzacji tekstu. Jej celem jest tylko
48odczytywanie i zarządzanie plikami z fontami oraz wczytywanie i
49wykonywanie hintingu i rasteryzacji poszczególnych glifów. Może być
50także uważana za "sterownik TrueType" dla bibliotek wyższego poziomu,
51jednak użycie samej biblioteki FreeType do rasteryzacji jest bardzo
52proste, co można zobaczyć w programach demonstracyjnych.
53
54%package devel
55Summary: Header files and development documentation
56Summary(pl.UTF-8): Pliki nagłówkowe biblioteki freetype i dokumentacja
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Provides: freetype-devel = %{version}
60
61%description devel
62This package includes the header files documentations and libraries
63necessary to develop applications that use freetype.
64
65%description devel -l pl.UTF-8
66Pakiet ten zawiera pliki nagłówkowe oraz biblioteki niezbędne przy
67kompilowaniu programów wykorzystujących bibliotekę freetype.
68
69%package static
70Summary: Freetype static libraries
71Summary(pl.UTF-8): Biblioteki statyczne freetype
72Group: Development/Libraries
73Requires: %{name}-devel = %{version}-%{release}
74Provides: freetype-static = %{version}
75
76%description static
77Static freetype libraries.
78
79%description static -l pl.UTF-8
80Biblioteki statyczne freetype.
81
82%package progs
83Summary: Freetype library utilities
84Summary(pl.UTF-8): Programy użytkowe freetype
85Group: Applications
86Requires: %{name} = %{version}-%{release}
87Provides: freetype-progs = %{version}
88Obsoletes: freetype-utils
89Obsoletes: freetype-tools
90
91%description progs
92Freetype library utilites:
93- ftimer - a simple performance timer for the engine,
94- fzoom - very simple glyph viewer,
95- ftlint - program will hint each glyph of a font file, at a given
96 point size,
97- ftwiew - display all glyphs in a given font, applying hinting to
98 each one,
99- fdump - a simple TrueType font or collection dumper,
100- ftstring - a simple program to show off string text generation.
101- ftstrpn - convert a rendered text string into the PGM or PBM format,
102- fterror - small test program. Tests the gettext() functionality for
103 internationalized messages.
104
105%description progs -l pl.UTF-8
106Przykładowe aplikacje wykorzystujące freetype:
107- ftimer - narzędzie mierzące szybkość silnika
108- fzoom - prosta przeglądarka glifów
109- ftlint - program robiący hinting każdego glifu z fontu przy podanym
110 rozmiarze
111- ftview - program wyświetlający z hintingiem wszystkie glify z fontu
112- fdump - narzędzie zrzucające dane z fontu lub zestawu fontów TT
113- ftstring - prosty program obrazujący generowanie tekstu
114- ftstrpn - konwerter zrenderowanego tekstu na format PGM/PBM
115- fterror - prosty program testujący działanie gettext() w
116 zlokalizowanych komunikatach.
117
118%prep
119%setup -q -n freetype-%{version}
120%patch0 -p1
121%patch1 -p1
122%patch2 -p1
123%patch3 -p1
124%patch4 -p1
125%patch5 -p1
126
127%build
128install /usr/share/automake/missing .
129%{__gettextize}
130# gettextize stupidity (doesn't see intl/Makefile in next lines after AC_OUTPUT)
131sed -e 's@\(AC_OUTPUT.*\) intl/Makefile@\1@' configure.in > configure.in.tmp
132mv -f configure.in.tmp configure.in
133%{__libtoolize}
134%{__aclocal}
135%{__autoconf}
136%configure \
137 %{?with_static_libs:--enable-static} \
138 --with-gnu-ld
139%{__make}
140
141%install
142rm -rf $RPM_BUILD_ROOT
143
144%{__make} install \
145 DESTDIR=$RPM_BUILD_ROOT
146
147%find_lang freetype
148
149# resolve conflict with freetype-demos-2.*
150mv -f $RPM_BUILD_ROOT%{_bindir}/{ftdump,ft1dump}
151mv -f $RPM_BUILD_ROOT%{_bindir}/{ftlint,ft1lint}
152mv -f $RPM_BUILD_ROOT%{_bindir}/{ftview,ft1view}
153mv -f $RPM_BUILD_ROOT%{_bindir}/{fttimer,ft1timer}
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post -p /sbin/ldconfig
159%postun -p /sbin/ldconfig
160
161%files -f freetype.lang
162%defattr(644,root,root,755)
163%attr(755,root,root) %{_libdir}/libttf.so.*.*.*
164%attr(755,root,root) %ghost %{_libdir}/libttf.so.2
165
166%files devel
167%defattr(644,root,root,755)
168%doc howto/unix.txt README announce docs/{*.txt,FAQ,TODO,credits}
169%attr(755,root,root) %{_libdir}/libttf.so
170%{_libdir}/libttf.la
171%{_includedir}/*
172
173%if %{with static_libs}
174%files static
175%defattr(644,root,root,755)
176%{_libdir}/lib*.a
177%endif
178
179%files progs
180%defattr(644,root,root,755)
181%attr(755,root,root) %{_bindir}/f*
This page took 0.028163 seconds and 4 git commands to generate.