]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/blame_incremental - fonts-TTF-microsoft.spec
- release 12 (by relup.sh)
[packages/fonts-TTF-microsoft.git] / fonts-TTF-microsoft.spec
... / ...
CommitLineData
1# NOTE
2# according to EULA we *can* store the .exe's in distfiles in
3# unaltered form (that is those .exe files), while can't distribute
4# resulting rpm.
5#
6# Conditional build:
7%bcond_with license_agreement # generates package
8
9%define base_name fonts-TTF-microsoft
10%define rel 12
11Summary: Microsoft TrueType fonts
12Summary(pl.UTF-8): Fonty TrueType firmy Microsoft
13%if %{with license_agreement}
14Name: %{base_name}
15%else
16Name: %{base_name}-installer
17%endif
18Version: 20020525
19Release: %{rel}%{?with_license_agreement:wla}
20License: Microsoft EULA (for non-commercial use)
21Group: Fonts
22%if %{with license_agreement}
23Source0: http://downloads.sourceforge.net/corefonts/andale32.exe
24# Source0-md5: cbdc2fdd7d2ed0832795e86a8b9ee19a
25Source1: http://downloads.sourceforge.net/corefonts/arial32.exe
26# Source1-md5: 9637df0e91703179f0723ec095a36cb5
27Source2: http://downloads.sourceforge.net/corefonts/arialb32.exe
28# Source2-md5: c9089ae0c3b3d0d8c4b0a95979bb9ff0
29Source3: http://downloads.sourceforge.net/corefonts/comic32.exe
30# Source3-md5: 2b30de40bb5e803a0452c7715fc835d1
31Source4: http://downloads.sourceforge.net/corefonts/courie32.exe
32# Source4-md5: 4e412c772294403ab62fb2d247d85c60
33Source5: http://downloads.sourceforge.net/corefonts/georgi32.exe
34# Source5-md5: 4d90016026e2da447593b41a8d8fa8bd
35Source6: http://downloads.sourceforge.net/corefonts/impact32.exe
36# Source6-md5: 7907c7dd6684e9bade91cff82683d9d7
37Source7: http://downloads.sourceforge.net/corefonts/times32.exe
38# Source7-md5: ed39c8ef91b9fb80f76f702568291bd5
39Source8: http://downloads.sourceforge.net/corefonts/trebuc32.exe
40# Source8-md5: 0d7ea16cac6261f8513a061fbfcdb2b5
41Source9: http://downloads.sourceforge.net/corefonts/verdan32.exe
42# Source9-md5: 12d2a75f8156e10607be1eaa8e8ef120
43Source10: http://downloads.sourceforge.net/corefonts/webdin32.exe
44# Source10-md5: 230a1d13a365b22815f502eb24d9149b
45%else
46Source21: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
47# Source21-md5: 329c25f457fea66ec502b7ef70cb9ede
48# extracted from one of the above
49Source20: Microsoft-EULA.txt
50%endif
51URL: http://corefonts.sourceforge.net/
52%if %{with license_agreement}
53BuildRequires: cabextract
54Requires(post,postun): fontpostinst
55Requires: %{_fontsdir}/TTF
56Requires: %{name}-ariblk
57Requires: fontpostinst
58%else
59Requires: cabextract
60Requires: mktemp > 1.5-18
61Requires: rpm-build-tools >= 4.4.37
62Requires: rpmbuild(macros) >= 1.544
63%endif
64BuildArch: noarch
65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67%define ttffontsdir %{_fontsdir}/TTF
68
69%description
70Microsoft free TrueType fonts collection.
71
72%description -l pl.UTF-8
73Kolekcja darmowych fontów TrueType firmy Microsoft.
74
75%package ariblk
76Summary: Microsoft TrueType fonts - Arial Black
77Group: Fonts
78Requires(post,postun): fontpostinst
79Requires: %{_fontsdir}/TTF
80Requires: fontpostinst
81
82%description ariblk
83Microsoft TrueType fonts - Arial Black.
84
85%prep
86%if %{with license_agreement}
87%setup -q -c -T
88%{_bindir}/cabextract -L %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} \
89%{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
90%{SOURCE10}
91mv licen.txt Microsoft-EULA.txt
92%endif
93
94%install
95rm -rf $RPM_BUILD_ROOT
96%if %{without license_agreement}
97install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
98
99sed -e '
100 s/@BASE_NAME@/%{base_name}/g
101 s/@TARGET_CPU@/%{_target_cpu}/g
102 s-@VERSION@-%{version}-g
103 s-@RELEASE@-%{release}-g
104 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
105 s,@DATADIR@,%{_datadir}/%{base_name},g
106 s,@LICENSE@,%{_datadir}/%{base_name}/Microsoft-EULA.txt,
107' %{SOURCE21} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
108
109cp -a %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
110install -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
111
112%else
113install -d $RPM_BUILD_ROOT%{ttffontsdir}
114cp -a *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
115%endif
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%if %{with license_agreement}
121%post
122fontpostinst TTF
123
124%postun
125fontpostinst TTF
126
127%post ariblk
128fontpostinst TTF
129
130%postun ariblk
131fontpostinst TTF
132
133%else
134%post
135echo "
136If you accept the license enclosed in the file
137%{_datadir}/%{base_name}/Microsoft-EULA.txt
138and want to install real fonts, then rebuild the package with the
139following command:
140
141%{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
142"
143%endif
144
145%files
146%defattr(644,root,root,755)
147%if %{with license_agreement}
148%doc Microsoft-EULA.txt
149%{ttffontsdir}/andalemo.ttf
150%{ttffontsdir}/arial.ttf
151%{ttffontsdir}/arialbd.ttf
152%{ttffontsdir}/arialbi.ttf
153%{ttffontsdir}/ariali.ttf
154%{ttffontsdir}/comic*.ttf
155%{ttffontsdir}/cour*.ttf
156%{ttffontsdir}/georgia*.ttf
157%{ttffontsdir}/impact.ttf
158%{ttffontsdir}/times*.ttf
159%{ttffontsdir}/trebuc*.ttf
160%{ttffontsdir}/verdana*.ttf
161%{ttffontsdir}/webdings.ttf
162%else
163%attr(755,root,root) %{_bindir}/%{base_name}.install
164%{_datadir}/%{base_name}
165%endif
166
167%if %{with license_agreement}
168%files ariblk
169%defattr(644,root,root,755)
170%{ttffontsdir}/ariblk.ttf
171%endif
This page took 0.030241 seconds and 5 git commands to generate.