]> git.pld-linux.org Git - packages/expect.git/blame_incremental - expect.spec
- updated to 5.45.4
[packages/expect.git] / expect.spec
... / ...
CommitLineData
1#
2# BIG FAT WARNING:
3# - expect requires mounted /dev/pts to avoid `spawn failed' errors.
4#
5%bcond_without tests
6Summary: Tcl expect extension
7Summary(de.UTF-8): Tcl-Erweiterung
8Summary(fr.UTF-8): Extension Tcl
9Summary(pl.UTF-8): Rozszerzenie Tcl expect
10Summary(ru.UTF-8): Расширение Tcl для управления программами из скриптов
11Summary(tr.UTF-8): Programlar arası etkileşimi mümkün kılan Tcl genişletmesi
12Summary(uk.UTF-8): Розширення Tcl для керування програмами зі скриптів
13Name: expect
14Version: 5.45.4
15Release: 1
16License: BSD
17Group: Development/Languages/Tcl
18Source0: http://downloads.sourceforge.net/expect/%{name}%{version}.tar.gz
19# Source0-md5: 00fce8de158422f5ccd2666512329bd2
20Patch0: %{name}-pty.patch
21Patch1: %{name}-bug7869.patch
22Patch2: %{name}-soname.patch
23Patch3: %{name}-format.patch
24Patch4: %{name}-5.43.0-log_file.patch
25Patch5: %{name}-5.45-match-gt-numchars-segfault.patch
26Patch6: %{name}-5.45-re-memleak.patch
27Patch7: %{name}-5.45-exp-log-buf-overflow.patch
28Patch8: %{name}-5.45-segfault-with-stubs.patch
29Patch9: %{name}-5.45-fd-leak.patch
30Patch10: %{name}-5.32.2-random.patch
31Patch11: %{name}-5.45-mkpasswd-dash.patch
32Patch12: %{name}-5.45-check-telnet.patch
33Patch13: %{name}-5.45-passmass-su-full-path.patch
34URL: http://expect.nist.gov/
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: tcl-devel >= 8.5.0
38BuildRequires: tk-devel >= 8.5.0
39BuildRequires: xorg-lib-libX11-devel
40BuildRequires: xorg-lib-libXScrnSaver-devel
41BuildRequires: xorg-lib-libXext-devel
42Requires: tcl >= 8.5.0
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%define _ulibdir /usr/lib
46
47%description
48Expect is a tool for automating interactive applications such as
49telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
50script to control another program and interact with it.
51
52%description -l pl.UTF-8
53Expect to narzędzie do automatyzacji interakcji z aplikacjami takimi
54jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w łatwy
55sposób przy pomocy skryptu kontrolować inny program.
56
57%description -l de.UTF-8
58Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
59telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
60Skript ein anderes Programm sehr leicht steuern oder damit
61interagieren.
62
63%description -l fr.UTF-8
64expect est un un outil pour automatiser les applications interactives
65comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
66pour un script de contrôler un autre programme et d'interagir avec
67lui.
68
69%description -l tr.UTF-8
70Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileşimli
71uygulamaları otomatize etmeye yarayan bir araçtır. Bir uygulamanın bir
72diğer uygulamayı denetlemesini kolaylaştırır.
73
74%description -l ru.UTF-8
75Expect - это инструмент для автоматизации интерактивных программ,
76таких как telnet, ftp, passwd, fsck, rlogin, tip, и т.п. Позволяет
77управлять программами и взаимодействовать с ними из скриптов.
78
79%description -l uk.UTF-8
80Expect - це інструмент для автоматизації інтерактивних програм, таких
81як telnet, ftp, passwd, fsck, rlogin, tip, і т.і. Дозволяє керувати
82програмами та взаємодіяти з ними зі скриптів.
83
84%package X11
85Summary: Tk extension
86Summary(pl.UTF-8): Rozszerzenie Tk
87Group: Development/Languages/Tcl
88Requires: %{name} = %{version}-%{release}
89
90%description X11
91This package contains expectk, which is an Tk extension, just as
92expect Tcl extension.
93
94%description X11 -l pl.UTF-8
95Ten pakiet zawiera expectk, który jest rozszerzeniem dla Tk takim jak
96expect jest dla Tcl.
97
98%package devel
99Summary: Tcl expect extension header files and development documentation
100Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do rozszerzenia expect języka Tcl
101Group: Development/Languages/Tcl
102Requires: %{name} = %{version}-%{release}
103Requires: tcl-devel >= 8.5.0
104Obsoletes: expect-static
105
106%description devel
107Tcl expect extension language header files and development
108documentation.
109
110%description devel -l pl.UTF-8
111Pliki nagłówkowe i dokumentacja do rozszerzenia expect języka Tcl.
112
113%prep
114%setup -q -n %{name}%{version}
115%patch0 -p1
116%patch1 -p1
117%patch2 -p1
118%patch3 -p1
119%patch4 -p1
120%patch5 -p1
121%patch6 -p1
122%patch7 -p1
123%patch8 -p1
124%patch9 -p1
125%patch10 -p1
126%patch11 -p1
127%patch12 -p1
128%patch13 -p1
129
130chmod +w {.,testsuite}/configure
131
132%build
133install /usr/share/automake/config.* .
134# only local macros, don't call aclocal
135%{__autoconf}
136cd testsuite
137%{__autoconf} -I ..
138cd ..
139CFLAGS="%{rpmcflags} -I%{_includedir}/tcl-private/unix"
140%configure \
141%if "%{_lib}" == "lib64"
142 --enable-64bit \
143%endif
144 --enable-gcc \
145 --enable-shared \
146 --with-tclconfig=%{_ulibdir} \
147 --with-tkconfig=%{_ulibdir} \
148 --with-tclinclude=%{_includedir} \
149 --with-tkinclude=%{_includedir}
150
151%{__make}
152
153%{?with_tests:%{__make} test TCLSH_PROG=tclsh}
154
155%install
156rm -rf $RPM_BUILD_ROOT
157
158LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
159%{__make} install \
160 DESTDIR=$RPM_BUILD_ROOT \
161 TCLSH_PROG=tclsh
162
163mv -f $RPM_BUILD_ROOT%{_bindir}/{rftp,rftp-expect}
164
165mv -f $RPM_BUILD_ROOT%{_libdir}/expect%{version}/libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}
166ln -sf ../libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}/expect%{version}/libexpect%{version}.so
167ln -sf libexpect%{version}.so $RPM_BUILD_ROOT%{_libdir}/libexpect.so
168
169%clean
170rm -rf $RPM_BUILD_ROOT
171
172%post -p /sbin/ldconfig
173%postun -p /sbin/ldconfig
174
175%files
176%defattr(644,root,root,755)
177%doc ChangeLog FAQ HISTORY NEWS README
178%attr(755,root,root) %{_bindir}/autoexpect
179%attr(755,root,root) %{_bindir}/autopasswd
180%attr(755,root,root) %{_bindir}/cryptdir
181%attr(755,root,root) %{_bindir}/decryptdir
182%attr(755,root,root) %{_bindir}/dislocate
183%attr(755,root,root) %{_bindir}/expect
184%attr(755,root,root) %{_bindir}/ftp-rfc
185%attr(755,root,root) %{_bindir}/kibitz
186%attr(755,root,root) %{_bindir}/lpunlock
187%attr(755,root,root) %{_bindir}/mkpasswd
188%attr(755,root,root) %{_bindir}/passmass
189%attr(755,root,root) %{_bindir}/rftp-expect
190%attr(755,root,root) %{_bindir}/rlogin-cwd
191%attr(755,root,root) %{_bindir}/timed-read
192%attr(755,root,root) %{_bindir}/timed-run
193%attr(755,root,root) %{_bindir}/unbuffer
194%attr(755,root,root) %{_bindir}/weather
195%attr(755,root,root) %{_libdir}/libexpect%{version}.so
196%dir %{_libdir}/expect%{version}
197%attr(755,root,root) %{_libdir}/expect%{version}/pkgIndex.tcl
198%attr(755,root,root) %{_libdir}/expect%{version}/libexpect%{version}.so
199%{_mandir}/man1/autoexpect.1*
200%{_mandir}/man1/cryptdir.1*
201%{_mandir}/man1/decryptdir.1*
202%{_mandir}/man1/dislocate.1*
203%{_mandir}/man1/expect.1*
204%{_mandir}/man1/kibitz.1*
205%{_mandir}/man1/mkpasswd.1*
206%{_mandir}/man1/passmass.1*
207%{_mandir}/man1/unbuffer.1*
208
209%files X11
210%defattr(644,root,root,755)
211%attr(755,root,root) %{_bindir}/multixterm
212%attr(755,root,root) %{_bindir}/tknewsbiff
213%attr(755,root,root) %{_bindir}/tkpasswd
214%attr(755,root,root) %{_bindir}/xkibitz
215%attr(755,root,root) %{_bindir}/xpstat
216%{_mandir}/man1/multixterm.1*
217%{_mandir}/man1/tknewsbiff.1*
218%{_mandir}/man1/xkibitz.1*
219
220%files devel
221%defattr(644,root,root,755)
222%attr(755,root,root) %{_libdir}/libexpect.so
223%{_includedir}/expect*.h
224%{_includedir}/tcldbg.h
225%{_mandir}/man3/libexpect.3*
This page took 0.096619 seconds and 5 git commands to generate.