]> git.pld-linux.org Git - packages/elinks.git/blame_incremental - elinks.spec
- justify_date patch replaced by date-format patch (use localized date format)
[packages/elinks.git] / elinks.spec
... / ...
CommitLineData
1# TODO: consider lua51
2#
3# Conditional build:
4%bcond_with x # Use the X Windows System
5%bcond_with gnutls # Enable GNUTLS SSL support (disables openssl)
6%bcond_with ruby # Enable (experimental) Ruby scripting support
7%bcond_without 256 # Disable 256 colors support
8%bcond_without bittorrent # Disable BitTorrent support
9%bcond_without cgi # Disable Local CGI support
10%bcond_without fsp # Disable FSP support
11%bcond_without guile # Disable Guile scripting
12%bcond_without idn # Disable Internation Domain Names support
13%bcond_without ipv6 # Disable IPv6 support
14%bcond_without js # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15%bcond_without led # Disable LEDs
16%bcond_without lua # Disable Lua scripting
17%bcond_without openssl # Disable OpenSSL support
18%bcond_without perl # Disable Perl scripting
19#
20%if %{with gnutls}
21%undefine with_openssl
22%endif
23#
24Summary: Experimantal Links (text WWW browser)
25Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
26Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
27Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
28Name: elinks
29Version: 0.11.3
30Release: 4
31Epoch: 1
32License: GPL
33Group: Applications/Networking
34Source0: http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
35# Source0-md5: a0eb50e18a2ac8e77d6b0df8f94bb5a6
36Source1: %{name}.desktop
37Source2: links.png
38Patch0: %{name}-home_etc.patch
39Patch1: %{name}-lua40.patch
40Patch2: %{name}-bug517.patch
41Patch3: %{name}-cgi.patch
42Patch4: %{name}-date-format.patch
43URL: http://www.elinks.cz/
44BuildRequires: autoconf
45BuildRequires: automake
46BuildRequires: bzip2-devel
47BuildRequires: expat-devel
48%{?with_fsp:BuildRequires: fsplib-devel}
49BuildRequires: gettext-devel
50BuildRequires: gpm-devel
51%{?with_guile:BuildRequires: guile-devel}
52%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
53%{?with_js:BuildRequires: js-devel >= 1.5-0.rc6a.1}
54%{?with_idn:BuildRequires: libidn-devel}
55%{?with_lua:BuildRequires: lua50-devel}
56BuildRequires: ncurses-devel >= 5.1
57%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
58%{?with_perl:BuildRequires: perl-devel}
59%{?with_ruby:BuildRequires: ruby-devel}
60BuildRequires: zlib-devel
61Provides: webclient
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%define _sysconfdir /etc/elinks
65%define specflags_ia32 -fomit-frame-pointer
66
67%description
68This is the elinks tree - intended to provide feature-rich version of
69links, however not rock-stable and dedicated mainly for testing. Its
70purpose is to make alternative to links, until Mikulas will have some
71time to maintain it, and to test and tune various patches for Mikulas
72to be able to include them in the official links releases.
73
74%description -l es.UTF-8
75Links es un browser WWW modo texto, similar al Lynx. El links muestra
76tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
77keepalive.
78
79%description -l pl.UTF-8
80Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
81elinks jednak jest dedykowana głównie do testowania.
82
83%description -l pt_BR.UTF-8
84Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
85tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
86keepalive.
87
88%prep
89%setup -q
90%patch0 -p1
91%patch1 -p1
92%patch2 -p1
93%patch3 -p1
94%patch4 -p1
95
96%build
97%{__aclocal}
98%{__autoconf}
99%{__autoheader}
100%configure \
101 HAVE_SMBCLIENT=yes \
102 --disable-no-root \
103 %{!?debug:--enable-fastmem} \
104 %{?debug:--enable-debug} \
105 %{!?with_ipv6:--disable-ipv6} \
106 %{?with_bittorrent:--enable-bittorrent} \
107 %{?with_cgi:--enable-cgi} \
108 --enable-finger \
109 --enable-gopher \
110 --enable-nntp \
111 %{?with_256:--enable-256-colors} \
112 --enable-exmode \
113 %{?with_fsp:--enable-fsp} \
114 %{?with_leds:--enable-leds} \
115 --enable-marks \
116 --enable-html-highlight \
117 %{!?with_idn:--without-idn} \
118 %{?with_guile:--with-guile} \
119 %{?with_perl:--with-perl} \
120 %{!?with_lua:--without-lua} \
121 %{?with_ruby:--with-ruby} \
122 %{!?with_js:--without-spidermonkey} \
123 %{?with_gnutls:--with-gnutls} \
124 %{!?with_openssl:--without-openssl} \
125 --with%{!?with_x:out}-x
126# xterm -e is default, one might want to change it to
127# something else
128# --with-xterm="xterm -e"
129
130%{__make} V=1
131
132%install
133rm -rf $RPM_BUILD_ROOT
134install -d $RPM_BUILD_ROOT%{_desktopdir} \
135 $RPM_BUILD_ROOT%{_datadir}/%{name} \
136 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
137
138%{__make} install V=1 \
139 DESTDIR=$RPM_BUILD_ROOT
140
141install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
142install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
143
144%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
145
146%find_lang %{name}
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%files -f %{name}.lang
152%defattr(644,root,root,755)
153%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
154%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
155%doc contrib/conv/{*awk,*.pl,*.sh}
156%doc doc/html/*.html
157%attr(755,root,root) %{_bindir}/*
158%{_mandir}/man*/*
159%{_desktopdir}/*.desktop
160%{_pixmapsdir}/*
161%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.086229 seconds and 4 git commands to generate.