]> git.pld-linux.org Git - packages/elfutils.git/blame_incremental - elfutils.spec
- release 2
[packages/elfutils.git] / elfutils.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform tests
4#
5Summary: A collection of utilities and DSOs to handle compiled objects
6Summary(pl.UTF-8): Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
7Name: elfutils
8Version: 0.141
9Release: 2
10License: GPL v2 with OSL linking exception
11Group: Development/Tools
12Source0: https://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
13# Source0-md5: 2d0fe5651c0de1fd28e7dd006effe7d1
14Patch0: %{name}-pl.po.patch
15Patch1: %{name}-debian-manpages.patch
16Patch2: %{name}-portability.patch
17Patch3: %{name}-robustify.patch
18Patch4: %{name}-align.patch
19Patch5: %{name}-paxflags.patch
20Patch6: %{name}-sparc.patch
21Patch7: %{name}-inline.patch
22Patch8: %{name}-Werror.patch
23Patch9: %{name}-bashism.patch
24Patch10: %{name}-scanf.patch
25URL: https://fedorahosted.org/elfutils/
26BuildRequires: autoconf >= 2.59
27BuildRequires: automake >= 1:1.7
28BuildRequires: gcc >= 5:3.4
29BuildRequires: gettext-devel
30%ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
31# PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
32# also needed for nanosecond timestamps on alpha
33BuildRequires: glibc-devel >= 6:2.3.4
34%endif
35BuildRequires: perl-tools-pod
36BuildRequires: rpmbuild(macros) >= 1.315
37BuildRequires: sharutils
38%if %{with tests} && %(test -d /proc/self ; echo $?)
39# native test needs proc (for libdwfl -p PID to work)
40BuildRequires: MOUNTED_PROC
41%endif
42Requires: %{name}-libelf = %{version}-%{release}
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45# fails to build with -Wl,-s
46%define filterout_ld (-Wl,)?-[sS] (-Wl,)?--strip.*
47
48%define programprefix eu-
49
50%description
51Elfutils is a collection of utilities, including ld (a linker), nm
52(for listing symbols from object files), size (for listing the section
53sizes of an object or archive file), strip (for discarding symbols),
54readline (the see the raw ELF file structures), and elflint (to check
55for well-formed ELF files). Also included are numerous helper
56libraries which implement DWARF, ELF, and machine-specific ELF
57handling.
58
59%description -l pl.UTF-8
60Elfutils to zestaw narzędzi, składający się z ld (linkera), nm (do
61listowania symboli z plików obiektów), size (do listowania rozmiarów
62sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
63readline (do oglądania surowych struktur plików ELF) oraz elflint (do
64sprawdzania poprawności plików ELF). Dołączone są także liczne
65biblioteki pomocnicze z zaimplementowaną obsługą DWARF, ELF i ELF
66specyficznych dla architektury.
67
68%package devel
69Summary: Development part of libraries to handle compiled objects
70Summary(pl.UTF-8): Część programistyczna bibliotek do obsługi skompilowanych obiektów
71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
73Obsoletes: libelf-devel
74
75%description devel
76The elfutils-devel package contains the development part of libraries
77to create applications for handling compiled objects. libelf allows
78you to access the internals of the ELF object file format, so you can
79see the different sections of an ELF file. libebl provides some
80higher-level ELF access functionality. libdwarf provides access to the
81DWARF debugging information. libasm provides a programmable assembler
82interface.
83
84%description devel -l pl.UTF-8
85Pakiet elfutils-devel zawiera część programistyczną bibliotek do
86tworzenia aplikacji obsługujących skompilowane obiekty. libelf pozwala
87na dostęp do wnętrzności formatu pliku obiektowego ELF, co pozwala na
88oglądanie różnych sekcji pliku ELF. libebl udostępnia funkcjonalność
89dostępu do plików ELF trochę wyższego poziomu. libdwarf pozwala na
90dostęp do informacji DWARF służących do odpluskwiania. libasm
91udostępnia programowalny interfejs asemblera.
92
93%package libelf
94Summary: Library to read and write ELF files
95Summary(pl.UTF-8): Biblioteki do odczytu i zapisu plików ELF
96Group: Libraries
97#Obsoletes: libelf
98
99%description libelf
100The elfutils-libelf package provides a DSO which allows reading and
101writing ELF files on a high level. Third party programs depend on this
102package to read internals of ELF files. The programs of the elfutils
103package use it also to generate new ELF files.
104
105%description libelf -l pl.UTF-8
106Pakiet elfutils-libelf udostępnia bibliotekę dzieloną, która pozwala
107na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
108wymagają tego pakietu, aby odczytywać zawartość plików ELF. Programy z
109pakietu elfutils używają jej także do generowania nowych plików ELF.
110
111%package static
112Summary: Static libraries to handle compiled objects
113Summary(pl.UTF-8): Statyczne biblioteki do obsługi skompilowanych obiektów
114Group: Development/Libraries
115Requires: %{name}-devel = %{version}-%{release}
116Obsoletes: libelf-static
117
118%description static
119The elfutils-static package contains the static libraries to create
120applications for handling compiled objects. libelf allows you to
121access the internals of the ELF object file format, so you can see the
122different sections of an ELF file. libebl provides some higher-level
123ELF access functionality. libdwarf provides access to the DWARF
124debugging information. libasm provides a programmable assembler
125interface.
126
127%description static -l pl.UTF-8
128Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
129aplikacji obsługujących skompilowane obiekty. libelf pozwala na dostęp
130do wnętrzności formatu pliku obiektowego ELF, co pozwala na oglądanie
131różnych sekcji pliku ELF. libebl udostępnia funkcjonalność dostępu do
132plików ELF trochę wyższego poziomu. libdwarf pozwala na dostęp do
133informacji DWARF służących do odpluskwiania. libasm udostępnia
134programowalny interfejs asemblera.
135
136%prep
137%setup -q
138%patch0 -p1
139%patch1 -p1
140%patch2 -p1
141%patch3 -p1
142%patch4 -p1
143%patch5 -p1
144%patch6 -p1
145%patch7 -p1
146%patch8 -p1
147%patch9 -p1
148%patch10 -p1
149
150rm -f po/stamp-po
151
152# temporarily disable test failing on specific archs
153%ifarch alpha
154%{__perl} -pi -e 's/run-elflint-self.sh//' tests/Makefile
155%endif
156
157%build
158#%%{__gettextize}
159%{__aclocal} -I m4
160%{__autoheader}
161%{__autoconf}
162%{__automake}
163%configure \
164 --program-prefix=%{programprefix}
165
166# make check depends on test-nlist not stripped
167%{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
168
169%{__make}
170%{__make} -C debian/man
171
172%if %{with tests}
173# some tests rely on English messages
174LC_ALL=C \
175%{__make} -C tests check
176%endif
177
178%install
179rm -rf $RPM_BUILD_ROOT
180install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
181
182%{__make} install \
183 DESTDIR=$RPM_BUILD_ROOT
184
185install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
186
187mv $RPM_BUILD_ROOT%{_libdir}/{libelf-*.so,libelf.so.*} $RPM_BUILD_ROOT/%{_lib}
188ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libelf-*.so) \
189 $RPM_BUILD_ROOT%{_libdir}/libelf.so
190
191%find_lang %{name}
192
193%clean
194rm -rf $RPM_BUILD_ROOT
195
196%post -p /sbin/ldconfig
197%postun -p /sbin/ldconfig
198
199%post libelf -p /sbin/ldconfig
200%postun libelf -p /sbin/ldconfig
201
202%files
203%defattr(644,root,root,755)
204%doc AUTHORS EXCEPTION NEWS NOTES README THANKS TODO
205%attr(755,root,root) %{_bindir}/eu-*
206%attr(755,root,root) %{_libdir}/libasm-*.so
207%ghost %attr(755,root,root) %{_libdir}/libasm.so.*
208%attr(755,root,root) %{_libdir}/libdw-*.so
209%ghost %attr(755,root,root) %{_libdir}/libdw.so.*
210%dir %{_libdir}/elfutils
211%attr(755,root,root) %{_libdir}/elfutils/lib*.so
212%{_mandir}/man1/eu-*.1*
213
214%files devel
215%defattr(644,root,root,755)
216%attr(755,root,root) %{_libdir}/libasm.so
217%attr(755,root,root) %{_libdir}/libdw.so
218%attr(755,root,root) %{_libdir}/libelf.so
219%{_libdir}/libebl.a
220%{_includedir}/elfutils
221%{_includedir}/dwarf.h
222%{_includedir}/gelf.h
223%{_includedir}/libelf.h
224%{_includedir}/nlist.h
225
226%files libelf -f %{name}.lang
227%defattr(644,root,root,755)
228%attr(755,root,root) /%{_lib}/libelf-*.so
229%ghost %attr(755,root,root) /%{_lib}/libelf.so.*
230
231%files static
232%defattr(644,root,root,755)
233%{_libdir}/libasm.a
234%{_libdir}/libdw.a
235%{_libdir}/libelf.a
This page took 0.037736 seconds and 4 git commands to generate.