]> git.pld-linux.org Git - packages/dehydrated.git/blame_incremental - dehydrated.spec
- release 2 (by relup.sh)
[packages/dehydrated.git] / dehydrated.spec
... / ...
CommitLineData
1Summary: letsencrypt/acme client implemented as a shell-script
2Name: dehydrated
3Version: 0.3.1
4Release: 2
5License: MIT
6Group: Applications/Networking
7Source0: https://github.com/lukas2511/dehydrated/archive/v%{version}/%{name}-%{version}.tar.gz
8# Source0-md5: 7a3b92b963da6469c4a53f051d6efa24
9Source1: apache.conf
10Source2: lighttpd.conf
11Source3: nginx.conf
12Source4: domains.txt
13Source5: hook.sh
14Source6: crontab
15Patch0: pld.patch
16URL: https://github.com/lukas2511/dehydrated
17BuildRequires: rpmbuild(macros) >= 1.713
18Requires: ca-certificates
19Requires: crondaemon
20Requires: curl
21Requires: diffutils
22Requires: grep
23Requires: mktemp
24Requires: openssl-tools
25Requires: sed
26Requires: webapps
27Suggests: webserver(access)
28Suggests: webserver(alias)
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%define _webapps /etc/webapps
33%define _webapp %{name}
34%define _sysconfdir %{_webapps}/%{_webapp}
35%define _appdir %{_datadir}/%{_webapp}
36
37%description
38This is a client for signing certificates with an ACME-server
39(currently only provided by letsencrypt) implemented as a relatively
40simple bash-script.
41
42Current features:
43- Signing of a list of domains
44- Signing of a CSR
45- Renewal if a certificate is about to expire or SAN (subdomains)
46 changed
47- Certificate revocation
48
49%prep
50%setup -q
51%patch0 -p1
52
53%install
54rm -rf $RPM_BUILD_ROOT
55install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/certs,/etc/cron.d} \
56 $RPM_BUILD_ROOT/var/lib/%{name}/{accounts,acme-challenge,certs}
57
58install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
59cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
60cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
61cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
62cp -p docs/examples/config $RPM_BUILD_ROOT%{_sysconfdir}
63cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
64cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/%{name}
65install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
66cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%triggerin -- apache1 < 1.3.37-3, apache1-base
72%webapp_register apache %{_webapp}
73
74%triggerun -- apache1 < 1.3.37-3, apache1-base
75%webapp_unregister apache %{_webapp}
76
77%triggerin -- apache < 2.2.0, apache-base
78%webapp_register httpd %{_webapp}
79
80%triggerun -- apache < 2.2.0, apache-base
81%webapp_unregister httpd %{_webapp}
82
83%triggerin -- lighttpd
84%webapp_register lighttpd %{_webapp}
85
86%triggerun -- lighttpd
87%webapp_unregister lighttpd %{_webapp}
88
89%triggerin -- nginx
90%webapp_register nginx %{_webapp}
91
92%triggerun -- nginx
93%webapp_unregister nginx %{_webapp}
94
95%files
96%defattr(644,root,root,755)
97%doc README.md CHANGELOG LICENSE
98%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
99%dir %attr(750,root,http) %{_sysconfdir}
100%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
101%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
102%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
103%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
104%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
105%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
106%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
107%attr(755,root,root) %{_sbindir}/%{name}
108%dir %attr(751,root,root) /var/lib/%{name}
109%dir %attr(700,root,root) /var/lib/%{name}/accounts
110%dir %attr(700,root,root) /var/lib/%{name}/certs
111# challenges written here, need to be readable by webserver
112%dir %attr(751,root,root) /var/lib/%{name}/acme-challenge
This page took 0.073318 seconds and 4 git commands to generate.