]> git.pld-linux.org Git - packages/cryptsetup.git/blame_incremental - cryptsetup.spec
- add -initrd subpackage; rel 4
[packages/cryptsetup.git] / cryptsetup.spec
... / ...
CommitLineData
1#
2# Conditonal build:
3%bcond_without initrd # don't build initrd version
4#
5%define realname cryptsetup
6Summary: LUKS for dm-crypt implemented in cryptsetup
7Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup
8Name: cryptsetup-luks
9Version: 1.0.6
10Release: 4
11License: GPL v2
12Group: Base
13Source0: http://luks.endorphin.org/source/%{realname}-%{version}.tar.bz2
14# Source0-md5: 00d452eb7a76e39f5749545d48934a10
15Patch1: %{name}-nostatic.patch
16URL: http://luks.endorphin.org/
17BuildRequires: autoconf
18BuildRequires: automake
19BuildRequires: device-mapper-devel
20BuildRequires: gettext-devel
21BuildRequires: libgcrypt-devel >= 1.1.42
22BuildRequires: libselinux-devel
23BuildRequires: libsepol-devel
24BuildRequires: libtool
25BuildRequires: libuuid-devel
26BuildRequires: popt-devel
27%if %{with initrd}
28BuildRequires: device-mapper-static >= 1.02.07
29BuildRequires: libgcrypt-static >= 1.1.42
30BuildRequires: libgpg-error-static
31BuildRequires: libselinux-static
32BuildRequires: libsepol-static
33BuildRequires: libuuid-static
34BuildRequires: popt-static
35%endif
36Provides: cryptsetup = %{version}
37Obsoletes: cryptsetup
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define _sbindir /sbin
41%define _noautoreqdep libcryptsetup.so.0
42
43%description
44LUKS is the upcoming standard for Linux hard disk encryption. By
45providing a standard on-disk-format, it does not only facilitate
46compatibility among distributions, but also provide secure management
47of multiple user passwords. In contrast to existing solution, LUKS
48stores all setup necessary setup information in the partition header,
49enabling the user to transport or migrate his data seamlessly.
50
51This package contains implementation of LUKS for dm-crypt implemented
52in cryptsetup.
53
54%description -l pl.UTF-8
55LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
56Dostarczając standardowy format danych na dysku nie tylko ułatwia
57utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
58bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
59do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
60informacje o konfiguracji w nagłówku partycji, pozwalając
61użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
62
63Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
64cryptsetup.
65
66%package devel
67Summary: Header files for cryptsetup library
68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki cryptsetup
69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: device-mapper-devel
72Requires: libgcrypt-devel >= 1.1.42
73Obsoletes: cryptsetup-devel
74
75%description devel
76Header files for cryptsetup library.
77
78%description devel -l pl.UTF-8
79Pliki nagłówkowe biblioteki cryptsetup.
80
81%package static
82Summary: Static cryptsetup library
83Summary(pl.UTF-8): Statyczna biblioteka cryptsetup
84Group: Development/Libraries
85Requires: %{name}-devel = %{version}-%{release}
86Obsoletes: cryptsetup-static
87
88%description static
89Static version of cryptsetup library.
90
91%description static -l pl.UTF-8
92Statyczna wersja biblioteki cryptsetup.
93
94%package initrd
95Summary: LUKS for dm-crypt implemented in cryptsetup - initrd version
96Group: Base
97
98%description initrd
99This package contains implementation of LUKS for dm-crypt implemented
100in cryptsetup - staticaly linked for initrd.
101
102%prep
103%setup -q -n %{realname}-%{version}
104%patch1 -p1
105
106%build
107%{__gettextize}
108%{__libtoolize}
109%{__aclocal} -I m4
110%{__autoconf}
111%{__autoheader}
112%{__automake}
113
114%if %{with initrd}
115%configure \
116 --enable-static \
117 --enable-static-cryptsetup
118%{__make}
119mv src/cryptsetup cryptsetup-initrd
120%{__make} clean
121%endif
122
123%configure \
124 --enable-static
125%{__make}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
132
133install -d $RPM_BUILD_ROOT/%{_lib}
134mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
135ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
136 $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
137
138%if %{with initrd}
139install cryptsetup-initrd $RPM_BUILD_ROOT%{_sbindir}
140%endif
141
142%find_lang %{realname}
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148%postun -p /sbin/ldconfig
149
150%files -f %{realname}.lang
151%defattr(644,root,root,755)
152%doc AUTHORS ChangeLog TODO
153%attr(755,root,root) %{_sbindir}/cryptsetup
154%attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
155%attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.0
156%{_mandir}/man8/cryptsetup.8*
157
158%files devel
159%defattr(644,root,root,755)
160%attr(755,root,root) %{_libdir}/libcryptsetup.so
161%{_libdir}/libcryptsetup.la
162%{_includedir}/libcryptsetup.h
163
164%files static
165%defattr(644,root,root,755)
166%{_libdir}/libcryptsetup.a
167
168%if %{with initrd}
169%files initrd
170%defattr(644,root,root,755)
171%attr(755,root,root) %{_sbindir}/cryptsetup-initrd
172%endif
This page took 0.026049 seconds and 4 git commands to generate.