]> git.pld-linux.org Git - packages/cryptsetup.git/blame_incremental - cryptsetup.spec
- updated to 1.3.0
[packages/cryptsetup.git] / cryptsetup.spec
... / ...
CommitLineData
1#
2# Conditonal build:
3%bcond_without initrd # don't build initrd version
4%bcond_without dietlibc # build initrd version with static glibc instead of dietlibc
5
6%define realname cryptsetup
7Summary: LUKS for dm-crypt implemented in cryptsetup
8Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup
9Name: cryptsetup-luks
10Version: 1.3.0
11Release: 1
12License: GPL v2
13Group: Base
14#Source0Download: http://code.google.com/p/cryptsetup/downloads/list
15Source0: http://cryptsetup.googlecode.com/files/%{realname}-%{version}.tar.bz2
16# Source0-md5: d2bc0fd59c1118ec3bfae099af38d333
17Source1: %{name}-initramfs-root-conf
18Source2: %{name}-initramfs-root-hook
19Source3: %{name}-initramfs-root-local-top
20Source4: %{name}-initramfs-passdev-hook
21Source5: %{name}-initramfs-README
22Patch0: %{name}-diet.patch
23Patch1: %{name}-pl.po-update.patch
24URL: http://code.google.com/p/cryptsetup/
25BuildRequires: autoconf >= 2.67
26BuildRequires: automake
27BuildRequires: device-mapper-devel >= 1.02.03
28BuildRequires: gettext-devel >= 0.15
29BuildRequires: libgcrypt-devel >= 1.1.42
30BuildRequires: libselinux-devel
31BuildRequires: libsepol-devel
32BuildRequires: libtool >= 2:2.0
33BuildRequires: libuuid-devel
34BuildRequires: popt-devel >= 1.7
35%if %{with initrd}
36BuildRequires: libgpg-error-static
37 %if %{with dietlibc}
38BuildRequires: device-mapper-dietlibc
39BuildRequires: dietlibc-static
40BuildRequires: libgcrypt-dietlibc
41BuildRequires: libuuid-dietlibc
42BuildRequires: popt-dietlibc
43 %else
44BuildRequires: device-mapper-static >= 1.02.07
45BuildRequires: libgcrypt-static >= 1.1.42
46BuildRequires: libselinux-static
47BuildRequires: libsepol-static
48BuildRequires: libuuid-static
49BuildRequires: popt-static
50 %endif
51%endif
52Requires: popt >= 1.7
53Provides: cryptsetup = %{version}
54Obsoletes: cryptsetup
55Conflicts: udev < 1:118-1
56Conflicts: udev-core < 1:115
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59%define _sbindir /sbin
60
61%description
62LUKS is the upcoming standard for Linux hard disk encryption. By
63providing a standard on-disk-format, it does not only facilitate
64compatibility among distributions, but also provide secure management
65of multiple user passwords. In contrast to existing solution, LUKS
66stores all setup necessary setup information in the partition header,
67enabling the user to transport or migrate his data seamlessly.
68
69This package contains implementation of LUKS for dm-crypt implemented
70in cryptsetup.
71
72%description -l pl.UTF-8
73LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
74Dostarczając standardowy format danych na dysku nie tylko ułatwia
75utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
76bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
77do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
78informacje o konfiguracji w nagłówku partycji, pozwalając
79użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
80
81Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
82cryptsetup.
83
84%package devel
85Summary: Header files for cryptsetup library
86Summary(pl.UTF-8): Pliki nagłówkowe biblioteki cryptsetup
87Group: Development/Libraries
88Requires: %{name} = %{version}-%{release}
89Requires: device-mapper-devel
90Requires: libgcrypt-devel >= 1.1.42
91Obsoletes: cryptsetup-devel
92
93%description devel
94Header files for cryptsetup library.
95
96%description devel -l pl.UTF-8
97Pliki nagłówkowe biblioteki cryptsetup.
98
99%package static
100Summary: Static cryptsetup library
101Summary(pl.UTF-8): Statyczna biblioteka cryptsetup
102Group: Development/Libraries
103Requires: %{name}-devel = %{version}-%{release}
104Obsoletes: cryptsetup-static
105
106%description static
107Static version of cryptsetup library.
108
109%description static -l pl.UTF-8
110Statyczna wersja biblioteki cryptsetup.
111
112%package initrd
113Summary: LUKS for dm-crypt implemented in cryptsetup - initrd version
114Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup - wersja initrd
115Group: Base
116Requires: udev-initrd >= 1:115
117Conflicts: geninitrd < 10000.10
118
119%description initrd
120This package contains implementation of LUKS for dm-crypt implemented
121in cryptsetup - statically linked for initrd.
122
123%description initrd -l pl.UTF-8
124Ten pakiet zawiera implementację LUKS dla dm-crypta zaimplementowaną
125w cryptsetup - wersję statycznie zlinkowaną dla initrd.
126
127%package initramfs
128Summary: LUKS for dm-crypt implemented in cryptsetup - support scripts for initramfs-tools
129Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup - skrypty dla initramfs-tools
130Group: Base
131Requires: %{name} = %{version}-%{release}
132Requires: initramfs-tools
133
134%description initramfs
135LUKS for dm-crypt implemented in cryptsetup - support scripts
136for initramfs-tools.
137
138%description initramfs -l pl.UTF-8
139LUKS dla dm-crypta zaimplementowany w cryptsetup - skrypty dla
140initramfs-tools.
141
142%prep
143%setup -q -n %{realname}-%{version}
144%patch0 -p1
145%patch1 -p1
146
147cp -a %{SOURCE5} README.initramfs
148
149%{__rm} po/stamp-po
150
151%build
152%{__gettextize}
153%{__libtoolize}
154%{__aclocal} -I m4
155%{__autoconf}
156%{__autoheader}
157%{__automake}
158
159%if %{with initrd}
160CC="%{__cc}"
161%configure \
162%if %{with dietlibc}
163%configure \
164 CC="diet ${CC#ccache } %{rpmcflags} %{rpmldflags} -Os" \
165 LIBS="-lcompat" \
166 ac_cv_lib_popt_poptConfigFileToString=yes \
167 ac_cv_lib_sepol_sepol_bool_set=no \
168 ac_cv_lib_selinux_is_selinux_enabled=no \
169%endif
170%if "%{?configure_cache}" == "1"
171 --cache-file=%{?configure_cache_file}%{!?configure_cache_file:configure}-initrd.cache \
172%endif
173 --disable-shared \
174 --enable-static \
175 --enable-static-cryptsetup \
176 --disable-nls
177
178%{__make} -C lib
179
180%if %{with dietlibc}
181# we have to do it by hand cause libtool "know better" and forces
182# static libs from /usr/lib
183CC="%{__cc}"
184diet ${CC#ccache } %{rpmcflags} %{rpmldflags} -Os -I. -I./lib -static \
185 -o cryptsetup-initrd src/cryptsetup.c ./lib/.libs/libcryptsetup.a \
186 -lpopt -lgcrypt -lgpg-error -ldevmapper -luuid -lcompat
187%else
188%{__make} -C src
189mv src/cryptsetup cryptsetup-initrd
190%endif
191
192%{__make} clean
193%endif
194
195%configure \
196 --enable-static
197%{__make}
198
199%install
200rm -rf $RPM_BUILD_ROOT
201install -d $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/{conf-hooks.d,hooks,scripts/local-top}
202
203%{__make} install \
204 DESTDIR=$RPM_BUILD_ROOT
205
206install -d $RPM_BUILD_ROOT/%{_lib}
207mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
208ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
209 $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
210
211%if %{with initrd}
212install -d $RPM_BUILD_ROOT%{_libdir}/initrd
213install -p cryptsetup-initrd $RPM_BUILD_ROOT%{_libdir}/initrd/cryptsetup
214%endif
215
216install -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/conf-hooks.d/cryptsetup
217install -p %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/hooks/cryptroot
218install -p %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/scripts/local-top/cryptroot
219install -p %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/initramfs-tools/hooks/cryptpassdev
220
221%find_lang %{realname}
222
223%clean
224rm -rf $RPM_BUILD_ROOT
225
226%post -p /sbin/ldconfig
227%postun -p /sbin/ldconfig
228
229%files -f %{realname}.lang
230%defattr(644,root,root,755)
231%doc AUTHORS ChangeLog TODO
232%attr(755,root,root) %{_sbindir}/cryptsetup
233%attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
234%attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.1
235%{_mandir}/man8/cryptsetup.8*
236
237%files devel
238%defattr(644,root,root,755)
239%attr(755,root,root) %{_libdir}/libcryptsetup.so
240%{_libdir}/libcryptsetup.la
241%{_includedir}/libcryptsetup.h
242%{_pkgconfigdir}/libcryptsetup.pc
243
244%files static
245%defattr(644,root,root,755)
246%{_libdir}/libcryptsetup.a
247
248%if %{with initrd}
249%files initrd
250%defattr(644,root,root,755)
251%attr(755,root,root) %{_libdir}/initrd/cryptsetup
252%endif
253
254%files initramfs
255%defattr(644,root,root,755)
256%doc README.initramfs
257%attr(755,root,root) %{_datadir}/initramfs-tools/conf-hooks.d/cryptsetup
258%attr(755,root,root) %{_datadir}/initramfs-tools/hooks/cryptroot
259%attr(755,root,root) %{_datadir}/initramfs-tools/hooks/cryptpassdev
260%attr(755,root,root) %{_datadir}/initramfs-tools/scripts/local-top/cryptroot
This page took 0.052377 seconds and 4 git commands to generate.