]> git.pld-linux.org Git - packages/clementine.git/blame_incremental - clementine.spec
Version: 1.1.1
[packages/clementine.git] / clementine.spec
... / ...
CommitLineData
1# TODO:
2# - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3# - apply patches to libprojectM.spec and use
4#
5# Conditional build:
6%bcond_without static_sqlite # with static sqlite3
7%bcond_with static_projectm # with static projectM
8
9%define qtver %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
10Summary: A music player and library organiser
11Summary(hu.UTF-8): Egy zenelejátszó és gyűjtemény-kezelő
12Name: clementine
13Version: 1.1.1
14Release: 1
15License: GPL v3 and GPL v2+
16Group: Applications/Multimedia
17URL: http://www.clementine-player.org/
18Source0: http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
19# Source0-md5: 28e4afb822388bd337a761db8f86febf
20Patch0: desktop-install.patch
21Patch1: unbundle-po.patch
22BuildRequires: QtCore-devel >= %{qtver}
23BuildRequires: QtDBus-devel >= %{qtver}
24BuildRequires: QtGui-devel >= %{qtver}
25BuildRequires: QtIOCompressor-devel
26BuildRequires: QtNetwork-devel >= %{qtver}
27BuildRequires: QtOpenGL-devel >= %{qtver}
28BuildRequires: QtSingleApplication-devel >= 2.6-4
29BuildRequires: QtSql-devel >= %{qtver}
30%{?with_tests:BuildRequires: QtTest-devel >= %{qtver}}
31BuildRequires: QtXml-devel >= %{qtver}
32BuildRequires: boost-devel
33BuildRequires: cmake >= 2.6
34#%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
35BuildRequires: gettext-devel
36%{?with_static_projectm:BuildRequires: glew-devel}
37BuildRequires: glib2-devel
38BuildRequires: gstreamer0.10-devel
39BuildRequires: gstreamer0.10-plugins-base-devel
40BuildRequires: gtest-devel
41BuildRequires: libgpod-devel >= 0.7.92
42BuildRequires: libimobiledevice-devel
43BuildRequires: libindicate-qt-devel
44BuildRequires: liblastfm-devel >= 0.3.3
45BuildRequires: libmtp-devel
46BuildRequires: libplist-devel
47%{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
48BuildRequires: libqxt-devel
49BuildRequires: libxml2-devel
50BuildRequires: pkgconfig
51BuildRequires: pkgconfig
52BuildRequires: protobuf-devel
53BuildRequires: qjson-devel
54BuildRequires: qt4-build >= %{qtver}
55BuildRequires: qt4-linguist
56BuildRequires: qt4-qmake
57BuildRequires: rpmbuild(find_lang) >= 1.33
58BuildRequires: rpmbuild(macros) >= 1.596
59BuildRequires: sed >= 4.0
60%{!?with_static_sqlite:BuildRequires: sqlite3-devel}
61BuildRequires: taglib-devel >= 1.6
62BuildRequires: usbmuxd-devel
63Requires(post,postun): desktop-file-utils
64Requires(post,postun): gtk-update-icon-cache
65Requires(post,postun): hicolor-icon-theme
66Requires: QtSingleApplication >= 2.6-4
67%{!?with_static_sqlite:Requires: QtSql-sqlite3 >= %{qtver}}
68Requires: gstreamer0.10-audio-effects-base
69# while we do not link (yet), we use datafiles
70Requires: libprojectM
71BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73# see libprojectM.spec for explanation
74%define filterout_ld -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
75
76%description
77Clementine is a modern music player and library organiser. It is
78largely a port of Amarok 1.4, with some features rewritten to take
79advantage of Qt4.
80
81%description -l hu.UTF-8
82Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
83az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
84a Qt4 előnyeit.
85
86%prep
87%setup -q -n %{name}-%{version}
88%patch0 -p1
89%patch1 -p1
90
91# We already don't use these but just to make sure
92rm -rf 3rdparty/gmock
93%{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
94rm -rf 3rdparty/qtsingleapplication
95rm -rf 3rdparty/qxt
96rm -rf 3rdparty/qtiocompressor
97%{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
98
99# Don't build tests. They require gmock
100sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
101# remove -Wall
102sed -i -e 's/-Wall//' src/CMakeLists.txt
103
104%build
105install -d build
106install -d build/src/translations
107cd build
108%cmake \
109 -DBUNDLE_PROJECTM_PRESETS=OFF \
110 -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
111 -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
112 -DUSE_SYSTEM_QXT=ON \
113 -DUSE_SYSTEM_PROJECTM=ON \
114 -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
115 ..
116%{__make}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120%{__make} -C build install \
121 DESTDIR=$RPM_BUILD_ROOT
122
123rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
124
125# not in our glibc?
126rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
127
128%find_lang %{name} --with-qm
129
130install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
131cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
132cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post
138%update_desktop_database_post
139%update_icon_cache hicolor
140
141%postun
142%update_desktop_database_postun
143%update_icon_cache hicolor
144
145%files -f %{name}.lang
146%defattr(644,root,root,755)
147%doc Changelog
148%attr(755,root,root) %{_bindir}/clementine
149%attr(755,root,root) %{_bindir}/clementine-tagreader
150%{_desktopdir}/clementine.desktop
151%{_pixmapsdir}/clementine.png
152%{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
153%{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.040545 seconds and 4 git commands to generate.