]> git.pld-linux.org Git - packages/ccmalloc.git/blame_incremental - ccmalloc.spec
- unified %clean section
[packages/ccmalloc.git] / ccmalloc.spec
... / ...
CommitLineData
1Summary: C/C++ memory debugging and profiling library
2Summary(pl.UTF-8): Biblioteka do debuggowania i profilowania obsługi pamięci w C/C++
3Name: ccmalloc
4Version: 0.3.4
5%define fnversion %(echo %{version} | tr . -)
6Release: 2
7License: GPL
8Group: Development/Debuggers
9Source0: http://www.inf.ethz.ch/personal/biere/projects/ccmalloc/%{name}-%{fnversion}.tar.gz
10# Source0-md5: ad0fb2eb9432de07f7d8de22c286a3ad
11URL: http://www.inf.ethz.ch/personal/biere/projects/ccmalloc/
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15ccmalloc detects memory leaks, multiple deallocations, over-writes,
16under-writes and access of deallocated data in C and C++ code, all
17without source recompile.
18
19It also displays statistics on allocation and deallocation.
20
21%description -l pl.UTF-8
22ccmalloc wykrywa wycieki pamięci, wielokrotne zwalnianie, zapisy
23poniżej i powyżej zaalokowanego obszaru oraz dostęp do zwolnionego
24obszaru pamięci w programach w C i C++ - bez rekompilacji.
25
26Wyświetla także statystyki alokacji i dealokacji.
27
28%prep
29%setup -q -n %{name}-%{fnversion}
30
31%build
32./configure --prefix=%{_prefix}
33
34%{__make}
35
36%install
37rm -rf $RPM_BUILD_ROOT
38install -d ${RPM_BUILD_ROOT}{%{_libdir},%{_bindir}}
39
40install lib/libccmalloc.a ${RPM_BUILD_ROOT}%{_libdir}
41install obj/ccmalloc*.o ${RPM_BUILD_ROOT}%{_libdir}
42install bin/ccmalloc ${RPM_BUILD_ROOT}%{_bindir}
43
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(644,root,root,755)
49%doc BUGS FEATURES NEWS README TODO USAGE ccmalloc.cfg
50%attr(755,root,root) %{_libdir}/*
51%attr(755,root,root) %{_bindir}/*
This page took 0.062156 seconds and 4 git commands to generate.