]> git.pld-linux.org Git - packages/carob.git/blame_incremental - carob.spec
- release 4
[packages/carob.git] / carob.spec
... / ...
CommitLineData
1%define _ver %(echo %{version} |tr . _)
2Summary: Carob library
3Summary(pl.UTF-8): Biblioteka carob
4Name: carob
5Version: 0.7.3
6Release: 4
7License: Apache License v2.0
8Group: Libraries
9Source0: https://forge.continuent.org/frs/download.php/255/%{name}-r%{_ver}.tar.gz
10# Source0-md5: f1023a5185bcc08d49d80564126a8592
11URL: http://carob.continuent.org/HomePage
12BuildRequires: gmp-devel
13BuildRequires: libstdc++-devel
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Bringing Sequoia technology to the C/C++ world.
18
19Carob's base is a C++ port of the JDBC driver code. It offers to
20developpers the same access as in Java. Connections, Requests,
21ResultSets and all necessary C++ classes can be used transparently and
22directly in any C++ enabled application.
23
24%description -l pl.UTF-8
25Przeniesienie technologii Sequoia do świata C/C++.
26
27Podstawą caroba jest port C++ kodu sterownika JDBC. Oferuje
28programistom ten sam sposób dostępu co w Javie. Połączenia, żądania,
29zbiory wyników (Connection, Request, ResultSet) i wszystkie potrzebne
30klasy C++ mogą być używane w sposób przezroczysty i bezpośredni w
31dowolnej aplikacji C++.
32
33%package devel
34Summary: Header files for carob library
35Summary(pl.UTF-8): Pliki nagłówkowe biblioteki carob
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40This is the package containing the header files for carob library.
41
42%description devel -l pl.UTF-8
43Ten pakiet zawiera pliki nagłówkowe biblioteki carob.
44
45%package static
46Summary: Static carob library
47Summary(pl.UTF-8): Statyczna biblioteka carob
48Group: Development/Libraries
49Requires: %{name}-devel = %{version}-%{release}
50
51%description static
52Static carob library.
53
54%description static -l pl.UTF-8
55Statyczna biblioteka carob.
56
57%prep
58%setup -q -n %{name}-r%{_ver}
59
60%build
61%{__make} \
62 CXX="%{__cxx}" \
63 CXXFLAGS="%{rpmcflags} -fPIC" \
64 LDFLAGS="%{rpmldflags} -lpthread"
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69install -d $RPM_BUILD_ROOT{%{_includedir}/carob,%{_libdir}}
70install libcarob.so.1 $RPM_BUILD_ROOT%{_libdir}
71install libcarob.a $RPM_BUILD_ROOT%{_libdir}
72install include/*.hpp $RPM_BUILD_ROOT%{_includedir}/carob
73ln -s libcarob.so.1 $RPM_BUILD_ROOT%{_libdir}/libcarob.so
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post -p /sbin/ldconfig
79%postun -p /sbin/ldconfig
80
81%files
82%defattr(644,root,root,755)
83%doc README
84%attr(755,root,root) %{_libdir}/libcarob.so.1
85
86%files devel
87%defattr(644,root,root,755)
88%attr(755,root,root) %{_libdir}/libcarob.so
89%{_includedir}/carob
90
91%files static
92%defattr(644,root,root,755)
93%{_libdir}/libcarob.a
This page took 0.050546 seconds and 4 git commands to generate.