]> git.pld-linux.org Git - packages/captive.git/blame_incremental - captive.spec
- updated gettext BR
[packages/captive.git] / captive.spec
... / ...
CommitLineData
1# http://gentoo-wiki.com/HOWTO_NTFS_write_with_Captive_approach
2# nice article about how to use it in gentoo, should be easy to prot to pld
3
4# please allow those bconds to remain here as next version might be gnome-vfs2 independent
5# %bcond_without vfs # disable gnome2 vfs
6Summary: Captive - NTFS read/write filesystem for Linux
7Summary(pl.UTF-8): Captive - obsługa NTFS dla Linuksa z odczytem i zapisem
8Name: captive
9Version: 1.1.7
10Release: 1
11License: GPL
12Group: Base/Kernel
13Source0: http://www.jankratochvil.net/project/captive/dist/%{name}-%{version}.tar.gz
14# Source0-md5: 34312cd854ca992f0daf0a8faabaae9a
15Patch0: %{name}-popt_link.patch
16URL: http://www.jankratochvil.net/project/captive/
17#%if %{with vfs}
18BuildRequires: gnome-vfs2-devel >= 2.0
19#%endif
20BuildRequires: autoconf
21BuildRequires: automake
22BuildRequires: gettext-tools
23BuildRequires: libfuse-devel >= 2.4.1
24BuildRequires: libtool
25BuildRequires: libxml2-devel >= 2.5.9
26BuildRequires: openssl-devel
27BuildRequires: perl-tools-pod
28BuildRequires: pkgconfig
29BuildRequires: readline-devel
30BuildRequires: rpmbuild(macros) >= 1.202
31BuildRequires: ORBit2-devel
32BuildRequires: sed >= 4.0
33Provides: group(captive)
34Provides: user(captive)
35Requires(postun): /usr/sbin/groupdel
36Requires(postun): /usr/sbin/userdel
37Requires(pre): /bin/id
38Requires(pre): /usr/bin/getgid
39Requires(pre): /usr/sbin/groupadd
40Requires(pre): /usr/sbin/useradd
41Requires: ntfsprogs >= 1.8.0
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45Captive project implements the first full read/write free access to
46NTFS disk drives. You can mount your Microsoft Windows NT, 200x or XP
47partition as a transparently accessible volume for your GNU/Linux.
48
49This compatibility was achieved in the Wine way by using the original
50Microsoft Windows ntfs.sys driver. It emulates the required subsystems
51of the Microsoft Windows kernel by reusing one of the original
52ntoskrnl.exe, ReactOS parts, or this project's own reimplementations,
53on a case by case basis. Project includes the first open source
54MS-Windows kernel API for Free operating systems. Involvement of the
55original driver files was chosen to achieve the best and unprecedented
56filesystem compatibility and safety.
57
58%description -l pl.UTF-8
59Projekt Captive implementuje pierwszy pełny, swobodny dostęp z
60odczytem i zapisem do partycji NTFS. Pozwala zamontować partycje z
61Microsoft Windows NT, 200x i XP jako dostępny w sposób przezroczysty
62wolumen pod Linuksem.
63
64Kompatybilność osiągnięto metodą Wine poprzez użycie oryginalnego
65sterownika ntfs.sys. Captive emuluje wymagane podsystemy jądra
66Microsoft Windows poprzez wykorzystanie oryginalnego ntoskrnl.exe,
67części ReactOS-a lub własne implementacje z tego projektu w zależności
68od danego przypadku. Projekt zawiera pierwsze API jądra MS-Windows z
69otwartymi źródłami dla wolnodostępnych systemów operacyjnych. Wybrano
70wykorzystanie plików oryginalnego sterownika aby osiągnąć lepszą
71kompatybilność i bezpieczeństwo.
72
73%package devel
74Summary: Header files for captive library
75Summary(pl.UTF-8): Pliki nagłówkowe biblioteki captive
76Group: Development/Libraries
77Requires: %{name} = %{version}-%{release}
78
79%description devel
80This is the package containing the header files for captive.
81
82%description devel -l pl.UTF-8
83Ten pakiet zawiera pliki nagłówkowe biblioteki captive.
84
85%package gnome
86Summary: Gnome VFS module for captive support
87Summary(pl.UTF-8): Moduł Gnome VFS z obsługą captive
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: gnome-vfs2 >= 2.0
91
92%description gnome
93Gnome VFS module for captive support.
94
95%description gnome -l pl.UTF-8
96Moduł Gnome VFS z obsługą captive.
97
98%prep
99%setup -q
100%patch0 -p1
101
102# Fix not finished moving captive-sandbox-server to libdir
103sed -i -e 's/--sandbox-server=@sbindir@/--sandbox-server=@libdir@/g' src/client/gnomevfs/captive.conf.in
104
105%build
106%{__libtoolize}
107%{__aclocal} -I macros
108%{__autoconf}
109%{__autoheader}
110%{__automake}
111%configure \
112 --enable-shared \
113 --disable-static \
114 --with-readline \
115 --disable-bug-replay \
116 --enable-lufs=no \
117 --enable-fuse=yes \
118 --disable-install-pkg \
119 --enable-sandbox-setuid=captive \
120 --enable-sandbox-setgid=captive \
121 --enable-sandbox-chroot=/var/lib/captive \
122 --enable-man-pages \
123 --enable-sbin-mountdir=/sbin \
124 --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
125 --with-orbit-line=link \
126 --with-tmpdir=/tmp
127
128%{__make}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132
133%{__make} install \
134 DESTDIR=$RPM_BUILD_ROOT
135
136rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs.la
137
138%find_lang %{name}
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%pre
144%groupadd -g 141 captive
145%useradd -u 141 -r -d /var/lib/captive -s /bin/false -c "Captive User" -g captive captive
146
147%postun
148if [ "$1" = "0" ]; then
149 %userremove captive
150 %groupremove captive
151fi
152
153%files -f %{name}.lang
154%defattr(644,root,root,755)
155%doc AUTHORS NEWS README THANKS TODO
156%attr(755,root,root) /sbin/*
157%attr(755,root,root) %{_bindir}/captive-cmdline
158#%attr(755,root,root) %{_bindir}/captive-bug-replay was here earlier.
159%attr(755,root,root) %{_libdir}/captive-sandbox-server
160%{_sysconfdir}/w32-mod-id.captivemodid.xml
161%attr(755,root,root) %{_libdir}/libcaptive-*.so
162%{_mandir}/man?/*
163%{_var}/lib/captive
164
165%files devel
166%defattr(644,root,root,755)
167%attr(755,root,root) %{_libdir}/libcaptive.so
168%{_libdir}/libcaptive.la
169%{_includedir}/captive
170
171#%if %{with vfs}
172%files gnome
173%defattr(644,root,root,755)
174%{_sysconfdir}/gnome-vfs-2.0/modules/*
175%attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs*.so
176#%endif
This page took 0.87904 seconds and 5 git commands to generate.