]> git.pld-linux.org Git - packages/busybox.git/blame_incremental - busybox.spec
- unix -> Unix
[packages/busybox.git] / busybox.spec
... / ...
CommitLineData
1# TODO:
2# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3# - make internal commands work even if busybox is not in /bin/busybox (initrd)
4# or when /proc is not mounted (static / normal)
5#
6# Conditional build:
7# alternative busybox config file (replaces default one) you should
8# define cfgfile macro, i.e.
9#
10# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11%bcond_with altconfig # use alternative config (defined by cfgfile)
12%bcond_with linkfl # creates links to busybox binary and puts them into file list
13# Options below are useful, when you want fileutils and grep providing.
14# For example, ash package requires fileutils and grep.
15%bcond_with fileutl_prov # adds fileutils providing
16%bcond_with grep_prov # adds grep providing
17# Option below is useful, when busybox is built with shell support.
18%bcond_with sh_prov # adds /bin/sh providing
19# WARNING! Shell, fileutils and grep providing may depend on config file!
20# Fileutils, grep and shell provided with busybox have not such
21# functionality as their GNU countenders.
22#
23%bcond_without static # don't build static version
24%bcond_without initrd # don't build initrd version
25%bcond_with dietlibc # build dietlibc-based initrd version
26%bcond_with glibc # build glibc-based initrd version
27#
28%ifnarch %{ix86} %{x8664} ppc sparc64
29%define with_glibc 1
30%endif
31Summary: Set of common Unix utilities for embeded systems
32Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
33Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
34Name: busybox
35Version: 1.9.0
36Release: 1
37License: GPL
38Group: Applications
39Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
40# Source0-md5: 2a6e0df1fd2a77caa541a7e8002851cb
41Source1: %{name}.config
42Source2: %{name}-initrd.config
43%{?with_altconfig:Source3: %{cfgfile}}
44Patch1: %{name}-logconsole.patch
45Patch2: %{name}-printf-gettext.patch
46Patch3: %{name}-loadfont.patch
47Patch4: %{name}-ash_exec.patch
48Patch5: %{name}-kernel_headers.patch
49Patch6: %{name}-insmod-morearchs.patch
50Patch7: %{name}-dhcp.patch
51Patch8: %{name}-fix_64_archs.patch
52Patch100: http://busybox.net/downloads/fixes-1.9.0/busybox-1.9.0-allno.patch
53Patch101: http://busybox.net/downloads/fixes-1.9.0/busybox-1.9.0-iproute.patch
54Patch102: http://busybox.net/downloads/fixes-1.9.0/busybox-1.9.0-nameif.patch
55URL: http://www.busybox.net/
56BuildRequires: gcc >= 3.2
57BuildRequires: perl-tools-pod
58BuildRequires: rpmbuild(macros) >= 1.333
59%{?with_static:BuildRequires: glibc-static}
60%if %{with initrd}
61 %if %{with dietlibc}
62BuildRequires: dietlibc-static
63 %else
64 %if %{with glibc}
65BuildRequires: glibc-static
66 %else
67%if "%{_target_base_arch}" != "%{_arch}"
68BuildRequires: cross%{_target_base_arch}-uClibc-static
69%else
70 %ifarch ppc %{x8664}
71BuildRequires: uClibc-static >= 2:0.9.29
72 %else
73BuildRequires: uClibc-static >= 2:0.9.21
74 %endif
75%endif
76 %endif
77 %endif
78%endif
79%{?with_fileutl_prov:Provides: fileutils}
80%{?with_grep_prov:Provides: grep}
81%{?with_sh_prov:Provides: /bin/sh}
82BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84%define _bindir /bin
85%define _initrd_bindir /bin
86
87%if "%{_target_base_arch}" != "%{_arch}"
88 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
89%else
90 %define CrossOpts %{nil}
91%endif
92
93%description
94BusyBox combines tiny versions of many common UNIX utilities into a
95single small executable. It provides minimalist replacements for most
96of the utilities you usually find in fileutils, shellutils, findutils,
97textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
98POSIX environment for any small or embedded system. The utilities in
99BusyBox generally have fewer options than their full-featured GNU
100cousins; however, the options that are included provide the expected
101functionality and behave very much like their GNU counterparts.
102
103BusyBox has been written with size-optimization and limited resources
104in mind. It is also extremely modular so you can easily include or
105exclude commands (or features) at compile time. This makes it easy to
106customize your embedded systems. To create a working system, just add
107a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
108ae).
109
110%description -l pl.UTF-8
111BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
112wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
113zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
114tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
115lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
116odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
117systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
118(np. elvis-tiny albo ae).
119
120%description -l pt_BR.UTF-8
121BusyBox combina versões reduzidas de muitos utilitários UNIX num único
122executável, fornecendo substitutos minimalistas para muitos dos
123executáveis encontrados em pacotes como fileutils, shellutils,
124findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
125em geral têm menos opções que os utilitários GNU, mas as opções
126implementadas comportam-se de maneira similar aos equivalentes GNU.
127
128%package static
129Summary: Static busybox
130Summary(pl.UTF-8): Statycznie skonsolidowany busybox
131Group: Applications
132
133%description static
134Static busybox.
135
136%description static -l pl.UTF-8
137Statycznie skonsolidowany busybox.
138
139%package initrd
140Summary: Static busybox for initrd
141Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
142Group: Applications
143Conflicts: geninitrd < 3075
144
145%description initrd
146Static busybox for initrd.
147
148%description initrd -l pl.UTF-8
149Statycznie skonsolidowany busybox dla initrd.
150
151%prep
152%setup -q
153%patch100 -p1
154%patch101 -p1
155%patch102 -p1
156%patch1 -p1
157%patch2 -p1
158%patch3 -p1
159%patch4 -p1
160%patch5 -p1
161%patch6 -p1
162%patch7 -p1
163%patch8 -p1
164
165%build
166install -d built
167%if %{with initrd}
168install %{SOURCE2} .config
169%{__make} oldconfig
170%{__make} \
171 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
172 LDFLAGS="%{ld_rpmldflags} -static" \
173%if %{with dietlibc}
174 LIBRARIES="-lrpc" \
175 CC="diet gcc"
176%else
177%if %{with glibc}
178 %{CrossOpts} \
179 CC="%{__cc}"
180%else
181 %if "%{_target_base_arch}" != "%{_arch}"
182 CROSS="%{_target_cpu}-uclibc-" \
183 %endif
184 CC="%{_target_cpu}-uclibc-gcc"
185%endif
186%endif
187
188mv -f busybox built/busybox.initrd
189%{__make} clean
190%endif
191
192
193%if %{with altconfig}
194install %{SOURCE3} .config
195%else
196install %{SOURCE1} .config
197%endif
198
199%if %{with static}
200%{__make} oldconfig
201%{__make} \
202 %{CrossOpts} \
203 CFLAGS_EXTRA="%{rpmcflags}" \
204 LDFLAGS="%{ld_rpmldflags} -static" \
205 CC="%{__cc}"
206mv -f busybox built/busybox.static
207%{__make} clean
208%endif
209
210%{__make} oldconfig
211%{__make} \
212 %{CrossOpts} \
213 CFLAGS_EXTRA="%{rpmcflags}" \
214 LDFLAGS="%{ld_rpmldflags}" \
215 CC="%{__cc}"
216%{__make} busybox.links docs/BusyBox.1
217
218%install
219rm -rf $RPM_BUILD_ROOT
220install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
221
222%{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
223%{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
224
225install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
226install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
227echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
228
229# install links to busybox binary, when linkfl is defined
230%if %{with linkfl}
231%{__make} install \
232 PREFIX=$RPM_BUILD_ROOT
233%else
234install busybox $RPM_BUILD_ROOT%{_bindir}
235%endif
236
237%clean
238rm -rf $RPM_BUILD_ROOT
239
240%files
241%defattr(644,root,root,755)
242%doc AUTHORS README .config
243
244%if %{with linkfl}
245%attr(755,root,root) /bin/*
246%attr(755,root,root) /sbin/*
247%attr(755,root,root) %{_bindir}/*
248%attr(755,root,root) %{_sbindir}/*
249%else
250%attr(755,root,root) %{_bindir}/busybox
251%endif
252
253%{_libdir}/busybox
254%{_mandir}/man1/*
255
256%if %{with static}
257%files static
258%defattr(644,root,root,755)
259%attr(755,root,root) %{_bindir}/busybox.static
260%endif
261
262%if %{with initrd}
263%files initrd
264%defattr(644,root,root,755)
265%attr(755,root,root) %{_initrd_bindir}/initrd-busybox
266%endif
This page took 0.188074 seconds and 4 git commands to generate.