]> git.pld-linux.org Git - packages/busybox.git/blame_incremental - busybox.spec
- rel 3 (fixed sh_name.patch)
[packages/busybox.git] / busybox.spec
... / ...
CommitLineData
1Summary: Set of common unix utils for embeded systems
2Name: busybox
3Version: 0.51
4Release: 3
5License: GPL
6Group: Applications
7Group(de): Applikationen
8Group(pl): Aplikacje
9Source0: ftp://ftp.lineo.com/pub/busybox/%{name}-%{version}.tar.gz
10Source1: %{name}-config.h
11Patch0: %{name}-logconsole.patch
12Patch1: %{name}-tee.patch
13Patch2: %{name}-sh-name.patch
14URL: http://busybox.lineo.com/
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16BuildRequires: uClibc-devel-BOOT
17
18%description
19BusyBox combines tiny versions of many common UNIX utilities into a
20single small executable. It provides minimalist replacements for most
21of the utilities you usually find in fileutils, shellutils, findutils,
22textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
23POSIX environment for any small or embedded system. The utilities in
24BusyBox generally have fewer options than their full-featured GNU
25cousins; however, the options that are included provide the expected
26functionality and behave very much like their GNU counterparts.
27
28BusyBox has been written with size-optimization and limited resources
29in mind. It is also extremely modular so you can easily include or
30exclude commands (or features) at compile time. This makes it easy to
31customize your embedded systems. To create a working system, just add
32a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
33ae).
34
35%package BOOT
36Summary: busybox for PLD bootdisk
37Group: Applications
38Group(de): Applikationen
39Group(pl): Aplikacje
40
41%description BOOT
42busybox for PLD bootdisk.
43
44%prep
45%setup -q
46%patch0
47%patch1
48%patch2 -p1
49
50%build
51# BOOT
52cp %{SOURCE1} Config.h
53%{__make} \
54 CFLAGS_EXTRA="-I%{_libdir}/bootdisk%{_includedir}" \
55 LDFLAGS="-nostdlib -s" \
56 LIBRARIES="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
57
58# TODO make main package dynamically linked
59
60%install
61rm -rf $RPM_BUILD_ROOT
62%{__install} -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1},%{_libdir}/busybox/{bin,%{_libdir}/busybox}}
63
64%{__install} busybox $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/busybox
65
66for i in `cat busybox.links`; do
67 ln -sfn busybox "$RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/`basename $i`"
68done
69%{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/bootdisk%{_libdir}/busybox
70# change sh to lash (see sh_name patch)
71mv -f $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/{sh,lash}
72
73%{__install} busybox $RPM_BUILD_ROOT%{_bindir}
74%{__install} busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
75%{__install} docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
76echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
77
78gzip -9nf AUTHORS TODO Changelog README
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(644,root,root,755)
85%doc *.gz
86%attr(755,root,root) %{_bindir}/*
87%{_libdir}/busybox
88%{_mandir}/man1/*
89
90%files BOOT
91%defattr(644,root,root,755)
92%attr(755,root,root) %{_libdir}/bootdisk/bin/*
93%{_libdir}/bootdisk%{_libdir}/*
This page took 0.290872 seconds and 4 git commands to generate.