]> git.pld-linux.org Git - packages/btsco.git/blame_incremental - btsco.spec
- now builds with kernel 2.6.21
[packages/btsco.git] / btsco.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without dist_kernel # without kernel from distribution
4%bcond_without kernel # don't build kernel modules
5%bcond_without userspace # don't build userspace utilities
6%bcond_with verbose # verbose build (V=1)
7#
8%define rel 4
9Summary: Bluetooth-alsa Project
10Summary(pl.UTF-8): Projekt Bluetooth-alsa
11Name: btsco
12Version: 0.5
13Release: %{rel}
14License: GPL
15Group: Applications/Sound
16Source0: http://dl.sourceforge.net/bluetooth-alsa/%{name}-%{version}.tgz
17# Source0-md5: d9fdd63a9e22ba839a41c8a9b89c2dda
18Patch0: %{name}-readme-pl.diff
19Patch1: %{name}-kernel.patch
20URL: http://sourceforge.net/projects/bluetooth-alsa/
21%if %{with kernel}
22%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
23%endif
24%if %{with userspace}
25BuildRequires: alsa-driver-devel >= 1.0.9-1
26BuildRequires: alsa-lib-devel >= 1.0.9-1
27BuildRequires: autoconf
28BuildRequires: automake
29BuildRequires: bluez-libs-devel >= 2.21-1
30BuildRequires: libao-devel >= 0.8.6-1
31BuildRequires: libtool
32BuildRequires: rpmbuild(macros) >= 1.379
33%endif
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37This project provides a way to use a bluetooth headset with Linux. We
38do this currently by making an alsa kernel driver which uses bluez to
39reach the headset. It works well enough now to get voice-quality audio
40to and from most headsets.
41
42%description -l pl.UTF-8
43Dzięki temu oprogramowaniu można używać zestawów słuchawkowych
44Bluetooth Headset z Linuksem. Osiągnięto to dzięki zbudowaniu alsowego
45modułu do jądra, który to używa systemu bluez do komunikacji z takim
46zestawem. Współpracuje z większością zestawów, ograniczeniem w
47komunikacji jest często urządzenie USB, które to może mieć
48nieobsługiwane częściowo protokoły, wskazówka: hciconfig hciXXX
49revision. W skrajnym wypadku można próbować użyć innego urządzenia
50USB.
51
52%package -n kernel%{_alt_kernel}-char-btsco
53Summary: Linux ALSA kernel driver for Bluetooth Headset
54Summary(pl.UTF-8): Sterownik ALSA do jądra Linuksa dla Bluetooth Headset
55Release: %{rel}@%{_kernel_ver_str}
56Group: Base/Kernel
57%{?with_dist_kernel:%requires_releq_kernel}
58Requires(post,postun): /sbin/depmod
59Requires: kernel%{_alt_kernel}-sound-alsa
60
61%description -n kernel%{_alt_kernel}-char-btsco
62Linux ALSA kernel driver for Bluetooth Headset named snd_bt_sco.
63
64%description -n kernel%{_alt_kernel}-char-btsco -l pl.UTF-8
65Sterownik ALSA do jądra Linuksa dla Bluetooth Headset o nazwie
66snd_bt_sco.
67
68%prep
69%setup -q
70%patch0 -p1
71%patch1 -p1
72
73%build
74%if %{with userspace}
75%{__aclocal}
76%{__autoconf}
77%{__autoheader}
78%{__automake}
79%configure
80
81%{__make} -Wall
82%endif
83
84%if %{with kernel}
85%build_kernel_modules -m snd-bt-sco -C kernel
86%endif
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91%if %{with userspace}
92install -d $RPM_BUILD_ROOT%{_bindir}
93
94for file in avdtp/avtest sbc/rcplay sbc/sbcenc sbc/sbcinfo a2play btsco2 btsco ; do
95 install $file $RPM_BUILD_ROOT%{_bindir}
96done
97%endif
98
99%if %{with kernel}
100%install_kernel_modules -m kernel/snd-bt-sco -d misc
101%endif
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -n kernel%{_alt_kernel}-char-btsco
107%depmod %{_kernel_ver}
108echo "after install this package, remember add lines like this:"
109echo "alias snd-card-1 snd-bt-sco"
110echo "alias sound-slot-1 snd-bt-sco"
111echo "to %{_sysconfdir}/modprobe.conf"
112
113%postun -n kernel%{_alt_kernel}-char-btsco
114%depmod %{_kernel_ver}
115
116%if %{with userspace}
117%files
118%defattr(644,root,root,755)
119%doc README README.PL.txt
120%attr(755,root,root) %{_bindir}/*
121%endif
122
123%if %{with kernel}
124%files -n kernel%{_alt_kernel}-char-btsco
125%defattr(644,root,root,755)
126/lib/modules/%{_kernel_ver}/misc/snd-bt-sco.ko.gz
127%endif
This page took 0.086406 seconds and 4 git commands to generate.