]> git.pld-linux.org Git - packages/binfmt-detector.git/blame_incremental - binfmt-detector.spec
- <= is evil, use <
[packages/binfmt-detector.git] / binfmt-detector.spec
... / ...
CommitLineData
1Summary: Microsoft PE executable type detector
2Summary(pl.UTF-8): Detector typu plików wykonywalnych PE Microsoftu
3Name: binfmt-detector
4Version: 0.2
5Release: 2
6License: GPL
7Group: Base
8Source0: http://team.pld-linux.org/~wolf/%{name}.tar.gz
9# Source0-md5: d6e9d6d8888b58c97eb65875853fd778
10Source1: %{name}.init
11BuildRequires: rpmbuild(macros) >= 1.268
12Requires(post,preun): /sbin/chkconfig
13Requires: rc-scripts
14Conflicts: wine < 1:0.9.12-2
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18This utility determines the Microsoft PE executable file's type
19(Native, .NET CLR) and runs it using the appropriate runtime (Wine,
20Mono).
21
22It is inteded to be used in a Linux binfmt configuration, since binfmt
23itself is incapable of reliably distinguishing between various PE file
24types (since they have no different "magic string") and runtimes
25refuse to run files which they don't support (CLR runtimes refuse to
26run Native images and vice versa).
27
28%description -l pl.UTF-8
29To narzędzie określa typ pliku wykonywalnego PE Microsoftu (natywny,
30.NET CLR) i uruchamia odpowiednie środowisko wykonawcze (Wine, Mono).
31
32Jest używane w połączeniu z linuksowym binfmt, ponieważ samo binfmt
33nie jest w stanie odróżnić różnych typów plików PE (nie zawierają one
34różnych "magicznych ciągów"), a środowiska uruchomieniowe nie
35pozwalają uruchomić nieobsługiwanych przez siebie plików (CLR nie
36uruchamia natywnych obrazów i vice versa).
37
38%prep
39%setup -q -n %{name}
40
41%build
42%{__cc} %{rpmcflags} binfmt-detector-cli.c -o binfmt-detector-cli
43
44%install
45rm -rf $RPM_BUILD_ROOT
46install -d $RPM_BUILD_ROOT{%{_bindir},/etc/rc.d/init.d}
47
48install binfmt-detector-cli $RPM_BUILD_ROOT%{_bindir}
49install binfmt-detector.sh $RPM_BUILD_ROOT%{_bindir}
50
51install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/binfmt-detector
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post
57/sbin/chkconfig --add binfmt-detector
58%service binfmt-detector restart
59
60%preun
61if [ "$1" = "0" ]; then
62 %service binfmt-detector stop
63 /sbin/chkconfig --del binfmt-detector
64fi
65
66%files
67%defattr(644,root,root,755)
68%doc README
69%attr(755,root,root) %{_bindir}/*
70%attr(754,root,root) /etc/rc.d/init.d/binfmt-detector
This page took 0.096621 seconds and 4 git commands to generate.