]> git.pld-linux.org Git - packages/bind.git/blame_incremental - bind.spec
- if named is chrooted then checkconf must also run chrooted
[packages/bind.git] / bind.spec
... / ...
CommitLineData
1# TODO
2# - apply http://www.caraytech.com/geodns/
3#
4# Conditional build:
5%bcond_without ssl # build without OpenSSL support
6%bcond_without ipv6 # build without IPv6 support
7%bcond_without ldap # build without LDAP support
8%bcond_without kerberos5 # build without kerneros5 support
9%bcond_without sql # build without SQL support
10%bcond_without static_libs # build without static libraries
11%bcond_without tests # perform tests
12%bcond_with edns_cli # build with the ability to use edns-client-subnet in dig
13%bcond_with hip # build with HIP RR support
14%if "%{pld_release}" == "ac"
15%bcond_with epoll # enable epoll support
16# there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17%ifarch %{x8664}
18%define with_epoll 1
19%endif
20%else
21%bcond_without epoll # disable epoll support
22%endif
23
24%define ver 9.9.2
25%if 1
26%define pverdot .P2
27%define pverdir -P2
28%else
29%define pverdot %{nil}
30%define pverdir %{nil}
31%endif
32Summary: BIND - DNS name server
33Summary(de.UTF-8): BIND - DNS-Namenserver
34Summary(es.UTF-8): BIND - Servidor de nombres DNS
35Summary(fr.UTF-8): BIND - serveur de noms DNS
36Summary(pl.UTF-8): BIND - serwer nazw DNS
37Summary(pt_BR.UTF-8): BIND - Servidor de nomes DNS
38Summary(ru.UTF-8): BIND - cервер системы доменных имен (DNS)
39Summary(tr.UTF-8): DNS alan adı sunucusu
40Summary(uk.UTF-8): BIND - cервер системи доменних імен (DNS)
41Summary(zh_CN.UTF-8): Internet 域名服务器
42Name: bind
43Version: %{ver}%{pverdot}
44Release: 1
45Epoch: 7
46License: BSD-like
47Group: Networking/Daemons
48Source0: ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49# Source0-md5: 2be7763c99b7e7b42ac3a18a267ce1aa
50Source1: named.init
51Source2: named.sysconfig
52Source3: named.logrotate
53Source4: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54# Source4-md5: 35b1dfaa12615c9802126ee833e0e7f7
55Source5: http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56# Source5-md5: 49fe799c6eca54ae227b22d57ebc1145
57Source6: %{name}-hip.tar.gz
58# Source6-md5: 62a8a67f51ff8db9fe815205416a1f62
59Source7: ftp://rs.internic.net/domain/root.zone
60# Source7-md5: 6241cd7c70f855345a68ed0697097ba5
61Source8: %{name}-127.0.0.zone
62Source9: %{name}-localhost.zone
63Source10: %{name}-named.conf
64Source11: %{name}.tmpfiles
65Source12: named.service
66Patch0: %{name}-time.patch
67Patch1: %{name}-link.patch
68Patch2: %{name}-pmake.patch
69Patch3: %{name}-sdb-ldap.patch
70Patch4: %{name}-ac-libs.patch
71Patch5: %{name}-edns-client-subnet.patch
72Patch6: nsupdate_segfault.patch
73URL: https://www.isc.org/software/bind
74BuildRequires: autoconf >= 2.59
75BuildRequires: automake
76BuildRequires: bison
77BuildRequires: flex
78%{?with_kerberos5:BuildRequires: heimdal-devel}
79BuildRequires: idnkit-devel
80BuildRequires: libtool
81%{?with_hip:BuildRequires: libxml2-devel}
82%{?with_sql:BuildRequires: mysql-devel}
83%{?with_ldap:BuildRequires: openldap-devel}
84%{?with_ssl:BuildRequires: openssl-devel >= 0.9.8d}
85%{?with_sql:BuildRequires: postgresql-devel}
86BuildRequires: readline-devel
87BuildRequires: rpm >= 4.4.9-56
88BuildRequires: rpmbuild(macros) >= 1.268
89%{?with_sql:BuildRequires: unixODBC-devel}
90Requires(post,preun): /sbin/chkconfig
91Requires(postun): /usr/sbin/groupdel
92Requires(postun): /usr/sbin/userdel
93Requires(pre): /bin/id
94Requires(pre): /usr/bin/getgid
95Requires(pre): /usr/sbin/groupadd
96Requires(pre): /usr/sbin/useradd
97Requires(pre): fileutils
98Requires: %{name}-libs = %{epoch}:%{version}-%{release}
99Requires: psmisc >= 20.1
100Requires: rc-scripts >= 0.2.0
101Requires: uname(release) >= 2.2.18
102Provides: group(named)
103Provides: nameserver
104Provides: user(named)
105Obsoletes: caching-nameserver
106Conflicts: %{name}-chroot
107Conflicts: logrotate < 3.8.0
108BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110%define schemadir /usr/share/openldap/schema
111
112%description
113BIND (Berkeley Internet Name Domain) is an implementation of the DNS
114(Domain Name System) protocols. BIND includes a DNS server (named),
115which resolves host names to IP addresses, and a resolver library
116(routines for applications to use when interfacing with DNS). A DNS
117server allows clients to name resources or objects and share the
118information with other network machines. The named DNS server can be
119used on workstations as a caching name server, but is generally only
120needed on one machine for an entire network. Note that the
121configuration files for making BIND act as a simple caching nameserver
122are included in the caching-nameserver package.
123
124Install the bind package if you need a DNS server for your network. If
125you want bind to act a caching name server, you will also need to
126install the caching-nameserver package.
127
128%description -l de.UTF-8
129Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
130IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
131caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
132Recher des Netzwerks erforderlich.
133
134%description -l es.UTF-8
135Incluye el servidor de nombres (DNS), que se usa para traducir nombres
136para IP (y viceversa). Puede ser usado en estaciones de trabajo como
137un servidor de nombres caché, pero generalmente sólo hace falta en una
138máquina para toda la red.
139
140%description -l fr.UTF-8
141Contient le serveur de noms named, utilisé pour définir les
142traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
143utilisé sur les stations de travail comme serveur de nom en cache mais
144n'est souvent nécessaire que sur une machine pour un réseau entier.
145
146%description -l pl.UTF-8
147Pakiet ten zawiera demona named, który służy do zmieniania nazw
148komputerów na numery IP i odwrotnie. Może być on używany na stacjach
149roboczych jako bufor odwołań do serwisu nazw (caching name server),
150ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
151program na fragment sieci.
152
153%description -l pt_BR.UTF-8
154Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
155IP (e vice-versa). Pode ser usado em estações de trabalho como um
156servidor de nomes cache, mas geralmente só é necessário em uma máquina
157para toda a rede.
158
159%description -l ru.UTF-8
160BIND (Berkeley Internet Name Domain) является реализацией протоколов
161DNS (Domain Name System). BIND включает DNS сервер (named) и
162библиотеку "резолвера" (подпрограммы для приложений, через которые
163происходят обращения к DNS). DNS сервер named может быть использован
164на рабочих станциях как кеширующий сервер, но обычно запускается на
165одной машине в локальной сети и используется остальными машинами (этим
166достигается намного более эффективное кеширование).
167
168Конфигурационные файлы, настраивающие BIND на работу в режиме простого
169кеширующего сервера, включены в пакет caching-nameserver.
170
171%description -l tr.UTF-8
172Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
173kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
174isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
175için sadece bir makina üzerinde kurulur.
176
177%description -l uk.UTF-8
178BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
179(Domain Name System). BIND включає DNS сервер (named) та бібліотеку
180"резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
181сервер named може бути використаний на робочих станціях як кешируючий
182сервер, але звичайно запускається на одній машині в локальній мережі і
183використовується іншими (цим досягається більша ефективність
184використання кешу).
185
186Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
187кешируючого серверу, включені в пакет caching-nameserver.
188
189%package utils
190Summary: DNS utils - host, dig, dnsquery, nslookup
191Summary(de.UTF-8): DNS-Utils - Host, Dig, Dnsquery, Nslookup
192Summary(es.UTF-8): Utilitarios DNS - host, dig, dnsquery y nslookup
193Summary(fr.UTF-8): Utilitaires DNS - host, dig, dnsquery, nslookup
194Summary(pl.UTF-8): Narzędzia DNS - host, dig, dnsquery, nslookup
195Summary(pt_BR.UTF-8): Utilitários DNS - host, dig, dnsquery e nslookup
196Summary(ru.UTF-8): Утилиты для посылки запросов к серверам DNS
197Summary(tr.UTF-8): DNS araçları - host, dig, dnsquery, nslookup
198Summary(uk.UTF-8): Утиліти для надсилання запитів до серверів DNS
199Summary(zh_CN.UTF-8): Internet 域名服务器实用工具
200Group: Networking/Utilities
201Requires: %{name}-libs = %{epoch}:%{version}-%{release}
202Requires: iconv
203
204%description utils
205Bind-utils contains a collection of utilities for querying DNS (Domain
206Name Service) name servers to find out information about Internet
207hosts. These tools will provide you with the IP addresses for given
208host names, as well as other information about registered domains and
209network addresses.
210
211You should install bind-utils if you need to get information from DNS
212name servers.
213
214%description utils -l de.UTF-8
215Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
216Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
217Informationen über registrierte Domains und Netzwerk-Adressen.
218
219%description utils -l es.UTF-8
220Conjunto de utilitarios para consulta a servidores de nombres. Estas
221herramientas permiten la determinación de direcciones IP para nombres
222de máquinas informados y busca información sobre dominios registrados
223y direcciones de red.
224
225%description utils -l fr.UTF-8
226Ensemble d'utilitaires pour interroger les serveurs de noms et
227rechercher des hôtes. Ces outils vous permettent de déterminer les
228adresses IP pour des noms d'hôtes donnés, et trouver des informations
229sur les noms de domaine déclarés et les adresses réseau.
230
231%description utils -l pl.UTF-8
232Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
233serwerów nazw z innych domen w celu uzyskania informacji o komputerach
234i ich adresach IP.
235
236%description utils -l pt_BR.UTF-8
237Conjunto de utilitários para consulta a servidores DNS. Estas
238ferramentas permitem a determinação de endereços IP para nomes de
239máquinas informados e busca informações sobre domínios registrados e
240endereços de rede. Você deveria instalar este pacote se necessitar
241obter informações de servidores DNS.
242
243%description utils -l ru.UTF-8
244Набор утилит для генерации запросов к серверам имен (DNS) и поиска
245адресов машин. Эти утилиты позволяют определить IP-адрес по известному
246доменному имени (и наоборот) и другую информацию о зарегистрированных
247доменах и сетевых адресах.
248
249%description utils -l tr.UTF-8
250Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
251için kullanılan araçlar bulunmaktadır.
252
253%description utils -l uk.UTF-8
254Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
255адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
256доменним іменем та навпаки, а також іншу інформацію про зареєстровані
257домени та адреси.
258
259%package libs
260Summary: DNS libraries
261Summary(pl.UTF-8): Biblioteki DNS
262Summary(ru.UTF-8): Библиотеки, необходимые для bind
263Summary(uk.UTF-8): Бібліотеки, необхідні для bind
264Summary(zh_CN.UTF-8): Internet 域名服务器开发库
265Group: Libraries
266
267%description libs
268The bind-libs package contains all libraries required for running BIND
269and bind utils.
270
271%description libs -l pl.UTF-8
272Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
273lub programów z pakietu bind-utils.
274
275%description libs -l ru.UTF-8
276Библиотеки, необходимые для работы bind.
277
278%description libs -l uk.UTF-8
279Бібліотеки, необхідні для роботи bind.
280
281%package devel
282Summary: DNS development includes
283Summary(es.UTF-8): Archivos de inclusión y bibliotecas para desarrollo DNS
284Summary(pl.UTF-8): Pliki nagłówkowe bibliotek DNS
285Summary(pt_BR.UTF-8): Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
286Summary(ru.UTF-8): Хедеры и библиотеки разработчика для bind
287Summary(uk.UTF-8): Хедери та бібліотеки програміста для bind
288Group: Development/Libraries
289Requires: %{name}-libs = %{epoch}:%{version}-%{release}
290
291%description devel
292The bind-devel package contains all the include files and symlinks
293required for DNS (Domain Name Service) development for BIND.
294
295You should install bind-devel if you want to develop bind DNS
296applications. If you install bind-devel, you'll also need to install
297bind-libs.
298
299%description devel -l es.UTF-8
300Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
301para el bind.
302
303%description devel -l pl.UTF-8
304Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
305binda, lub kompilował kod źródłowy oprogramowania korzystającego z
306tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
307pakiet.
308
309%description devel -l pt_BR.UTF-8
310Todos os arquivos de cabeçalho e bibliotecas necessários para o
311desenvolvimento com o bind.
312
313%description devel -l ru.UTF-8
314Все хедеры и библиотеки, необходимые для написания программ с
315использованием BIND 9.x.x.
316
317%description devel -l uk.UTF-8
318Всі хедери та бібліотеки, необхідні для розробки програм з
319використанням BIND 9.x.x.
320
321%package static
322Summary: DNS static libs
323Summary(pl.UTF-8): Biblioteki statyczne DNS
324Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento DNS
325Summary(ru.UTF-8): Статические библиотеки разработчика для bind
326Summary(uk.UTF-8): Статичні бібліотеки програміста для bind
327Group: Development/Libraries
328Requires: %{name}-devel = %{epoch}:%{version}-%{release}
329
330%description static
331Static bind libraries.
332
333%description static -l pl.UTF-8
334Statyczne biblioteki binda.
335
336%description static -l pt_BR.UTF-8
337Bibliotecas estáticas para desenvolvimento DNS.
338
339%description static -l ru.UTF-8
340Статические библиотеки, необходимые для написания программ с
341использованием BIND.
342
343%description static -l uk.UTF-8
344Статичні бібліотеки, необхідні для розробки програм з використанням
345BIND.
346
347%package -n openldap-schema-bind
348Summary: BIND schema for openldap
349Summary(pl.UTF-8): Schemat BIND dla openldap
350Group: Development/Libraries
351Requires(post,postun): sed >= 4.0
352Requires: openldap-servers
353Requires: sed >= 4.0
354
355%description -n openldap-schema-bind
356BIND schema for openldap.
357
358%description -n openldap-schema-bind -l pl.UTF-8
359Schemat BIND dla openldap.
360
361%prep
362%setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
363%patch0 -p1
364%patch1 -p1
365%patch2 -p1
366%{?with_ldap:%patch3 -p1}
367%patch4 -p1
368%{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
369%patch6 -p0
370
371%{?with_edns_cli:%patch5 -p0}
372
373%build
374%{__libtoolize}
375%{__aclocal}
376%{__autoconf}
377cp -f /usr/share/automake/config.* .
378%configure \
379 CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
380 --with-idn \
381 --with-libtool \
382 %{?with_ssl:--with-openssl} \
383 %{?with_ipv6:--enable-ipv6} \
384 %{?with_kerberos5:--with-gssapi} \
385 %{?with_sql:--with-dlz-postgres=yes} \
386 %{?with_sql:--with-dlz-mysql=yes} \
387 --with-dlz-bdb=no \
388 --with-dlz-filesystem=yes \
389 %{?with_ldap:--with-dlz-ldap=yes} \
390 --with-dlz-odbc=no \
391 --with-dlz-stub=yes \
392 --enable-largefile \
393 %{!?with_epoll:--disable-epoll --disable-devpoll} \
394 %{!?with_static_libs:--enable-static=no} \
395 --enable-threads \
396 --enable-getifaddrs
397
398%{__make}
399%{?with_hip:cd bind-hip/; %{__make}}
400
401%{?with_tests:%{__make} test}
402
403%install
404rm -rf $RPM_BUILD_ROOT
405install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
406 $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
407 $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
408 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
409
410%{__make} install \
411 DESTDIR=$RPM_BUILD_ROOT
412
413bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
414mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
415%{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
416
417cp -p bin/tests/named.conf EXAMPLE-CONFIG-named
418cp -p bin/tests/ndc.conf EXAMPLE-CONFIG-ndc
419install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/named
420cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/named
421cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/named
422cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
423cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
424cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
425cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
426mv $RPM_BUILD_ROOT/etc/bind.keys $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
427
428ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
429ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
430ln -sf %{_var}/lib/named/named.log $RPM_BUILD_ROOT%{_var}/log/named
431ln -sf %{_var}/lib/named/named.stats $RPM_BUILD_ROOT%{_var}/log/named.stats
432
433touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
434
435install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
436install %{SOURCE11} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
437
438%if %{with ldap}
439install -d $RPM_BUILD_ROOT%{schemadir}
440cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
441%endif
442
443%{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
444
445rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
446echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
447
448# let rpm generate deps (workaround -m644 used for libs installation)
449chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
450
451# we don't want Makefiles in documentation...
452rm -rf _doc
453cp -a doc _doc
454rm -f _doc/misc/Makefile*
455
456%clean
457rm -rf $RPM_BUILD_ROOT
458
459%pre
460if [ -f %{_sysconfdir}/named.boot ]; then
461 cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
462 mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
463 echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
464fi
465%groupadd -g 58 named
466%useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
467
468%post
469/sbin/chkconfig --add named
470%service named restart
471
472%preun
473if [ "$1" = "0" ]; then
474 %service named stop
475 /sbin/chkconfig --del named
476fi
477
478%postun
479if [ "$1" = "0" ]; then
480 %userremove named
481 %groupremove named
482fi
483
484%post libs -p /sbin/ldconfig
485%postun libs -p /sbin/ldconfig
486
487%post -n openldap-schema-bind
488%openldap_schema_register %{schemadir}/dnszone.schema
489%service -q ldap restart
490
491%postun -n openldap-schema-bind
492if [ "$1" = "0" ]; then
493 %openldap_schema_unregister %{schemadir}/dnszone.schema
494 %service -q ldap restart
495fi
496
497%triggerpostun -- %{name} < 7:9.4.2-2
498/sbin/chkconfig named reset
499%{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
500%{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
501%{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
502
503%files
504%defattr(644,root,root,755)
505%doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
506%doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
507
508%attr(754,root,root) /etc/rc.d/init.d/named
509%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
510%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
511%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
512%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
513
514%attr(755,root,root) %{_sbindir}/arpaname
515%attr(755,root,root) %{_sbindir}/ddns-confgen
516%attr(755,root,root) %{_sbindir}/dnssec-*
517%attr(755,root,root) %{_sbindir}/genrandom
518%attr(755,root,root) %{_sbindir}/isc-hmac-fixup
519%attr(755,root,root) %{_sbindir}/lwresd
520%attr(755,root,root) %{_sbindir}/named
521%attr(755,root,root) %{_sbindir}/named-*
522%attr(755,root,root) %{_sbindir}/nsec3hash
523%attr(755,root,root) %{_sbindir}/rndc
524%attr(755,root,root) %{_sbindir}/rndc-confgen
525
526%{_mandir}/man1/arpaname.1*
527%{_mandir}/man5/named.conf.5*
528%{_mandir}/man5/rndc.conf.5*
529%{_mandir}/man8/ddns-confgen.8*
530%{_mandir}/man8/dnssec-*.8*
531%{_mandir}/man8/genrandom.8*
532%{_mandir}/man8/isc-hmac-fixup.8*
533%{_mandir}/man8/lwresd.8*
534%{_mandir}/man8/named.8*
535%{_mandir}/man8/named-*.8*
536%{_mandir}/man8/nsec3hash.8*
537%{_mandir}/man8/rndc.8*
538%{_mandir}/man8/rndc-confgen.8*
539%lang(ja) %{_mandir}/ja/man8/named*
540
541/usr/lib/tmpfiles.d/%{name}.conf
542
543%attr(770,root,named) %dir %{_var}/lib/named
544%attr(770,root,named) %dir %{_var}/lib/named/D
545%attr(750,root,named) %dir %{_var}/lib/named/M
546%attr(770,root,named) %dir %{_var}/lib/named/S
547%attr(750,root,named) %dir %{_var}/lib/named/etc
548%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
549%attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
550%config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
551%config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
552%attr(660,named,named) %ghost %{_var}/lib/named/named.log
553%attr(660,named,named) %ghost %{_var}/lib/named/named.stats
554
555%attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
556%attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
557
558%attr(770,root,named) %dir %{_var}/run/named
559%attr(770,root,named) %dir %{_var}/run/lwresd
560
561%files utils
562%defattr(644,root,root,755)
563%attr(755,root,root) %{_bindir}/dig
564%attr(755,root,root) %{_bindir}/host
565%attr(755,root,root) %{_bindir}/nslookup
566%attr(755,root,root) %{_bindir}/nsupdate
567%{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
568%{_mandir}/man1/dig.1*
569%{_mandir}/man1/host.1*
570%{_mandir}/man1/nslookup.1*
571%{_mandir}/man1/nsupdate.1*
572
573%lang(fi) %{_mandir}/fi/man1/host.1*
574
575%lang(fr) %{_mandir}/fr/man1/host.1*
576
577%lang(hu) %{_mandir}/hu/man1/host.1*
578
579%lang(ja) %{_mandir}/ja/man1/dig.1*
580%lang(ja) %{_mandir}/ja/man1/host.1*
581%lang(ja) %{_mandir}/ja/man1/nslookup.1*
582%lang(ja) %{_mandir}/ja/man8/nsupdate.8*
583
584%lang(pl) %{_mandir}/pl/man1/host.1*
585
586%files libs
587%defattr(644,root,root,755)
588%attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
589%attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
590%attr(755,root,root) %{_libdir}/libdns.so.*.*.*
591%attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
592%attr(755,root,root) %{_libdir}/libisc.so.*.*.*
593%attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
594%attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
595%attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
596%attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
597%attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
598%attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
599%attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
600
601%files devel
602%defattr(644,root,root,755)
603%attr(755,root,root) %{_bindir}/isc-config.sh
604%attr(755,root,root) %{_libdir}/libbind9.so
605%attr(755,root,root) %{_libdir}/libdns.so
606%attr(755,root,root) %{_libdir}/libisc.so
607%attr(755,root,root) %{_libdir}/libisccc.so
608%attr(755,root,root) %{_libdir}/libisccfg.so
609%attr(755,root,root) %{_libdir}/liblwres.so
610%{_libdir}/libbind9.la
611%{_libdir}/libdns.la
612%{_libdir}/libisc.la
613%{_libdir}/libisccc.la
614%{_libdir}/libisccfg.la
615%{_libdir}/liblwres.la
616%{_includedir}/bind9
617%{_includedir}/dns
618%{_includedir}/dst
619%{_includedir}/isc
620%{_includedir}/isccc
621%{_includedir}/isccfg
622%{_includedir}/lwres
623%{_mandir}/man1/isc-config.sh.1*
624%{_mandir}/man3/lwres*.3*
625
626%if %{with static_libs}
627%files static
628%defattr(644,root,root,755)
629%{_libdir}/libbind9.a
630%{_libdir}/libdns.a
631%{_libdir}/libisc.a
632%{_libdir}/libisccc.a
633%{_libdir}/libisccfg.a
634%{_libdir}/liblwres.a
635%endif
636
637%if %{with ldap}
638%files -n openldap-schema-bind
639%defattr(644,root,root,755)
640%{_datadir}/openldap/schema/dnszone.schema
641%endif
This page took 0.032242 seconds and 4 git commands to generate.