]> git.pld-linux.org Git - packages/beecrypt.git/blame_incremental - beecrypt.spec
do not try to use 32bit arm asm on 64bit arm
[packages/beecrypt.git] / beecrypt.spec
... / ...
CommitLineData
1#
2# WARNING: despite unchanged SONAME, the RSA ABI (and API) has changed since 3.x!
3#
4# Conditional build:
5%bcond_without java # build with Java support
6%bcond_with javac # use javac instead of gcj
7%bcond_without python # don't build python module
8%bcond_without static_libs # don't build static libraries
9#
10Summary: The BeeCrypt Cryptography Library
11Summary(pl.UTF-8): Biblioteka kryptograficzna BeeCrypt
12Name: beecrypt
13Version: 4.2.1
14Release: 7
15Epoch: 2
16License: LGPL v2.1+
17Group: Libraries
18Source0: http://dl.sourceforge.net/project/beecrypt/beecrypt/%{version}/%{name}-%{version}.tar.gz
19# Source0-md5: 8441c014170823f2dff97e33df55af1e
20Patch0: %{name}-ac.patch
21Patch1: %{name}-ac_python.patch
22Patch2: %{name}-armv8.patch
23URL: http://sourceforge.net/projects/beecrypt/
24BuildRequires: autoconf >= 2.50
25BuildRequires: automake
26%if %{with java} && !%{with javac}
27%ifarch i586 i686 athlon pentium3 pentium4 %{x8664}
28BuildRequires: jdk
29%else
30BuildRequires: gcc-java
31BuildRequires: libgcj-devel
32%endif
33%endif
34%if %{with java} && %{with javac}
35BuildRequires: jdk
36%endif
37BuildRequires: libtool
38%if %{with python}
39BuildRequires: python-devel
40BuildRequires: python-modules
41BuildRequires: rpm-pythonprov
42%endif
43BuildRequires: rpmbuild(macros) >= 1.213
44Obsoletes: beecrypt-doc
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%define specflags_alpha -mno-explicit-relocs
48%define specflags_pentium2 -mmmx
49%define specflags_pentium3 -mmmx -msse
50%define specflags_pentium4 -mmmx -msse -msse2
51%define specflags_athlon -mmmx
52
53%description
54BeeCrypt is an open source cryptography library that contains highly
55optimized C and assembler implementations of many well-known
56algorithms including Blowfish, MD5, SHA-1, Diffie-Hellman, and
57ElGamal.
58
59%description -l pl.UTF-8
60BeeCrypt jest open sourcową biblioteką, która zawiera wysoko
61zoptymailzowane funkcje w C oraz assemblerze wielu algorytmów
62szyfrowania m.in.: Blowfish, MD5, SHA-1, Diffie-Hellman oraz ElGamal.
63
64%package devel
65Summary: The BeeCrypt Cryptography Library - development files
66Summary(pl.UTF-8): Pliki dla programistów używających biblioteki BeeCrypt
67Group: Development/Libraries
68Requires: %{name} = %{epoch}:%{version}-%{release}
69
70%description devel
71The BeeCrypt Cryptography Library - development files.
72
73%description devel -l pl.UTF-8
74Biblioteka kryptograficzna BeeCrypt - pliki dla programistów.
75
76%package static
77Summary: The BeeCrypt Cryptography Library - static library
78Summary(pl.UTF-8): Biblioteka statyczna BeeCrypt
79Group: Development/Libraries
80Requires: %{name}-devel = %{epoch}:%{version}-%{release}
81
82%description static
83The BeeCrypt Cryptography Library - static library.
84
85%description static -l pl.UTF-8
86Biblioteka statyczna BeeCrypt.
87
88%package java
89Summary: BeeCrypt Java glue library
90Summary(pl.UTF-8): Biblioteka łącząca BeeCrypt z Javą
91Group: Libraries
92Requires: %{name} = %{epoch}:%{version}-%{release}
93
94%description java
95BeeCrypt Java glue library.
96
97%description java -l pl.UTF-8
98Biblioteka łącząca BeeCrypt z Javą.
99
100%package java-devel
101Summary: Development files for BeeCrypt Java glue library
102Summary(pl.UTF-8): Pliki programistyczne biblioteki łączącej Beecrypt z Javą
103Group: Development/Libraries
104Requires: %{name}-devel = %{epoch}:%{version}-%{release}
105Requires: %{name}-java = %{epoch}:%{version}-%{release}
106
107%description java-devel
108Development files for BeeCrypt Java glue library.
109
110%description java-devel -l pl.UTF-8
111Pliki programistyczne biblioteki łączącej Beecrypt z Javą.
112
113%package java-static
114Summary: BeeCrypt Java glue static library
115Summary(pl.UTF-8): Statyczna biblioteka łącząca BeeCrypt z Javą
116Group: Development/Libraries
117Requires: %{name}-java-devel = %{epoch}:%{version}-%{release}
118
119%description java-static
120BeeCrypt Java glue static library.
121
122%description java-static -l pl.UTF-8
123Statyczna biblioteka łącząca BeeCrypt z Javą.
124
125%package -n python-beecrypt
126Summary: Python interface to BeeCrypt library
127Summary(pl.UTF-8): Pythonowy interfejs do biblioteki BeeCrypt
128Group: Development/Languages/Python
129Requires: %{name} = %{epoch}:%{version}-%{release}
130%pyrequires_eq python-libs
131
132%description -n python-beecrypt
133The python-beecrypt package contains a module which permits
134applications written in the Python programming language to use the
135interface supplied by BeeCrypt libraries.
136
137%description -n python-beecrypt -l pl.UTF-8
138Pakiet python-beecrypt zawiera moduł, który pozwala aplikacjom
139napisanym w Pythonie na używanie interfejsu dostarczanego przez
140bibliotekę BeeCrytp.
141
142%prep
143%setup -q
144%patch0 -p1
145%patch1 -p1
146%patch2 -p1
147
148# --with-cplusplus or building (even empty) *.cxx into libbeecrypt
149# makes it (and thus rpm) depending on libstdc++ which is unacceptable
150%{__perl} -pi -e 's/ cppglue\.cxx$//' Makefile.am
151
152%build
153%{__libtoolize}
154%{__aclocal}
155%{__autoconf}
156%{__autoheader}
157%{__automake}
158%configure \
159 --disable-openmp \
160 %{?with_javac:ac_cv_have_gcj=no} \
161 %{!?with_static_libs:--disable-static} \
162 --without-cplusplus \
163 --with%{!?with_java:out}-java \
164 %{!?with_python:--without-python}
165
166%{__make}
167
168%install
169rm -rf $RPM_BUILD_ROOT
170install -d $RPM_BUILD_ROOT/%{_lib}
171
172%{__make} install \
173 DESTDIR=$RPM_BUILD_ROOT
174
175mv -f $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.so.* $RPM_BUILD_ROOT/%{_lib}
176ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libbeecrypt.so.*.*.*) \
177 $RPM_BUILD_ROOT%{_libdir}/libbeecrypt.so
178
179%{?with_python:%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}}
180
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184%post -p /sbin/ldconfig
185%postun -p /sbin/ldconfig
186
187%post java -p /sbin/ldconfig
188%postun java -p /sbin/ldconfig
189
190%files
191%defattr(644,root,root,755)
192%doc AUTHORS BENCHMARKS BUGS CONTRIBUTORS NEWS README
193%attr(755,root,root) /%{_lib}/libbeecrypt.so.*.*.*
194%attr(755,root,root) %ghost /%{_lib}/libbeecrypt.so.7
195
196%files devel
197%defattr(644,root,root,755)
198%attr(755,root,root) %{_libdir}/libbeecrypt.so
199%{_libdir}/libbeecrypt.la
200%{_includedir}/beecrypt
201
202%if %{with static_libs}
203%files static
204%defattr(644,root,root,755)
205%{_libdir}/libbeecrypt.a
206%endif
207
208%if %{with java}
209%files java
210%defattr(644,root,root,755)
211%attr(755,root,root) %{_libdir}/libbeecrypt_java.so.*.*.*
212%attr(755,root,root) %ghost %{_libdir}/libbeecrypt_java.so.7
213
214%files java-devel
215%defattr(644,root,root,755)
216%attr(755,root,root) %{_libdir}/libbeecrypt_java.so
217%{_libdir}/libbeecrypt_java.la
218
219%if %{with static_libs}
220%files java-static
221%defattr(644,root,root,755)
222%{_libdir}/libbeecrypt_java.a
223%endif
224%endif
225
226%if %{with python}
227%files -n python-beecrypt
228%defattr(644,root,root,755)
229%attr(755,root,root) %{py_sitedir}/_bc.so
230%endif
This page took 0.061993 seconds and 5 git commands to generate.