]> git.pld-linux.org Git - packages/balsa.git/blame_incremental - balsa.spec
- updated gettext BR
[packages/balsa.git] / balsa.spec
... / ...
CommitLineData
1# TODO:
2# - use webkit as html widget?
3#
4# Conditional build:
5%bcond_without ldap # build without LDAP support
6%bcond_with gpgme # build with GPG support (experimental)
7%bcond_without esmtp # build without ESMTP support
8%bcond_without gtkhtml # build without HTML support
9%bcond_without gtkhtml2 # build with libgtkhtml-2 (default gtkhtml-4)
10%bcond_with compface # build with Compface
11%bcond_with gtksourceview # build with GtkSourceView
12%bcond_without gtkspell # build without GtkSpell
13%bcond_with sqlite # build with SQLite for GPE address books
14
15Summary: Balsa Mail Client
16Summary(es.UTF-8): Balsa es un lector de e-mail
17Summary(pl.UTF-8): Balsa - klient poczty
18Summary(pt_BR.UTF-8): Balsa é um leitor de e-mail
19Name: balsa
20Version: 2.4.10
21Release: 2
22License: GPL v3+
23Group: X11/Applications
24Source0: http://pawsa.fedorapeople.org/balsa/%{name}-%{version}.tar.bz2
25# Source0-md5: fa2b7cb9d248912ac2e3dcc08cd6aa5b
26Patch0: %{name}-desktop.patch
27Patch1: %{name}-gtkhtml4.patch
28URL: http://balsa.gnome.org/
29BuildRequires: ORBit2-devel >= 1:2.12.4
30BuildRequires: aspell-devel >= 2:0.50
31BuildRequires: autoconf >= 2.52
32BuildRequires: automake
33%{?with_compface:BuildRequires: compface-devel}
34BuildRequires: docbook-dtd412-xml
35BuildRequires: gettext-tools
36BuildRequires: glib2-devel >= 2.6.4-1
37BuildRequires: gmime-devel >= 2.4.0
38BuildRequires: gnome-doc-utils
39BuildRequires: gnome-icon-theme
40%{?with_gpgme:BuildRequires: gpgme-devel >= 1:0.9.0}
41BuildRequires: gtk+2-devel >= 2:2.10.0
42%{?with_gtksourceview:BuildRequires: gtksourceview-devel}
43%{?with_gtkspell:BuildRequires: gtkspell-devel}
44BuildRequires: heimdal-devel
45BuildRequires: intltool
46%{?with_esmtp:BuildRequires: libesmtp-devel >= 1.0.4}
47%if %{with gtkhtml}
48%{!?with_gtkhtml2:BuildRequires: gtkhtml-devel >= 4.0}
49%{?with_gtkhtml2:BuildRequires: libgtkhtml-devel >= 2.0}
50%endif
51BuildRequires: libgnomeui-devel >= 2.3.3.1-2
52BuildRequires: libltdl-devel
53BuildRequires: libnotify-devel
54BuildRequires: libtool
55BuildRequires: libunique-devel
56%{?with_ldap:BuildRequires: openldap-devel >= 2.4.6}
57BuildRequires: openssl-devel >= 0.9.7d
58BuildRequires: pcre-devel >= 3.0
59BuildRequires: pkgconfig
60BuildRequires: rpmbuild(macros) >= 1.197
61BuildRequires: scrollkeeper >= 0.1.4
62# actually, it requires sqlite >= 2.8
63%{?with_sqlite:BuildRequires: sqlite3-devel}
64%{?with_gpgme:Requires: gpgme >= 1:0.9.0}
65Requires(post,postun): scrollkeeper
66# sr@Latn vs. sr@latin
67Conflicts: glibc-misc < 6:2.7
68BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70%description
71Balsa is an e-mail reader. This client is part of the GNOME desktop
72environment. It supports local mailboxes, POP3 and IMAP.
73
74%description -l es.UTF-8
75Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
76cajas de correo electrónico locales, POP3 y IMAP.
77
78%description -l pl.UTF-8
79Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
80IMAP oraz lokalne skrzynki pocztowe.
81
82%description -l pt_BR.UTF-8
83Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
84Suporta caixas de correio locais, POP3 a IMAP.
85
86%prep
87%setup -q
88%patch0 -p1
89%{!?with_gtkhtml2:%patch1 -p1}
90
91%build
92%{__libtoolize}
93%{__aclocal}
94%{__autoconf}
95%{__autoheader}
96%{__autoconf}
97%configure \
98 --with-gss \
99 --with-ssl \
100 --with-unique \
101 --disable-silent-rules \
102 %{!?with_esmtp:--without-esmtp} \
103%if %{with gtkhtml}
104 --with-html-widget=%{?with_gtkhtml2:gtkhtml2}%{!?with_gtkhtml2:gtkhtml4} \
105%else
106 --disable-gtkhtml \
107%endif
108 %{?with_gpgme:--with-gpgme} \
109 %{?with_compface:--with-compface} \
110 %{?with_gtksourceview:--with-gtksourceview} \
111 %{?with_gtkspell:--with-gtkspell} \
112 %{?with_sqlite:--with-sqlite} \
113 %{?with_ldap:--with-ldap}
114%{__make}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119%{__make} install \
120 DESTDIR=$RPM_BUILD_ROOT
121
122[ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
123 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
124%find_lang %{name} --with-gnome --all-name
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130%scrollkeeper_update_post
131
132%postun
133%scrollkeeper_update_postun
134
135%files -f %{name}.lang
136%defattr(644,root,root,755)
137%doc AUTHORS ChangeLog NEWS README TODO
138%attr(755,root,root) %{_bindir}/balsa
139%attr(755,root,root) %{_bindir}/balsa-ab
140%dir %{_sysconfdir}/sound/events
141%{_sysconfdir}/sound/events/balsa.soundlist
142%{_datadir}/%{name}
143%{_datadir}/sounds/%{name}
144%{_mandir}/man1/balsa.1*
145%{_omf_dest_dir}/%{name}
146%{_desktopdir}/balsa.desktop
147%{_pixmapsdir}/gnome-balsa2.png
148%{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.073395 seconds and 5 git commands to generate.