]> git.pld-linux.org Git - packages/apache-mod_ruby.git/blame_incremental - apache-mod_ruby.spec
- fix config dir
[packages/apache-mod_ruby.git] / apache-mod_ruby.spec
... / ...
CommitLineData
1# TODO:
2# - make it work with ruby 1.9, currently any request -> Sig11
3%define mod_name mod_ruby
4%define apxs /usr/sbin/apxs
5Summary: Apache mod_ruby module - embeds the Ruby interpreter into the Apache web server
6Summary(pl.UTF-8): Moduł Apache'a mod_ruby - zapewniający obsługę skryptów rubego przez serwer Apache
7Name: apache-%{mod_name}
8Version: 1.3.0
9Release: 1.1
10License: BSD-like
11Group: Networking/Daemons/HTTP
12Source0: http://www.modruby.net/archive/%{mod_name}-%{version}.tar.gz
13# Source0-md5: 5aae358c3c9f1bfa2554da9242289ab7
14Source1: %{name}.conf
15Patch0: %{name}-struct.patch
16URL: http://www.modruby.net/
17BuildRequires: %{apxs}
18BuildRequires: apache-devel >= 2.0
19BuildRequires: rpmbuild(macros) >= 1.268
20BuildRequires: ruby-devel >= 1:1.6.4
21Requires: apache(modules-api) = %apache_modules_api
22Requires: ruby >= 1:1.6.4
23%{?ruby_mod_ver_requires_eq}
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
28
29%description
30mod_ruby embeds the Ruby interpreter into the Apache web server,
31allowing Ruby CGI scripts to be executed natively. These scripts will
32start up much faster than without mod_ruby.
33
34%description -l pl.UTF-8
35mod_ruby zapewnia obsługę skryptów Ruby'ego bezpośrednio z poziomu
36Apache'a, dzięki czemu będą się one ładowały znacznie szybciej niż
37gdyby były wywoływane tradycyjnie.
38
39%prep
40%setup -q -n %{mod_name}-%{version}
41%patch0 -p1
42
43%build
44./configure.rb \
45 --with-apr-includes='/usr/include/apr -I/usr/include/apr-util'\
46 --with-apxs=%{apxs}
47%{__make}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{ruby_rubylibdir}}
52install -p %{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/%{mod_name}.so
53cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/70_mod_%{mod_name}.conf
54cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
55
56%clean
57rm -rf $RPM_BUILD_ROOT
58
59%post
60%service -q httpd restart
61
62%postun
63if [ "$1" = "0" ]; then
64 %service -q httpd restart
65fi
66
67%files
68%defattr(644,root,root,755)
69%doc COPYING ChangeLog README.en examples doc/*
70%lang(ja) %doc README.ja
71%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
72%attr(755,root,root) %{_pkglibdir}/*.so
73%{ruby_rubylibdir}/*
This page took 0.033087 seconds and 5 git commands to generate.