]> git.pld-linux.org Git - packages/apache-mod_clamav.git/blame_incremental - apache-mod_clamav.spec
Release 8 (by relup.sh)
[packages/apache-mod_clamav.git] / apache-mod_clamav.spec
... / ...
CommitLineData
1%define apxs /usr/sbin/apxs
2%define mod_name clamav
3Summary: An Apache virus scanning filter
4Summary(pl.UTF-8): Filtr skanera antywirusowego dla Apache'a
5Name: apache-mod_%{mod_name}
6Version: 0.23
7Release: 8
8License: GPL v2
9Group: Networking/Daemons/HTTP
10Source0: http://software.othello.ch/mod_clamav/mod_%{mod_name}-%{version}.tar.gz
11# Source0-md5: 32c7b285dfdff5d13371b92ebe73b352
12Source1: %{name}.conf
13Patch0: %{name}-clamav.patch
14Patch1: gcc10.patch
15URL: http://software.othello.ch/mod_clamav/
16BuildRequires: %{apxs}
17BuildRequires: apache-devel >= 2.0
18BuildRequires: apr-devel >= 1:1.0
19BuildRequires: apr-util-devel >= 1:1.0
20BuildRequires: autoconf >= 2.12
21BuildRequires: automake
22BuildRequires: clamav-devel
23BuildRequires: libtool
24BuildRequires: pkgconfig
25BuildRequires: rpmbuild(macros) >= 1.268
26Requires: apache(modules-api) = %apache_modules_api
27Requires: apache-mod_proxy
28Requires: clamav
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
33
34%description
35mod_clamav is an Apache 2 filter which scans the content delivered by
36the proxy module (mod_proxy) for viruses using the Clamav virus
37scanning engine.
38
39%description -l pl.UTF-8
40mod_clamav to filtr dla serwera Apache 2 skanujący treści dostarczane
41przez moduł proxy (mod_proxy) pod kątem wirusów przy użyciu silnika
42skanera antywirusowego Clamav.
43
44%prep
45%setup -q -n mod_%{mod_name}-%{version}
46%patch0 -p1
47%patch1 -p1
48
49%build
50%{__libtoolize}
51%{__aclocal}
52%{__autoconf}
53%{__automake}
54CPPFLAGS="-I$(/usr/bin/apr-1-config --includedir) -I$(/usr/bin/apu-1-config --includedir) $(pkg-config --cflags libclamav)"
55%configure \
56 --with-apxs=%{apxs}
57%{__make}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
62
63install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
64install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/32_mod_clamav.conf
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%post
70%service -q httpd restart
71
72%postun
73if [ "$1" = "0" ]; then
74 %service -q httpd restart
75fi
76
77%files
78%defattr(644,root,root,755)
79%doc AUTHORS ChangeLog mod_clamav.html NEWS README TODO
80%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_clamav.conf
81%attr(755,root,root) %{_pkglibdir}/mod_clamav.so
This page took 0.082788 seconds and 5 git commands to generate.