]> git.pld-linux.org Git - packages/anubis.git/blame_incremental - anubis.spec
- openssl support is gone, enable gnutls by default
[packages/anubis.git] / anubis.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without gnutls # TLS support using GnuTLS library
4%bcond_without gpgme # signing/encrypting with gnupg using gpgme library
5%bcond_without pam # PAM authentication
6%bcond_without pcre # PCRE library support
7%bcond_without tcp_wrappers # tcp_wrappers for access control
8%bcond_with mysql # MySQL support
9%bcond_with pgsql # PostgreSQL support
10#
11Summary: An outgoing mail processor, and the SMTP tunnel
12Summary(pl.UTF-8): Procesor wychodzącej poczty i tunel SMTP
13Name: anubis
14Version: 4.3
15Release: 1
16License: GPL v3+
17Group: Applications/Mail
18Source0: https://ftp.gnu.org/gnu/anubis/%{name}-%{version}.tar.bz2
19# Source0-md5: 32dc9adf1d0daa54bff70f10b4e289b5
20Source1: %{name}.init
21Source2: %{name}.pamd
22Patch0: %{name}-info.patch
23Patch1: %{name}-nolibnsl.patch
24Patch2: %{name}-pl.po-update.patch
25URL: http://www.gnu.org/software/anubis/
26BuildRequires: autoconf >= 2.64
27BuildRequires: automake >= 1:1.16
28BuildRequires: bison
29BuildRequires: flex
30BuildRequires: gdbm-devel
31BuildRequires: gettext-tools >= 0.21
32%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
33%{?with_gpgme:BuildRequires: gpgme-devel >= 1:1.0.0}
34BuildRequires: gsasl-devel >= 0.2.3
35BuildRequires: guile-devel >= 5:2.2.0
36BuildRequires: libgcrypt-devel >= 1.7.0
37%{?with_tcp_wrappers:BuildRequires: libwrap-devel}
38%{?with_mysql:BuildRequires: mysql-devel}
39%{?with_pam:BuildRequires: pam-devel}
40BuildRequires: pcre-devel
41%{?with_pgsql:BuildRequires: postgresql-devel}
42BuildRequires: rpm-perlprov
43BuildRequires: rpmbuild(macros) >= 1.268
44BuildRequires: texinfo
45Requires(post,preun): /sbin/chkconfig
46Requires: identserver
47Requires: libgcrypt >= 1.7.0
48Requires: pam >= 0.77.3
49Requires: rc-scripts
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53GNU Anubis is an outgoing mail processor. It goes between the MUA
54(Mail User Agent) and the MTA (Mail Transport Agent), and can perform
55on the fly various sorts of processing and conversion on the outgoing
56mail in accord with the sender's specified rules, based on a highly
57configurable regular expressions system. It operates as a proxy
58server, independently from mail user agents. GNU Anubis can edit
59outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
60Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
61using the TLS/SSL encryption even if your mail user agent doesn't
62support it, or tunnel a connection through a SOCKS proxy. Moreover,
63GNU Anubis supports the remailers (it allows sending mail in an
64anonymous way).
65
66Remember, that to use per-user configuration files ident server has to
67be running. Without it only system-wide configuration file is used.
68
69If you want to use GNU Anubis with mutt mail client, install msg2smtp
70package.
71
72%description -l pl.UTF-8
73GNU Anubis zajmuje się przetwarzaniem poczty wychodzącej. Znajduje się
74on pomiędzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i może
75wykonywać w locie różne rodzaje przetwarzania i konwersji poczty
76wychodzącej zależnie od podanych reguł, bazujących na wysoce
77konfigurowalnym systemie wyrażeń regularnych. GNU Anubis działa jako
78serwer proxy, niezależnie od programów pocztowych. Potrafi on zmieniać
79nagłówki listów, szyfrować lub podpisywać jest przy pomocy GNU Privacy
80Guard, tworzyć bezpieczne tunele SMTP używając szyfrowania TLS/SSL
81nawet, gdy Twój program pocztowy nie ma takich możliwości. Możliwe
82jest też tunelowanie połączeń przez SOCKS proxy. Co więcej, GNU Anubis
83wspiera także remailery (czyli pozawala na anonimowe wysyłanie
84poczty).
85
86Pamiętaj, że aby używać plików konfiguracyjnych użytkowników, serwer
87ident musi być aktywny. Inaczej, użyty będzie tylko główny plik
88konfiguracyjny.
89
90Jeśli chcesz używać GNU Anubis z klientem poczty mutt, zainstaluj
91pakiet msg2smtp.
92
93%package -n msg2smtp
94Summary: msg2smtp takes mail at input and relays it to an SMTP server
95Summary(pl.UTF-8): msg2smtp wysyła pocztę przyjmowaną na wejściu do serwera SMTP
96Group: Applications/Mail
97
98%description -n msg2smtp
99The msg2smtp script is a bridge between MUA programs which use
100"sendmail" command to send mail (such as Mutt) and smtp servers. It is
101particularly useful when used in connection with GNU Anubis mail
102processor.
103
104%description -n msg2smtp -l pl.UTF-8
105Skrypt msg2smtp jest pomostem między programami pocztowymi używającymi
106polecenia "sendmail" do wysyłania listów (np. Mutt), a serwerem smtp.
107Jest on szczególnie przydatny w połączeniu z procesorem poczty GNU
108Anubis.
109
110%prep
111%setup -q
112%patch0 -p1
113%patch1 -p1
114%patch2 -p1
115
116%{__rm} po/stamp-po
117
118%build
119%{__gettextize}
120%{__aclocal} -I m4 -I am -I gint -I doc/imprimatur
121%{__autoconf}
122%{__autoheader}
123%{__automake}
124%configure \
125 --disable-dependency-tracking \
126 --disable-silent-rules \
127 %{!?with_gnutls:--without-gnutls} \
128 %{!?with_gpgme:--without-gpgme} \
129 %{?with_mysql:--with-mysql} \
130 %{?with_pam:--with-pam} \
131 %{?with_pcre:--with-pcre} \
132 %{?with_pgsql:--with-postgres} \
133 %{?with_tcp_wrappers:--with-tcp-wrappers}
134
135%{__make}
136
137%install
138rm -rf $RPM_BUILD_ROOT
139install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
140
141%{__make} install \
142 DESTDIR=$RPM_BUILD_ROOT
143
144install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
145install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
146cp -p ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
147%{?with_pam:cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
148cp -pf ./examples/1anubisrc examples/anubisrc
149
150rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
151
152%find_lang %{name}
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%post
158/sbin/chkconfig --add anubis
159%service anubis restart
160[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
161
162
163%preun
164if [ "$1" = "0" ]; then
165 %service anubis stop
166 /sbin/chkconfig --del anubis
167fi
168
169%postun -p /sbin/postshell
170-/usr/sbin/fix-info-dir -c %{_infodir}
171
172%files -f %{name}.lang
173%defattr(644,root,root,755)
174%doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc %{?with_pam:examples/pam}
175%attr(754,root,root) /etc/rc.d/init.d/anubis
176%attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/anubisrc
177%if %{with pam}
178%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/anubis
179%endif
180%if %{with gnutls}
181%attr(755,root,root) %{_bindir}/anubisusr
182%endif
183%attr(755,root,root) %{_sbindir}/anubis
184%attr(755,root,root) %{_sbindir}/anubisadm
185%{_datadir}/anubis
186%{_mandir}/man1/anubis.1*
187%{_infodir}/anubis.info*
188
189%files -n msg2smtp
190%defattr(644,root,root,755)
191%doc contrib/msg2smtp.txt
192%attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.035832 seconds and 5 git commands to generate.