]> git.pld-linux.org Git - packages/amarok.git/blame_incremental - amarok.spec
- updated to 1.3-beta1
[packages/amarok.git] / amarok.spec
... / ...
CommitLineData
1#
2# TODO:
3# * postgresql support alongside mysql
4# * NMM, MAS audio backend support
5# * make descriptions less useless
6#
7# Conditional builds:
8%bcond_without arts # disable arts engine
9%bcond_without gstreamer # disable gstreamer
10%bcond_without xine # disable xine engine
11%bcond_without xmms # disable xmms wrapping
12%bcond_without zeroconf # disbale suport for zeroconf
13%bcond_with mysql # enable mysql support
14#
15%define _beta beta1
16Summary: A KDE audio player
17Summary(pl): Odtwarzacz audio dla KDE
18Name: amarok
19Version: 1.3
20Release: 0.%{_beta}.1
21License: GPL
22Group: X11/Applications/Multimedia
23Source0: http://dl.sourceforge.net/amarok/%{name}-%{version}-beta1.tar.bz2
24# Source0-md5: d270fd69f58d3f4ba1c0d7ff4c520f5a
25Patch0: kde-common-gcc4.patch
26URL: http://amarok.kde.org/
27BuildRequires: SDL-devel
28BuildRequires: alsa-lib-devel
29BuildRequires: arts-qt-devel
30BuildRequires: automake
31%{?with_gstreamer:BuildRequires: gstreamer-plugins-devel >= 0.8.1}
32BuildRequires: kdebase-devel
33BuildRequires: kdemultimedia-akode
34BuildRequires: kdemultimedia-devel >= 9:3.1.93
35BuildRequires: libmusicbrainz-devel
36BuildRequires: libvisual-devel >= 0.2.0
37BuildRequires: pcre-devel
38BuildRequires: rpmbuild(macros) >= 1.129
39BuildRequires: sed >= 4.0
40BuildRequires: sqlite3-devel
41BuildRequires: taglib-devel >= 1.3.1
42#BuildRequires: unsermake >= 040511
43%{?with_xine:BuildRequires: xine-lib-devel >= 2:1.0-0.rc5.0}
44%{?with_xmms:BuildRequires: xmms-devel}
45%{?with_mysql:BuildRequires: mysql-devel}
46#BuildRequires: kdebindings-kjsembed-devel
47Requires: %{name}-plugin = %{version}-%{release}
48Requires: kdebase-core >= 9:3.1.93
49Requires: kdemultimedia-audiocd >= 9:3.1.93
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53A KDE audio player.
54
55%description -l pl
56Odtwarzacz audio dla KDE.
57
58%package arts
59Summary: Plugin arts
60Summary(pl): Wtyczka arts
61Group: X11/Applications/Multimedia
62Requires: %{name} = %{version}-%{release}
63Provides: %{name}-plugin = %{version}-%{release}
64
65%description arts
66Plugin arts.
67
68%description arts -l pl
69Wtyczka arts.
70
71
72%package akode
73Summary: Plugin akode
74Summary(pl): Wtyczka akode
75Group: X11/Applications/Multimedia
76Requires: %{name} = %{version}-%{release}
77Provides: %{name}-plugin = %{version}-%{release}
78
79%description akode
80Plugin akode.
81
82%description akode -l pl
83Wtyczka akode.
84
85
86%package gstreamer
87Summary: Plugin gstreamer
88Summary(pl): Wtyczka gstreamer
89Group: X11/Applications/Multimedia
90# needed libs
91# at least /usr/lib/gstreamer-0.8/libgstresample.so
92# probably /usr/lib/gstreamer-0.8/libgstadder.so
93# and probably /usr/lib/gstreamer-0.8/libgstvolume.so
94Requires: gstreamer-audio-effects
95Requires: %{name} = %{version}-%{release}
96Provides: %{name}-plugin = %{version}-%{release}
97
98%description gstreamer
99Plugin gstreamer.
100
101%description gstreamer -l pl
102Wtyczka gstreamer.
103
104%package xine
105Summary: Plugin xine
106Summary(pl): Wtyczka xine
107Group: X11/Applications/Multimedia
108Requires: %{name} = %{version}-%{release}
109Provides: %{name}-plugin = %{version}-%{release}
110
111%description xine
112Plugin xine.
113
114%description xine -l pl
115Wtyczka xine.
116
117%package zeroconf
118Summary: Zeroconf data
119Summary(pl): Dane dla zeroconf
120Group: X11/Applications/Multimedia
121Requires: %{name} = %{version}-%{release}
122Requires: kdenetwork-kdnssd
123Provides: %{name}-plugin = %{version}-%{release}
124
125%description zeroconf
126Zeroconf data.
127
128%description zeroconf -l pl
129Zeroconf data.
130
131
132%prep
133%setup -q -n %{name}-%{version}-%{_beta}
134%patch0 -p1
135%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
136 amarok/src/amarok.desktop \
137
138%build
139cp -f /usr/share/automake/config.sub admin
140
141#export UNSERMAKE=/usr/share/unsermake/unsermake
142
143%{__make} -f admin/Makefile.common cvs
144
145%configure \
146 --disable-rpath \
147 %{!?with_arts:--without-arts} \
148 %{!?with_xine:--without-xine} \
149 %{!?with_gstreamer:--without-gstreamer} \
150 %{?with_mysql:--with-mysql} \
151 --disable-final \
152 --with-qt-libraries=%{_libdir} \
153 --without-included-sqlite
154
155%{__make}
156
157%install
158rm -rf $RPM_BUILD_ROOT
159
160%{__make} install \
161 DESTDIR=$RPM_BUILD_ROOT \
162 kde_htmldir=%{_kdedocdir} \
163 kde_libs_htmldir=%{_kdedocdir}
164
165# remove bogus dir
166rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
167
168#find_lang amarok --all-name --with-kde
169
170%clean
171rm -rf $RPM_BUILD_ROOT
172
173%post
174echo "Remember to install libvisual-plugins-* packages if you"
175echo "want to have a visualizations in amarok."
176
177%files
178%defattr(644,root,root,755)
179# -f %{name}.lang
180%defattr(644,root,root,755)
181%doc amarok/AUTHORS amarok/ChangeLog amarok/README amarok/TODO
182%attr(755,root,root) %{_bindir}/amarok
183%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
184%attr(755,root,root) %{_bindir}/amarokapp
185%attr(755,root,root) %{_bindir}/amarok_libvisual
186#%attr(755,root,root) %{_bindir}/release_amarok
187%{_libdir}/kde3/konqsidebar_universalamarok.la
188%attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
189%{_libdir}/kde3/libamarok_void-engine_plugin.la
190%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
191%{_datadir}/apps/amarok
192%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
193%{_datadir}/apps/konqsidebartng/add/amarok.desktop
194%{_datadir}/apps/konqsidebartng/entries/amarok.desktop
195%{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
196%{_datadir}/apps/profiles/amarok.profile.xml
197%{_datadir}/config/amarokrc
198%{_datadir}/config.kcfg/amarok.kcfg
199%{_datadir}/services/amarok_void-engine_plugin.desktop
200%{_datadir}/servicetypes/amarok_plugin.desktop
201%{_desktopdir}/kde/amarok.desktop
202%{_iconsdir}/*/*/apps/amarok.*
203
204%if %{with arts}
205%files arts
206%defattr(644,root,root,755)
207%{_libdir}/kde3/libamarok_artsengine_plugin.la
208%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
209%{_libdir}/libamarokarts.la
210%attr(755,root,root) %{_libdir}/libamarokarts.so
211%{_libdir}/mcop/Amarok
212%{_libdir}/mcop/amarokarts.mcopclass
213%{_libdir}/mcop/amarokarts.mcoptype
214%{_datadir}/services/amarok_artsengine_plugin.desktop
215%endif
216
217%files akode
218%defattr(644,root,root,755)
219%{_libdir}/kde3/libamarok_aKode-engine.la
220%attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
221%{_datadir}/services/amarok_aKode-engine.desktop
222
223%if %{with gstreamer}
224%files gstreamer
225%defattr(644,root,root,755)
226%{_libdir}/kde3/libamarok_gstengine_plugin.la
227%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
228%{_datadir}/config.kcfg/gstconfig.kcfg
229%{_datadir}/services/amarok_gstengine_plugin.desktop
230%endif
231
232%if %{with xine}
233%files xine
234%defattr(644,root,root,755)
235%{_libdir}/kde3/libamarok_xine-engine.la
236%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
237%{_datadir}/services/amarok_xine-engine.desktop
238#%{_datadir}/services/amarok_xineengine_plugin.desktop
239%endif
240
241%if %{with zeroconf}
242%files zeroconf
243%defattr(644,root,root,755)
244%{_datadir}/apps/zeroconf/_shoutcast._tcp
245%endif
This page took 0.033188 seconds and 4 git commands to generate.