]> git.pld-linux.org Git - packages/amarok.git/blame_incremental - amarok.spec
- add xinecfg.kcfg to xine package
[packages/amarok.git] / amarok.spec
... / ...
CommitLineData
1#
2# TODO:
3# * postgresql support alongside mysql
4# * NMM, MAS audio backend support
5# * make descriptions less useless
6# * HelixPlayer engine?
7#
8# Conditional builds:
9%bcond_without arts # disable arts engine
10%bcond_without gstreamer # disable gstreamer
11%bcond_without mas # disable MAS audio backend
12%bcond_without xine # disable xine engine
13%bcond_without xmms # disable xmms wrapping
14%bcond_without zeroconf # disable suport for zeroconf
15%bcond_with helixplayer # enable HelixPlayer engine
16%bcond_with nmm # enable NMM audio backend
17%bcond_with mysql # enable mysql support
18%bcond_with akode # enable aKode engine (too buggy/incomplete)
19#
20%define _beta beta3
21Summary: A KDE audio player
22Summary(pl): Odtwarzacz audio dla KDE
23Name: amarok
24Version: 1.3
25Release: 0.%{_beta}.2
26License: GPL
27Group: X11/Applications/Multimedia
28Source0: http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
29# Source0-md5: e6587bcdd3dc9a811d40d00b89e13ceb
30Patch0: kde-common-gcc4.patch
31URL: http://amarok.kde.org/
32BuildRequires: SDL-devel
33BuildRequires: alsa-lib-devel
34BuildRequires: arts-qt-devel
35BuildRequires: automake
36%{?with_gstreamer:BuildRequires: gstreamer-plugins-devel >= 0.8.1}
37BuildRequires: kdebase-devel
38%{?with_akode:BuildRequires: kdemultimedia-akode}
39BuildRequires: kdemultimedia-devel >= 9:3.1.93
40BuildRequires: libltdl-devel
41BuildRequires: libmusicbrainz-devel
42BuildRequires: libvisual-devel >= 0.2.0
43BuildRequires: pcre-devel
44BuildRequires: rpmbuild(macros) >= 1.129
45BuildRequires: sed >= 4.0
46BuildRequires: sqlite3-devel
47BuildRequires: taglib-devel >= 1.4
48#BuildRequires: unsermake >= 040511
49%{?with_xine:BuildRequires: xine-lib-devel >= 2:1.0-0.rc5.0}
50%{?with_xmms:BuildRequires: xmms-devel}
51%{?with_mysql:BuildRequires: mysql-devel}
52#BuildRequires: kdebindings-kjsembed-devel
53Requires: %{name}-plugin = %{version}-%{release}
54Requires: kdebase-core >= 9:3.1.93
55Requires: kdemultimedia-audiocd >= 9:3.1.93
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58%description
59A KDE audio player.
60
61%description -l pl
62Odtwarzacz audio dla KDE.
63
64%package arts
65Summary: Plugin arts
66Summary(pl): Wtyczka arts
67Group: X11/Applications/Multimedia
68PreReq: %{name} = %{version}-%{release}
69Provides: %{name}-plugin = %{version}-%{release}
70
71%description arts
72Plugin arts.
73
74%description arts -l pl
75Wtyczka arts.
76
77%package akode
78Summary: Plugin akode
79Summary(pl): Wtyczka akode
80Group: X11/Applications/Multimedia
81PreReq: %{name} = %{version}-%{release}
82Provides: %{name}-plugin = %{version}-%{release}
83
84%description akode
85Plugin akode.
86
87%description akode -l pl
88Wtyczka akode.
89
90%package gstreamer
91Summary: Plugin gstreamer
92Summary(pl): Wtyczka gstreamer
93Group: X11/Applications/Multimedia
94PreReq: %{name} = %{version}-%{release}
95# needed libs
96# at least /usr/lib/gstreamer-0.8/libgstresample.so
97# probably /usr/lib/gstreamer-0.8/libgstadder.so
98# and probably /usr/lib/gstreamer-0.8/libgstvolume.so
99Requires: gstreamer-audio-effects
100Provides: %{name}-plugin = %{version}-%{release}
101
102%description gstreamer
103Plugin gstreamer.
104
105%description gstreamer -l pl
106Wtyczka gstreamer.
107
108%package xine
109Summary: Plugin xine
110Summary(pl): Wtyczka xine
111Group: X11/Applications/Multimedia
112PreReq: %{name} = %{version}-%{release}
113Provides: %{name}-plugin = %{version}-%{release}
114
115%description xine
116Plugin xine.
117
118%description xine -l pl
119Wtyczka xine.
120
121%package zeroconf
122Summary: Zeroconf data
123Summary(pl): Dane dla zeroconf
124Group: X11/Applications/Multimedia
125PreReq: %{name} = %{version}-%{release}
126Requires: kdenetwork-kdnssd
127Provides: %{name}-plugin = %{version}-%{release}
128
129%description zeroconf
130Zeroconf data.
131
132%description zeroconf -l pl
133Zeroconf data.
134
135%prep
136%setup -q -n %{name}-%{version}-%{_beta}
137%patch0 -p1
138%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
139 amarok/src/amarok.desktop \
140
141%build
142cp -f /usr/share/automake/config.sub admin
143
144#export UNSERMAKE=/usr/share/unsermake/unsermake
145
146%{__make} -f admin/Makefile.common cvs
147
148%configure \
149 --disable-rpath \
150 %{!?with_arts:--without-arts} \
151 %{!?with_mas:--with-mas} \
152 %{!?with_xine:--without-xine} \
153 %{!?with_gstreamer:--without-gstreamer} \
154 %{!?with_akode:--without-akode} \
155 %{?with_helix:--with-helix} \
156 %{?with_mysql:--with-mysql} \
157 --disable-final \
158 --with-qt-libraries=%{_libdir} \
159 --without-included-sqlite
160
161%{__make}
162
163%install
164rm -rf $RPM_BUILD_ROOT
165
166%{__make} install \
167 DESTDIR=$RPM_BUILD_ROOT \
168 kde_htmldir=%{_kdedocdir} \
169 kde_libs_htmldir=%{_kdedocdir}
170
171# remove bogus dir
172rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
173
174%find_lang amarok --all-name --with-kde
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post
180echo "Remember to install libvisual-plugins-* packages if you"
181echo "want to have a visualizations in amarok."
182
183%files -f %{name}.lang
184%defattr(644,root,root,755)
185%doc AUTHORS ChangeLog README TODO
186%attr(755,root,root) %{_bindir}/amarok
187%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
188%attr(755,root,root) %{_bindir}/amarokapp
189%attr(755,root,root) %{_bindir}/amarok_libvisual
190#%attr(755,root,root) %{_bindir}/release_amarok
191%{_libdir}/kde3/konqsidebar_universalamarok.la
192%attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
193%{_libdir}/kde3/libamarok_void-engine_plugin.la
194%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
195%{_datadir}/apps/amarok
196%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
197%{_datadir}/apps/konqsidebartng/add/amarok.desktop
198%{_datadir}/apps/konqsidebartng/entries/amarok.desktop
199%{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
200%{_datadir}/apps/profiles/amarok.profile.xml
201%{_datadir}/config/amarokrc
202%{_datadir}/config.kcfg/amarok.kcfg
203%{_datadir}/services/amarok_void-engine_plugin.desktop
204%{_datadir}/servicetypes/amarok_plugin.desktop
205%{_desktopdir}/kde/amarok.desktop
206%{_iconsdir}/*/*/apps/amarok.*
207
208%if %{with arts}
209%files arts
210%defattr(644,root,root,755)
211%{_libdir}/kde3/libamarok_artsengine_plugin.la
212%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
213%{_libdir}/libamarokarts.la
214%attr(755,root,root) %{_libdir}/libamarokarts.so
215%{_libdir}/mcop/Amarok
216%{_libdir}/mcop/amarokarts.mcopclass
217%{_libdir}/mcop/amarokarts.mcoptype
218%{_datadir}/services/amarok_artsengine_plugin.desktop
219%endif
220
221%if %{with akode}
222%files akode
223%defattr(644,root,root,755)
224%{_libdir}/kde3/libamarok_aKode-engine.la
225%attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
226%{_datadir}/services/amarok_aKode-engine.desktop
227%endif
228
229%if %{with gstreamer}
230%files gstreamer
231%defattr(644,root,root,755)
232%{_libdir}/kde3/libamarok_gstengine_plugin.la
233%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
234%{_datadir}/config.kcfg/gstconfig.kcfg
235%{_datadir}/services/amarok_gstengine_plugin.desktop
236%endif
237
238%if %{with xine}
239%files xine
240%defattr(644,root,root,755)
241%{_libdir}/kde3/libamarok_xine-engine.la
242%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
243%{_datadir}/config.kcfg/xinecfg.kcfg
244%{_datadir}/services/amarok_xine-engine.desktop
245#%{_datadir}/services/amarok_xineengine_plugin.desktop
246%endif
247
248%if %{with zeroconf}
249%files zeroconf
250%defattr(644,root,root,755)
251%{_datadir}/apps/zeroconf/_shoutcast._tcp
252%endif
This page took 0.026111 seconds and 4 git commands to generate.